aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Fish <gentoo@seaofdirac.net>2019-07-25 20:39:26 +0200
committerNicholas Fish <gentoo@seaofdirac.net>2019-07-25 20:39:26 +0200
commita14f869f0e6dc7837d44222ebf5e97fc698c6611 (patch)
treec8d5413b3a7db996960b6ba44c7585420fa74749 /gui-apps/mako/mako-9999.ebuild
parentnet-wireless/broadcom-sta: patch for removed get_ds() function from Linux 5.1+ (diff)
downloadennui-a14f869f0e6dc7837d44222ebf5e97fc698c6611.tar.gz
ennui-a14f869f0e6dc7837d44222ebf5e97fc698c6611.tar.bz2
ennui-a14f869f0e6dc7837d44222ebf5e97fc698c6611.zip
gui-wm/mako: add without D-Bus dependency
Signed-off-by: Nicholas Fish <gentoo@seaofdirac.net>
Diffstat (limited to 'gui-apps/mako/mako-9999.ebuild')
-rw-r--r--gui-apps/mako/mako-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/gui-apps/mako/mako-9999.ebuild b/gui-apps/mako/mako-9999.ebuild
new file mode 100644
index 0000000..60eca46
--- /dev/null
+++ b/gui-apps/mako/mako-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway."
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+icons"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ sys-apps/systemd
+ sys-auth/elogind
+ )
+ sys-apps/dbus[user-session]
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ app-text/scdoc
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}