aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/weston/files/weston-1.9.0-make-error-portable.patch')
-rw-r--r--dev-libs/weston/files/weston-1.9.0-make-error-portable.patch40
1 files changed, 18 insertions, 22 deletions
diff --git a/dev-libs/weston/files/weston-1.9.0-make-error-portable.patch b/dev-libs/weston/files/weston-1.9.0-make-error-portable.patch
index b1d2932..508ddbd 100644
--- a/dev-libs/weston/files/weston-1.9.0-make-error-portable.patch
+++ b/dev-libs/weston/files/weston-1.9.0-make-error-portable.patch
@@ -1,11 +1,10 @@
# Eliminate calls to error()/error.h, which are GNU extensions, not POSIX in order to compile with musl
# See https://patchwork.freedesktop.org/patch/50793/
-diff --git a/configure.ac b/configure.ac
-index 263fc22..f52cd62 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -57,6 +57,8 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
+diff -Naur weston-1.9.0.orig/configure.ac weston-1.9.0/configure.ac
+--- weston-1.9.0.orig/configure.ac 2015-09-22 01:11:26.000000000 +0000
++++ weston-1.9.0/configure.ac 2016-01-01 21:20:54.097472570 +0000
+@@ -57,6 +57,8 @@
[[#include <time.h>]])
AC_CHECK_HEADERS([execinfo.h])
@@ -13,17 +12,15 @@ index 263fc22..f52cd62 100644
+
AC_CHECK_FUNCS([mkostemp strchrnul initgroups posix_fallocate])
- COMPOSITOR_MODULES="wayland-server >= 1.7.93 pixman-1 >= 0.25.2"
-diff --git a/src/weston-error.h b/src/weston-error.h
-new file mode 100644
-index 0000000..2089d02
---- /dev/null
-+++ b/src/weston-error.h
+ COMPOSITOR_MODULES="wayland-server >= 1.9.0 pixman-1 >= 0.25.2"
+diff -Naur weston-1.9.0.orig/src/weston-error.h weston-1.9.0/src/weston-error.h
+--- weston-1.9.0.orig/src/weston-error.h 1970-01-01 00:00:00.000000000 +0000
++++ weston-1.9.0/src/weston-error.h 2016-01-01 21:20:54.097472570 +0000
@@ -0,0 +1,24 @@
-/* TODO
- If S is zero error() will not exit so this macro should call warnx() in those cases
- or just add a plain replacement function for error() to weston-launch.c */
-
++/* TODO
++ If S is zero error() will not exit so this macro should call warnx() in those cases
++ or just add a plain replacement function for error() to weston-launch.c */
++
+#ifndef WESTON_ERROR_H
+#define WESTON_ERROR_H
+
@@ -34,7 +31,7 @@ index 0000000..2089d02
+#include <string.h>
+#define weston_error(s, e, f, ...) do { \
+ if (e) \
-+ errx((s), (f) ": %s", ##__VA_ARGS__, strerror(e)); \
++ errx((s), (f), ##__VA_ARGS__, strerror(e)); \
+ else \
+ errx((s), (f), ##__VA_ARGS__); \
+} while(0)
@@ -44,11 +41,10 @@ index 0000000..2089d02
+
+#endif
+
-diff --git a/src/weston-launch.c b/src/weston-launch.c
-index 10c66de..3e6d30a 100644
---- a/src/weston-launch.c
-+++ b/src/weston-launch.c
-@@ -30,7 +30,6 @@
+diff -Naur weston-1.9.0.orig/src/weston-launch.c weston-1.9.0/src/weston-launch.c
+--- weston-1.9.0.orig/src/weston-launch.c 2015-08-10 22:28:46.000000000 +0000
++++ weston-1.9.0/src/weston-launch.c 2016-01-01 21:20:54.098472589 +0000
+@@ -33,7 +33,6 @@
#include <poll.h>
#include <errno.h>
@@ -56,7 +52,7 @@ index 10c66de..3e6d30a 100644
#include <getopt.h>
#include <sys/types.h>
-@@ -56,6 +55,7 @@
+@@ -59,6 +58,7 @@
#endif
#include "weston-launch.h"