summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen-overlay@occam.eroen.eu>2016-09-18 23:54:24 +0200
committereroen <eroen-overlay@occam.eroen.eu>2016-09-18 23:54:24 +0200
commit25b640f724bcf30885ebd201746be1e3b67b64c6 (patch)
tree355c82e8ca090ac27b52d55ac6d7ae8115c20480
parentsteam.eclass - allow anonymous login (diff)
downloaderoen-25b640f724bcf30885ebd201746be1e3b67b64c6.tar.gz
eroen-25b640f724bcf30885ebd201746be1e3b67b64c6.tar.bz2
eroen-25b640f724bcf30885ebd201746be1e3b67b64c6.zip
supermeatboy-9999 - new ebuild using steam.eclass
-rw-r--r--games-arcade/supermeatboy/metadata.xml11
-rw-r--r--games-arcade/supermeatboy/supermeatboy-9999.ebuild53
2 files changed, 64 insertions, 0 deletions
diff --git a/games-arcade/supermeatboy/metadata.xml b/games-arcade/supermeatboy/metadata.xml
new file mode 100644
index 0000000..774b3d7
--- /dev/null
+++ b/games-arcade/supermeatboy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>eroen-overlay@occam.eroen.eu</email>
+ <name>eroen</name>
+ </maintainer>
+ <longdescription lang="en">
+ User data is kept in `~/.local/share/SuperMeatBoy`.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-arcade/supermeatboy/supermeatboy-9999.ebuild b/games-arcade/supermeatboy/supermeatboy-9999.ebuild
new file mode 100644
index 0000000..076ec6e
--- /dev/null
+++ b/games-arcade/supermeatboy/supermeatboy-9999.ebuild
@@ -0,0 +1,53 @@
+# By eroen <eroen-overlay@occam.eroen.eu>, 2016
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+# $Id$
+
+EAPI=6
+
+inherit eutils gnome2-utils steam
+
+DESCRIPTION="Platforming with an adorable cube of meat"
+HOMEPAGE="http://www.supermeatboy.com https://steamdb.info/app/40809"
+#SRC_URI="~amd64 ~x86"
+LICENSE="all-rights-reserved"
+RESTRICT="bindist"
+
+STEAM_app_id=40800
+
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="media-libs/libsdl2
+ media-libs/openal
+ sys-devel/gcc[cxx]"
+
+src_install() {
+ exeinto /opt/$PN/bin
+ use amd64 && doexe amd64/*
+ use x86 && doexe x86/*
+
+ insinto /opt/$PN
+ doins -r resources
+ doins buttonmap.cfg gameaudio.dat gamedata.dat locdb.txt
+
+ doicon -s 64 supermeatboy.png
+ make_wrapper $PN /opt/$PN/bin/SuperMeatBoy /opt/$PN
+ make_desktop_entry $PN SuperMeatBoy supermeatboy
+ dodoc README-linux.txt
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}