summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2012-02-24 16:11:08 -0500
committerAaron Mavrinac <mavrinac@gmail.com>2012-02-24 16:11:08 -0500
commitf3766e187714ff72102905169fdb082a57838a01 (patch)
treec1d5362abd9d60fd13d90669d9d8184f2f4fb984 /dev-python/fuzzpy/fuzzpy-0.4.2.ebuild
parentsci-electronics/gazebo: Add environment variables for resource paths. (diff)
downloadezod-f3766e187714ff72102905169fdb082a57838a01.tar.gz
ezod-f3766e187714ff72102905169fdb082a57838a01.tar.bz2
ezod-f3766e187714ff72102905169fdb082a57838a01.zip
dev-python/fuzzpy: Version bump to v0.4.2.
Diffstat (limited to 'dev-python/fuzzpy/fuzzpy-0.4.2.ebuild')
-rw-r--r--dev-python/fuzzpy/fuzzpy-0.4.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/fuzzpy/fuzzpy-0.4.2.ebuild b/dev-python/fuzzpy/fuzzpy-0.4.2.ebuild
new file mode 100644
index 0000000..662253e
--- /dev/null
+++ b/dev-python/fuzzpy/fuzzpy-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+
+inherit distutils eutils
+
+DESCRIPTION="FuzzPy is a library for fuzzy sets, fuzzy graphs, and general fuzzy
+mathematics for Python."
+HOMEPAGE="http://github.com/ezod/fuzzpy"
+SRC_URI="mirror://pypi/f/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc gnuplot pydot"
+
+RDEPEND="
+ gnuplot? ( dev-python/gnuplot-py )
+ pydot? ( media-gfx/pydot )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/epydoc )
+"
+
+DOCS="AUTHORS RELEASE-NOTES"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ env python setup.py doc
+ dohtml -r doc/
+ fi
+}