summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2009-05-21 12:06:43 -0400
committerAaron Mavrinac <mavrinac@gmail.com>2009-05-21 12:06:43 -0400
commitf62868676cbff0583cb350b4f8b4a836d1a51c32 (patch)
treef7e22f2a1040fbd5194aee618e43862cd87ea89d /dev-python/fuzzpy
parentVersion bump dev-python/fuzzpy to 0.0.1. (diff)
downloadezod-f62868676cbff0583cb350b4f8b4a836d1a51c32.tar.gz
ezod-f62868676cbff0583cb350b4f8b4a836d1a51c32.tar.bz2
ezod-f62868676cbff0583cb350b4f8b4a836d1a51c32.zip
Actually add the dev-python/fuzzpy 0.0.1 ebuild.
Diffstat (limited to 'dev-python/fuzzpy')
-rw-r--r--dev-python/fuzzpy/fuzzpy-0.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/fuzzpy/fuzzpy-0.0.1.ebuild b/dev-python/fuzzpy/fuzzpy-0.0.1.ebuild
new file mode 100644
index 0000000..0231ef2
--- /dev/null
+++ b/dev-python/fuzzpy/fuzzpy-0.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.5
+
+inherit distutils eutils
+
+DESCRIPTION="FuzzPy is a library for fuzzy sets, fuzzy graphs, and general fuzzy
+mathematics for Python."
+HOMEPAGE="http://code.google.com/p/fuzzpy"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+IUSE="doc"
+
+RDEPEND="virtual/python"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/epydoc )"
+
+DOCS="AUTHORS README TODO"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ ./gendoc.sh
+ dohtml -r doc/
+ fi
+}