summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHoang Minh Thang <hoangminhthang@ktqd.org>2012-07-26 23:06:37 +0700
committerHoang Minh Thang <hoangminhthang@ktqd.org>2012-07-26 23:06:37 +0700
commit60aeaaedaf4531cc1b27bd0d62c36466a265cfed (patch)
tree8e0b5f2f256632489f2ae352f71389712fc0381a /app-text/cherrytree/cherrytree-0.25.4.ebuild
parentadd ekho (diff)
downloadgentoo-vn-60aeaaedaf4531cc1b27bd0d62c36466a265cfed.tar.gz
gentoo-vn-60aeaaedaf4531cc1b27bd0d62c36466a265cfed.tar.bz2
gentoo-vn-60aeaaedaf4531cc1b27bd0d62c36466a265cfed.zip
add cherrytreeHEADmaster
Diffstat (limited to 'app-text/cherrytree/cherrytree-0.25.4.ebuild')
-rw-r--r--app-text/cherrytree/cherrytree-0.25.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/cherrytree/cherrytree-0.25.4.ebuild b/app-text/cherrytree/cherrytree-0.25.4.ebuild
new file mode 100644
index 0000000..0f8de39
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-0.25.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cherrytree/cherrytree-0.25.ebuild,v 1.1 2011/06/09 07:41:52 radhermit Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45] 3.* *-jython"
+
+inherit distutils eutils fdo-mime
+
+DESCRIPTION="A hierarchical note taking application"
+HOMEPAGE="http://www.giuspen.com/cherrytree/"
+SRC_URI="http://www.giuspen.com/software/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ >=dev-python/pygtk-2.12:2
+ dev-python/pygtksourceview"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ "
+
+src_prepare() {
+ # Avoid sandbox violation
+ sed -e "s:subprocess.call(\"update-desktop-database\"):#subprocess.call(\"update-desktop-database\"):g" \
+ -i setup.py || die "sed failed to patch install.py"
+
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+