summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHoang Minh Thang <hoangminhthang@ktqd.org>2012-02-01 15:26:32 +0700
committerHoang Minh Thang <hoangminhthang@ktqd.org>2012-02-01 15:26:32 +0700
commit3179038c1a2c75d1330db7fd4fef29ecb0551eb1 (patch)
tree6c6835a9a2c67c4b18fa2f35ba41c4cdad7eae01 /media-gfx/xmorph
parentb2uconverter v10.01.4 (diff)
downloadgentoo-vn-3179038c1a2c75d1330db7fd4fef29ecb0551eb1.tar.gz
gentoo-vn-3179038c1a2c75d1330db7fd4fef29ecb0551eb1.tar.bz2
gentoo-vn-3179038c1a2c75d1330db7fd4fef29ecb0551eb1.zip
espeakedit-1.46.02
Diffstat (limited to 'media-gfx/xmorph')
-rw-r--r--media-gfx/xmorph/Manifest2
-rw-r--r--media-gfx/xmorph/xmorph-20090929.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/xmorph/Manifest b/media-gfx/xmorph/Manifest
new file mode 100644
index 0000000..017b621
--- /dev/null
+++ b/media-gfx/xmorph/Manifest
@@ -0,0 +1,2 @@
+DIST xmorph_20090926.tar.gz 1576680 RMD160 9c15f3a0dc72dd76375aa12e05f6068a8d5105ad SHA1 658fd5301c5eb592c4007dddf4b874febf1adf78 SHA256 24b4b8476ca70815a117cf2c440ab118d1ec345f8198aa8869281659908138d9
+EBUILD xmorph-20090929.ebuild 948 RMD160 f5e94e98a4797fea504fdecf211f9672fae3a1d1 SHA1 070e1a0b39cac186ebd0e5270adec2a73e84346b SHA256 d950024e7300d4b56516861d1fa3f22b3d66c0c8c7a8965d80874e3398b257f7
diff --git a/media-gfx/xmorph/xmorph-20090929.ebuild b/media-gfx/xmorph/xmorph-20090929.ebuild
new file mode 100644
index 0000000..3fd41f6
--- /dev/null
+++ b/media-gfx/xmorph/xmorph-20090929.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Library that implements digital image warping, known as morphing, along with GUIs."
+HOMEPAGE="http://xmorph.sourceforge.net/"
+SRC_URI="http://ftp.de.debian.org/debian/pool/main/x/xmorph/xmorph_20090926.tar.gz"
+RESTRICT="nomirror"
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gtk nls fftw"
+# Options I'm ignoring:
+# --with-waili --with-xmorph --with-tkmorph
+
+# --disable-gtktest \
+# --without-gtkmorph \
+
+RDEPEND="nls? ( virtual/libintl )
+ gtk? ( x11-libs/gtk+ )"
+
+DEPEND="nls? ( sys-devel/gettext )
+ gtk? ( x11-libs/gtk+ )
+ fftw? ( >=sci-libs/fftw-3 )"
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk gtkmorph) \
+ $(use_with fftw) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+}