aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregory M. Tuner <gmt@be-evil.net>2014-06-05 04:24:51 -0700
committerGregory M. Tuner <gmt@be-evil.net>2014-06-05 04:24:51 -0700
commit1f9e6dceb7e61dd35b6a76b9cadbf6c32a08f110 (patch)
tree9737aa1f4ad1ea8a3f0139b2b34a066302672834 /x11-libs/xpyb/xpyb-9999-r1.ebuild
parentdev-lang/python-2.6.7-r2: sync with eclass shebang fixing changes (diff)
downloadgmt-1f9e6dceb7e61dd35b6a76b9cadbf6c32a08f110.tar.gz
gmt-1f9e6dceb7e61dd35b6a76b9cadbf6c32a08f110.tar.bz2
gmt-1f9e6dceb7e61dd35b6a76b9cadbf6c32a08f110.zip
x11-libs/*: live ebuilds from x11-overlay w/ multilib merges
Signed-off-by: Gregory M. Tuner <gmt@be-evil.net>
Diffstat (limited to 'x11-libs/xpyb/xpyb-9999-r1.ebuild')
-rw-r--r--x11-libs/xpyb/xpyb-9999-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/xpyb/xpyb-9999-r1.ebuild b/x11-libs/xpyb/xpyb-9999-r1.ebuild
new file mode 100644
index 0000000..05f8387
--- /dev/null
+++ b/x11-libs/xpyb/xpyb-9999-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit flag-o-matic python-r1 xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/xpyb"
+#SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+DESCRIPTION="XCB-based Python bindings for the X Window System"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS=""
+IUSE="selinux"
+
+RDEPEND=">=x11-libs/libxcb-1.7
+ >=x11-proto/xcb-proto-1.7.1[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( NEWS README )
+
+_mypywrap() {
+ local CFLAGS="${CFLAGS} $(python_get_CFLAGS)"
+ local CXXFLAGS="${CXXFLAGS} $(python_get_CFLAGS)"
+ export CFLAGS CXXFLAGS
+ "$@"
+}
+
+pkg_setup() {
+ xorg-2_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable selinux xselinux)
+ )
+ append-cflags -fno-strict-aliasing
+ python_parallel_foreach_impl _mypywrap xorg-2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl _mypywrap xorg-2_src_compile
+}
+
+src_install() {
+ python_foreach_impl _mypywrap xorg-2_src_install
+}