aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt4/PyQt4-4.10.3-r4.ebuild')
-rw-r--r--dev-python/PyQt4/PyQt4-4.10.3-r4.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/PyQt4/PyQt4-4.10.3-r4.ebuild b/dev-python/PyQt4/PyQt4-4.10.3-r4.ebuild
index 287464e..d44e5a7 100644
--- a/dev-python/PyQt4/PyQt4-4.10.3-r4.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.10.3-r4.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.10.3-r2.ebuild,v 1.1 2013/12/25 21:00:36 pesa Exp $
+# $Header: $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
inherit eutils multibuild python-r1 qmake-utils toolchain-funcs
DESCRIPTION="Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/ http://pypi.python.org/pypi/PyQt"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/ https://pypi.python.org/pypi/PyQt4"
if [[ ${PV} == *_pre* ]]; then
MY_P="PyQt-x11-gpl-snapshot-${PV%_pre*}-${REVISION}"
@@ -20,7 +20,7 @@ fi
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64"
IUSE="X dbus debug declarative designer doc examples help kde multimedia opengl phonon script scripttools sql svg webkit xmlpatterns"
REQUIRED_USE="
@@ -42,7 +42,7 @@ QT_PV="4.8.0:4"
RDEPEND="
${PYTHON_DEPS}
- >=dev-python/sip-4.15.0:=[${PYTHON_USEDEP}]
+ =dev-python/sip-4.15*:=[${PYTHON_USEDEP}]
>=dev-qt/qtcore-${QT_PV}
X? (
>=dev-qt/qtgui-${QT_PV}