aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-1.2.6-r1.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-1.2.6-r1.ebuild319
1 files changed, 319 insertions, 0 deletions
diff --git a/media-video/ffmpeg/ffmpeg-1.2.6-r1.ebuild b/media-video/ffmpeg/ffmpeg-1.2.6-r1.ebuild
new file mode 100644
index 0000000..6636870
--- /dev/null
+++ b/media-video/ffmpeg/ffmpeg-1.2.6-r1.ebuild
@@ -0,0 +1,319 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://source.ffmpeg.org/ffmpeg.git"
+fi
+
+inherit eutils flag-o-matic multilib toolchain-funcs ${SCM} multilib-minimal
+
+DESCRIPTION="Complete solution to record, convert and stream audio and video. Includes libavcodec."
+HOMEPAGE="http://ffmpeg.org/"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+elif [ "${PV%_p*}" != "${PV}" ] ; then # Snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+else # Release
+ SRC_URI="http://ffmpeg.org/releases/${P/_/-}.tar.bz2"
+fi
+FFMPEG_REVISION="${PV#*_p}"
+
+LICENSE="GPL-2 amr? ( GPL-3 ) encode? ( aac? ( GPL-3 ) )"
+SLOT="0"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64"
+fi
+IUSE="
+ aac aacplus alsa amr bindist bluray +bzip2 cdio celt
+ cpudetection debug doc +encode examples faac fdk flite fontconfig frei0r
+ gnutls gsm +hardcoded-tables +iconv iec61883 ieee1394 jack jpeg2k libass
+ libcaca libsoxr libv4l modplug mp3 +network openal openssl opus oss pic
+ pulseaudio rtmp schroedinger sdl speex static-libs test theora threads
+ truetype twolame v4l vaapi vdpau vorbis vpx X x264 xvid +zlib
+ "
+
+# String for CPU features in the useflag[:configure_option] form
+# if :configure_option isn't set, it will use 'useflag' as configure option
+CPU_FEATURES="3dnow:amd3dnow 3dnowext:amd3dnowext altivec avx mmx mmxext ssse3 vis neon"
+
+for i in ${CPU_FEATURES}; do
+ IUSE="${IUSE} ${i%:*}"
+done
+
+FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"
+
+for i in ${FFTOOLS}; do
+ IUSE="${IUSE} +fftools_$i"
+done
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+ amr? ( media-libs/opencore-amr[${MULTILIB_USEDEP}] )
+ bluray? ( media-libs/libbluray[${MULTILIB_USEDEP}] )
+ bzip2? ( app-arch/bzip2[${MULTILIB_USEDEP}] )
+ cdio? ( || ( dev-libs/libcdio-paranoia[${MULTILIB_USEDEP}]
+ <dev-libs/libcdio-0.90[-minimal,${MULTILIB_USEDEP}] ) )
+ celt? ( >=media-libs/celt-0.11.1[${MULTILIB_USEDEP}] )
+ encode? (
+ aac? ( media-libs/vo-aacenc[${MULTILIB_USEDEP}] )
+ aacplus? ( media-libs/libaacplus[${MULTILIB_USEDEP}] )
+ amr? ( media-libs/vo-amrwbenc[${MULTILIB_USEDEP}] )
+ faac? ( media-libs/faac[${MULTILIB_USEDEP}] )
+ fdk? ( media-libs/fdk-aac[${MULTILIB_USEDEP}] )
+ mp3? ( >=media-sound/lame-3.98.3[${MULTILIB_USEDEP}] )
+ theora? ( >=media-libs/libtheora-1.1.1[encode,${MULTILIB_USEDEP}]
+ media-libs/libogg[${MULTILIB_USEDEP}] )
+ twolame? ( media-sound/twolame[${MULTILIB_USEDEP}] )
+ x264? ( >=media-libs/x264-0.0.20111017[${MULTILIB_USEDEP}] )
+ xvid? ( >=media-libs/xvid-1.1.0[${MULTILIB_USEDEP}] )
+ )
+ flite? ( app-accessibility/flite[${MULTILIB_USEDEP}] )
+ fontconfig? ( media-libs/fontconfig[${MULTILIB_USEDEP}] )
+ frei0r? ( media-plugins/frei0r-plugins[${MULTILIB_USEDEP}] )
+ gnutls? ( >=net-libs/gnutls-2.12.16[${MULTILIB_USEDEP}] )
+ gsm? ( >=media-sound/gsm-1.0.12-r1[${MULTILIB_USEDEP}] )
+ iconv? ( virtual/libiconv[${MULTILIB_USEDEP}] )
+ iec61883? ( media-libs/libiec61883[${MULTILIB_USEDEP}]
+ sys-libs/libraw1394[${MULTILIB_USEDEP}]
+ sys-libs/libavc1394[${MULTILIB_USEDEP}] )
+ ieee1394? ( media-libs/libdc1394[${MULTILIB_USEDEP}]
+ sys-libs/libraw1394[${MULTILIB_USEDEP}] )
+ jack? ( media-sound/jack-audio-connection-kit[${MULTILIB_USEDEP}] )
+ jpeg2k? ( >=media-libs/openjpeg-1.3-r2:0[${MULTILIB_USEDEP}] )
+ libass? ( media-libs/libass[${MULTILIB_USEDEP}] )
+ libcaca? ( media-libs/libcaca[${MULTILIB_USEDEP}] )
+ libsoxr? ( media-libs/soxr[${MULTILIB_USEDEP}] )
+ libv4l? ( media-libs/libv4l[${MULTILIB_USEDEP}] )
+ modplug? ( media-libs/libmodplug[${MULTILIB_USEDEP}] )
+ openal? ( >=media-libs/openal-1.1[${MULTILIB_USEDEP}] )
+ openssl? ( dev-libs/openssl[${MULTILIB_USEDEP}] )
+ opus? ( media-libs/opus[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ rtmp? ( >=media-video/rtmpdump-2.2f[${MULTILIB_USEDEP}] )
+ sdl? ( >=media-libs/libsdl-1.2.13-r1[audio,video,${MULTILIB_USEDEP}] )
+ schroedinger? ( media-libs/schroedinger[${MULTILIB_USEDEP}] )
+ speex? ( >=media-libs/speex-1.2_beta3[${MULTILIB_USEDEP}] )
+ truetype? ( media-libs/freetype:2[${MULTILIB_USEDEP}] )
+ vaapi? ( >=x11-libs/libva-0.32[${MULTILIB_USEDEP}] )
+ vdpau? ( x11-libs/libvdpau[${MULTILIB_USEDEP}] )
+ vorbis? ( media-libs/libvorbis[${MULTILIB_USEDEP}]
+ media-libs/libogg[${MULTILIB_USEDEP}] )
+ vpx? ( >=media-libs/libvpx-0.9.6[${MULTILIB_USEDEP}] )
+ X? ( x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ !media-video/qt-faststart
+ !media-libs/libpostproc
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-medialibs-20131008-r1
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)]
+ )
+"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/make-3.81
+ doc? ( app-text/texi2html )
+ fontconfig? ( virtual/pkgconfig )
+ gnutls? ( virtual/pkgconfig )
+ ieee1394? ( virtual/pkgconfig )
+ libv4l? ( virtual/pkgconfig )
+ mmx? ( dev-lang/yasm )
+ rtmp? ( virtual/pkgconfig )
+ schroedinger? ( virtual/pkgconfig )
+ test? ( net-misc/wget )
+ truetype? ( virtual/pkgconfig )
+ v4l? ( sys-kernel/linux-headers )
+"
+# faac is license-incompatible with ffmpeg
+REQUIRED_USE="bindist? ( encode? ( !faac !aacplus ) !openssl )
+ libv4l? ( v4l )
+ fftools_cws2fws? ( zlib )
+ test? ( encode )"
+
+S=${WORKDIR}/${P/_/-}
+BUILD_DIR=${S}_build
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libavutil/avconfig.h
+)
+
+src_prepare() {
+ if [ "${PV%_p*}" != "${PV}" ] ; then # Snapshot
+ export revision=git-N-${FFMPEG_REVISION}
+ fi
+
+ epatch_user
+}
+
+multilib_src_configure() {
+ local myconf="${EXTRA_FFMPEG_CONF}"
+
+ # options to use as use_enable in the foo[:bar] form.
+ # This will feed configure with $(use_enable foo bar)
+ # or $(use_enable foo foo) if no :bar is set.
+ local ffuse="bzip2:bzlib cpudetection:runtime-cpudetect debug doc
+ gnutls hardcoded-tables iconv network openssl sdl:ffplay vaapi vdpau zlib"
+
+ use openssl && myconf="${myconf} --enable-nonfree"
+
+ # Encoders
+ if use encode
+ then
+ ffuse="${ffuse} aac:libvo-aacenc amr:libvo-amrwbenc mp3:libmp3lame fdk:libfdk-aac"
+ for i in aacplus faac theora twolame x264 xvid; do
+ ffuse="${ffuse} ${i}:lib${i}"
+ done
+
+ # Licensing.
+ if use aac || use amr ; then
+ myconf="${myconf} --enable-version3"
+ fi
+ if use aacplus || use faac || use fdk ; then
+ myconf="${myconf} --enable-nonfree"
+ fi
+ else
+ myconf="${myconf} --disable-encoders"
+ fi
+
+ # libavdevice options
+ ffuse="${ffuse} cdio:libcdio iec61883:libiec61883 ieee1394:libdc1394 libcaca openal"
+
+ # Indevs
+ use v4l || myconf="${myconf} --disable-indev=v4l2"
+ for i in alsa oss jack ; do
+ use ${i} || myconf="${myconf} --disable-indev=${i}"
+ done
+ ffuse="${ffuse} libv4l:libv4l2 pulseaudio:libpulse X:x11grab"
+
+ # Outdevs
+ for i in alsa oss sdl ; do
+ use ${i} || myconf="${myconf} --disable-outdev=${i}"
+ done
+
+ # libavfilter options
+ ffuse="${ffuse} flite:libflite frei0r fontconfig libass truetype:libfreetype"
+
+ # libswresample options
+ ffuse="${ffuse} libsoxr"
+
+ # Threads; we only support pthread for now but ffmpeg supports more
+ ffuse="${ffuse} threads:pthreads"
+
+ # Decoders
+ ffuse="${ffuse} amr:libopencore-amrwb amr:libopencore-amrnb jpeg2k:libopenjpeg"
+ use amr && myconf="${myconf} --enable-version3"
+ for i in bluray celt gsm modplug opus rtmp schroedinger speex vorbis vpx; do
+ ffuse="${ffuse} ${i}:lib${i}"
+ done
+
+ for i in ${ffuse} ; do
+ myconf="${myconf} $(use_enable ${i%:*} ${i#*:})"
+ done
+
+ # CPU features
+ for i in ${CPU_FEATURES}; do
+ use ${i%:*} || myconf="${myconf} --disable-${i#*:}"
+ done
+ if use pic ; then
+ myconf="${myconf} --enable-pic"
+ # disable asm code if PIC is required
+ # as the provided asm decidedly is not PIC for x86.
+ abi_arch_use x86 && myconf="${myconf} --disable-asm"
+ fi
+
+ # when cross-abi-compiling for amd64, no pic flag is present,
+ # but unless we do a pic build we get textrels.
+ use '!x86' && abi_arch_use x86 && myconf+=" --enable-pic --disable-asm"
+
+ [[ ${ABI} == "x32" ]] && myconf+=" --disable-asm" #427004
+
+ # Try to get cpu type based on CFLAGS.
+ # Bug #172723
+ # We need to do this so that features of that CPU will be better used
+ # If they contain an unknown CPU it will not hurt since ffmpeg's configure
+ # will just ignore it.
+ for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
+ [ "${i}" = "native" ] && i="host" # bug #273421
+ myconf="${myconf} --cpu=${i}"
+ break
+ done
+
+ # Mandatory configuration
+ myconf="
+ --enable-gpl
+ --enable-postproc
+ --enable-avfilter
+ --enable-avresample
+ --disable-stripping
+ ${myconf}"
+
+ # cross compile support
+ if tc-is-cross-compiler ; then
+ myconf="${myconf} --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}-"
+ case ${CHOST} in
+ *freebsd*)
+ myconf="${myconf} --target-os=freebsd"
+ ;;
+ mingw32*)
+ myconf="${myconf} --target-os=mingw32"
+ ;;
+ *linux*)
+ myconf="${myconf} --target-os=linux"
+ ;;
+ esac
+ fi
+
+ "${S}/configure" \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --shlibdir="${EPREFIX}/usr/$(get_libdir)" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --enable-shared \
+ --cc="${CC:-$(tc-getCC)}" \
+ --cxx="${CXX:-$(tc-getCXX)}" \
+ --ar="$(tc-getAR)" \
+ --optflags="${CFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-cxxflags="${CXXFLAGS}" \
+ $(use_enable static-libs static) \
+ ${myconf} || die
+}
+
+multilib_src_compile() {
+ emake V=1
+
+ for i in ${FFTOOLS} ; do
+ if use fftools_$i ; then
+ emake V=1 tools/$i
+ fi
+ done
+}
+
+multilib_src_install() {
+ emake V=1 DESTDIR="${D}" install install-man
+
+ for i in ${FFTOOLS} ; do
+ if use fftools_$i ; then
+ dobin tools/$i
+ fi
+ done
+
+ cd "${S}"
+ dodoc Changelog README CREDITS doc/*.txt doc/APIchanges doc/RELEASE_NOTES
+ use doc && dohtml -r doc/*
+ if use examples ; then
+ dodoc -r doc/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+multilib_src_test() {
+ LD_LIBRARY_PATH="${BUILD_DIR}/libpostproc:${BUILD_DIR}/libswscale:${BUILD_DIR}/libswresample:${BUILD_DIR}/libavcodec:${BUILD_DIR}/libavdevice:${BUILD_DIR}/libavfilter:${BUILD_DIR}/libavformat:${BUILD_DIR}/libavutil:${BUILD_DIR}/libavresample" \
+ emake V=1 fate
+}