summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Köster <koesterreich@fastmail.fm>2012-10-27 10:43:08 +0200
committerFabian Köster <koesterreich@fastmail.fm>2012-10-27 10:43:08 +0200
commitdd83a8774c3ff6d488e78dc450c4a323fb4bb776 (patch)
tree0fa62a20c45e957bf21874f6f9b4af419eba2936 /sys-libs/pcsc-ctapi-wrapper
downloadhibiscus-dd83a8774c3ff6d488e78dc450c4a323fb4bb776.tar.gz
hibiscus-dd83a8774c3ff6d488e78dc450c4a323fb4bb776.tar.bz2
hibiscus-dd83a8774c3ff6d488e78dc450c4a323fb4bb776.zip
Initial commit
Diffstat (limited to 'sys-libs/pcsc-ctapi-wrapper')
-rw-r--r--sys-libs/pcsc-ctapi-wrapper/Manifest2
-rw-r--r--sys-libs/pcsc-ctapi-wrapper/pcsc-ctapi-wrapper-0.3.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-libs/pcsc-ctapi-wrapper/Manifest b/sys-libs/pcsc-ctapi-wrapper/Manifest
new file mode 100644
index 0000000..80cbd96
--- /dev/null
+++ b/sys-libs/pcsc-ctapi-wrapper/Manifest
@@ -0,0 +1,2 @@
+DIST pcsc-ctapi-wrapper-0.3.tar.gz 14792 SHA256 5ae49663120a711183a624798d150006cf18e2eedaf489c4aa139b6e97befb33 SHA512 d7298ab22d90fa4a6b49ac8c7c1339dfb5ca150776fdc83c1c92dc9b979065ed419df7c0ed29072cdd29f2f04121db9057b37f0f9e66c29474b80782b0b87dbc WHIRLPOOL 460181260fbb6f4c515f1a96f0c02ad44ad18585d27b6831610cc36a4b70db80492c5ce72613fe6c9db94d1da827b60df570c1346ce091aedc8694d8f092b6b0
+EBUILD pcsc-ctapi-wrapper-0.3.ebuild 851 SHA256 6a80380a5a0ff33a87bed9d5e540c03acf495e4fc8fdc060bc60eccad5926e6e SHA512 91931421a0feabb10048d35aef6a40af4451ad95ae344b9f6e61c369073a1b3e2f530cf08d61172dd795d27a8edc14acd9881e616d011f7463debf55ed7af2cf WHIRLPOOL a418cca0d57ecf1799021bf5ce1fea497bd875a63a6828ba551910933e0c4c5e0af2be07140b7e4cc266ea23e37bb802d249ec84771f2908f62b4847cf713516
diff --git a/sys-libs/pcsc-ctapi-wrapper/pcsc-ctapi-wrapper-0.3.ebuild b/sys-libs/pcsc-ctapi-wrapper/pcsc-ctapi-wrapper-0.3.ebuild
new file mode 100644
index 0000000..956b34b
--- /dev/null
+++ b/sys-libs/pcsc-ctapi-wrapper/pcsc-ctapi-wrapper-0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libchipcard/libchipcard-5.0.2.ebuild,v 1.5 2012/04/16 19:39:58 ranger Exp $
+
+EAPI=2
+
+inherit eutils multilib
+
+DESCRIPTION="Wrapper library for using smartcard readers that support PCSC only (e.g. SCR24x) with any application that supports CTAPI."
+HOMEPAGE="http://pcsc-ctapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pcsc-ctapi/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=sys-apps/pcsc-lite-1.6.2"
+DEPEND="${RDEPEND}"
+
+src_install() {
+
+ dolib.so lib${PN}.so.${PV} || die "dolib.so failed"
+ dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.0 || die
+ dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so || die
+
+ dodoc README || die "dodoc failed"
+}