summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/spiffy/spiffy-0.05.ebuild')
-rw-r--r--dev-java/spiffy/spiffy-0.05.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-java/spiffy/spiffy-0.05.ebuild b/dev-java/spiffy/spiffy-0.05.ebuild
index 03fd9e3..cf5c351 100644
--- a/dev-java/spiffy/spiffy-0.05.ebuild
+++ b/dev-java/spiffy/spiffy-0.05.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-JAVA_PKG_IUSE="doc source"
+JAVA_PKG_IUSE="doc source test"
inherit eutils java-pkg-2 java-pkg-simple
@@ -21,14 +21,16 @@ COMMON_DEPS="dev-java/log4j"
DEPEND="${COMMON_DEPS}
app-arch/unzip
- dev-java/junit:4
+ test? (
+ dev-java/junit:4
+ )
dev-java/struts:1.2
>=virtual/jdk-1.5"
RDEPEND="${COMMON_DEPS}
>=virtual/jre-1.5"
JAVA_SRC_DIR="src"
-JAVA_GENTOO_CLASSPATH="junit-4,log4j,struts-1.2"
+JAVA_GENTOO_CLASSPATH="log4j,struts-1.2,junit-4"
src_unpack() {
unpack ${A}