summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/spiffy/spiffy-0.05.ebuild')
-rw-r--r--dev-java/spiffy/spiffy-0.05.ebuild54
1 files changed, 18 insertions, 36 deletions
diff --git a/dev-java/spiffy/spiffy-0.05.ebuild b/dev-java/spiffy/spiffy-0.05.ebuild
index 8a53476..4d8313a 100644
--- a/dev-java/spiffy/spiffy-0.05.ebuild
+++ b/dev-java/spiffy/spiffy-0.05.ebuild
@@ -1,15 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI="5"
JAVA_PKG_IUSE="doc source"
-MY_PN="SuperCSV"
-MY_P="${MY_PN}-${PV}"
-
-inherit java-pkg-2 eutils
+inherit java-pkg-2 java-pkg-simple
DESCRIPTION="A collection of often used helper methods and utility classes used in industry"
HOMEPAGE="http://spiffyframework.sourceforge.net/"
@@ -17,42 +14,27 @@ SRC_URI="mirror://sourceforge/spiffyframework/spiffyframework/v0.xx/${PN}-all-${
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-
COMMON_DEPS="dev-java/log4j"
DEPEND="${COMMON_DEPS}
app-arch/unzip
- dev-java/junit:0
+ dev-java/junit:4
dev-java/struts
- >=virtual/jdk-1.5"
+ >=virtual/jdk-1.5"
RDEPEND="${COMMON_DEPS}
- >=virtual/jre-1.5"
-
-S="${WORKDIR}"
-
-src_prepare() {
- unzip -o ${PN}-all-${PV}-source.zip
- rm -v *.jar *.zip || die
-}
-
-src_compile() {
- local classpath="$(java-pkg_getjars junit,log4j,struts-1.2)"
-
- mkdir build
- find src -name '*.java' > sources.list
- ejavac -d build -cp "${classpath}" @sources.list
- jar cf ${PN}.jar -C build/ .
-
- # TODO javadoc
-}
-
-src_install() {
- java-pkg_newjar ${PN}.jar
-
- #use doc && java-pkg_dohtml -r docs/*
- use source && java-pkg_dosrc src/org
+ >=virtual/jre-1.5"
+
+JAVA_GENTOO_CLASSPATH="junit-4,log4j,struts-1.2"
+
+src_unpack() {
+ unpack ${A}
+ rm -v ${PN}-all-${PV}.jar || die
+ rm -v ${PN}-with_source-all-${PV}.jar || die
+ rm -v ${PN}-all-${PV}-javadoc.zip || die
+ cd "${S}"
+ unzip ${PN}-all-${PV}-source.zip
+ rm ${PN}-all-${PV}-source.zip
}
-