aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-04-27 23:17:35 +0800
committerIan Delaney <della5@iinet.com.au>2012-04-27 23:17:35 +0800
commit801c384fe9ab8abced5163fa99b567b7ac711bd3 (patch)
treeb7326da487b6a76f63377001b8c62813d5c9f285
parent[dev-python/manuel] added -1.6.0.ebuild (diff)
downloadimprovise-801c384fe9ab8abced5163fa99b567b7ac711bd3.tar.gz
improvise-801c384fe9ab8abced5163fa99b567b7ac711bd3.tar.bz2
improvise-801c384fe9ab8abced5163fa99b567b7ac711bd3.zip
[dev-python/manueal] test phase update
(Portage version: 2.1.10.56/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/manuel/files/manuel-1.6.0-rm_zope_test.patch52
-rw-r--r--dev-python/manuel/manuel-1.6.0.ebuild10
2 files changed, 58 insertions, 4 deletions
diff --git a/dev-python/manuel/files/manuel-1.6.0-rm_zope_test.patch b/dev-python/manuel/files/manuel-1.6.0-rm_zope_test.patch
new file mode 100644
index 0000000..2f5db58
--- /dev/null
+++ b/dev-python/manuel/files/manuel-1.6.0-rm_zope_test.patch
@@ -0,0 +1,52 @@
+diff -ur manuel-1.5.0.orig/src/manuel/tests.py manuel-1.5.0/src/manuel/tests.py
+--- src/manuel/tests.py 2011-03-09 09:33:11.000000000 +0800
++++ src/manuel/tests.py 2012-04-27 21:40:45.653694740 +0800
+@@ -9,15 +9,15 @@
+ import os.path
+ import re
+ import unittest
+-import zope.testing.renormalizing
++#import zope.testing.renormalizing
+
+ doctest = manuel.absolute_import('doctest')
+
+ here = os.path.dirname(os.path.abspath(__file__))
+
+-checker = zope.testing.renormalizing.RENormalizing([
+- (re.compile(r"<unittest\.result\.TestResult"), '<unittest.TestResult'),
+- ])
++#checker = zope.testing.renormalizing.RENormalizing([
++# (re.compile(r"<unittest\.result\.TestResult"), '<unittest.TestResult'),
++# ])
+
+
+ def turtle_on_the_bottom_test():
+@@ -52,7 +52,7 @@
+ optionflags = doctest.NORMALIZE_WHITESPACE | doctest.ELLIPSIS
+
+ m = manuel.ignore.Manuel()
+- m += manuel.doctest.Manuel(optionflags=optionflags, checker=checker)
++# m += manuel.doctest.Manuel(optionflags=optionflags, checker=checker)
+ m += manuel.codeblock.Manuel()
+ m += manuel.capture.Manuel()
+ m += manuel.testcase.SectionManuel()
+diff -ur
+manuel-1.6.0.orig/src/manuel/doctest.py
+manuel-1.6.0/src/manuel/doctest.py
+--- src/manuel/doctest.py 2012-04-17 03:08:54.000000000 +0800
++++ src/manuel/doctest.py 2012-04-27 22:39:12.657973564 +0800
+@@ -46,14 +46,6 @@
+ assert region in document
+
+
+-class DocTest(doctest.DocTest):
+- def __init__(self, examples, globs, name, filename, lineno, docstring):
+- # do everything like regular doctests, but don't make a copy of globs
+- doctest.DocTest.__init__(self, examples, globs, name, filename, lineno,
+- docstring)
+- self.globs = globs
+-
+-
+ def evaluate(m, region, document, globs):
+ # If the parsed object is not a doctest Example then we don't need to
+ # handle it.
diff --git a/dev-python/manuel/manuel-1.6.0.ebuild b/dev-python/manuel/manuel-1.6.0.ebuild
index 70c59ba..2d8174f 100644
--- a/dev-python/manuel/manuel-1.6.0.ebuild
+++ b/dev-python/manuel/manuel-1.6.0.ebuild
@@ -6,7 +6,7 @@ EAPI="4"
PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="2.5 3.*"
-DISTUTILS_SRC_TEST="setup.py"
+
inherit distutils eutils
DESCRIPTION="Manuel lets you build tested documentation."
@@ -15,17 +15,19 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="ZPL"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64"
IUSE="test"
-DEPEND="dev-python/setuptools"
+DEPEND="dev-python/setuptools
+ dev-python/six"
# test? ( net-zope/zope-testing )"
RDEPEND="${DEPEND}"
DOCS=( CHANGES.txt )
src_prepare() {
- epatch "${FILESDIR}"/manuel-1.5.0-rm_zope_test.patch
+ sed -e s':from . ::' -i src/${PN}/tests.py || die
+ epatch "${FILESDIR}"/${P}-rm_zope_test.patch
}
src_test() {