aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-10 20:01:58 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-10 20:01:58 +0800
commitd58b2197669fee2bc07101574cf9415240931c3b (patch)
treec4fbec3660e644afaafc38ba2469623bf3161515
parent[dev-python/django-auth-ldap] refined; added 'bump' -1.1 (diff)
downloadimprovise-d58b2197669fee2bc07101574cf9415240931c3b.tar.gz
improvise-d58b2197669fee2bc07101574cf9415240931c3b.tar.bz2
improvise-d58b2197669fee2bc07101574cf9415240931c3b.zip
[dev-python/django-pipeline] New pipeline-1.2.5.ebuild
(Portage version: 2.1.10.56/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/django-pipeline/Manifest1
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.5.ebuild71
-rw-r--r--dev-python/django-pipeline/metadata.xml10
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/django-pipeline/Manifest b/dev-python/django-pipeline/Manifest
new file mode 100644
index 0000000..82b0ebe
--- /dev/null
+++ b/dev-python/django-pipeline/Manifest
@@ -0,0 +1 @@
+DIST django-pipeline-1.2.5.tar.gz 27027 SHA256 0bc87e8166c9bb9a5100a5826196667f5a42335f4331e10bf87bdcbfe70e795a SHA512 b7f0c4e95c76ef12f7f8cd9ccdf777ffc81ecf2de16d0680b801c68687f6e22619cc6e27a56f1317a2b91eb6cc6061361736cf6db76cd8773888bfd62f252d8a WHIRLPOOL a7d0e7889d9a1b0ba5423ca66a3e658f9760ba080a0ee06e3dd598aa2fe040079b7d1ab300e1dd1533d0038f5012e4dbdeac91a8074456e9ce3c0227b98e3261
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.5.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.5.ebuild
new file mode 100644
index 0000000..d676a75
--- /dev/null
+++ b/dev-python/django-pipeline/django-pipeline-1.2.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="An asset packaging library for Django"
+HOMEPAGE="http://pypi.python.org/pypi/django-debug-toolbar/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+LICENSE="MIT"
+SLOT="0"
+PYTHON_MODNAME="pipeline"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ >=dev-python/django-1.4" #tests require >=1.4
+
+src_prepare() {
+ sed -e s':from pipeline.conf:from tests:' -i tests/tests/compiler.py || die
+}
+
+src_compile() {
+ use doc && emake -C docs html
+ rm -f docs/_build/doctrees/environment.pickle || die
+ distutils_src_compile
+}
+
+src_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
+ testing() {
+ local exit_status=0 test
+ pushd build-${PYTHON_ABI}/lib/tests/tests > /dev/null || die
+ PYTHONPATH=../../
+ for test in [a-z]*.py
+ do
+ "$(PYTHON)" ${test} || \
+ eval $(eerror "test "${test}" failed" && exit_status="1")
+ einfo "test ${test} passed OK"
+ done
+ popd > /dev/null
+ return ${exit_status}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ docompress -x usr/share/doc/${P}/doctrees
+ dohtml -r docs/_build/html/
+ insinto usr/share/doc/${P}/doctrees
+ doins docs/_build/doctrees/*
+ fi
+
+ # Remove un-needed tests to avoid file collosions
+ rmtests() {
+ rm -rf ${ED}/$(python_get_sitedir)/tests/ || die
+ }
+
+ python_execute_function rmtests
+}
diff --git a/dev-python/django-pipeline/metadata.xml b/dev-python/django-pipeline/metadata.xml
new file mode 100644
index 0000000..d02cc23
--- /dev/null
+++ b/dev-python/django-pipeline/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer><email>tampakrap@gentoo.org</email></maintainer>
+ <maintainer>
+ <email>della5@iinet.com.au</email>
+ <name>Ian Delaney aka idella4 proxy maintainer</name>
+ </maintainer>
+</pkgmetadata>