aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-13 01:38:38 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-13 01:38:38 +0800
commit1545db35f28029c082d52ed9ccc14595766951c0 (patch)
treec728cd655e8ef6a9ad6cbf85cac5f650395295c6 /dev-python/sqlite3dbm
parent[dev-python] refinements (diff)
downloadimprovise-1545db35f28029c082d52ed9ccc14595766951c0.tar.gz
improvise-1545db35f28029c082d52ed9ccc14595766951c0.tar.bz2
improvise-1545db35f28029c082d52ed9ccc14595766951c0.zip
[dev-python/[sqlite3dbm,roman,qserve] new ebuilds; deps to bump to mwlib
Diffstat (limited to 'dev-python/sqlite3dbm')
-rw-r--r--dev-python/sqlite3dbm/Manifest1
-rw-r--r--dev-python/sqlite3dbm/files/conf.py221
-rw-r--r--dev-python/sqlite3dbm/metadata.xml10
-rw-r--r--dev-python/sqlite3dbm/sqlite3dbm-0.1.0.ebuild47
4 files changed, 279 insertions, 0 deletions
diff --git a/dev-python/sqlite3dbm/Manifest b/dev-python/sqlite3dbm/Manifest
new file mode 100644
index 0000000..98ffb45
--- /dev/null
+++ b/dev-python/sqlite3dbm/Manifest
@@ -0,0 +1 @@
+DIST sqlite3dbm-0.1.0.tar.gz 9561 SHA256 1f39467f70ce7398e353ca21b622bd0ba156a78004e853daf3ccb59981782f6f SHA512 35b96dffdf82d71c7418f4471413f4d2f6dca4adc74dd0543a5aa8681f67ef4e0b4d124227f695ef7479b78964f97db8ef031e699b4a5887c981edc880298dad WHIRLPOOL 465352f386058137f29fef83a8248d580e6591987c73d9d998fa093055dfb27fdabbe3c99c57ad5c2bcb75c9c60fdb2fcdb0bf2152fd4acf95f075da71f56483
diff --git a/dev-python/sqlite3dbm/files/conf.py b/dev-python/sqlite3dbm/files/conf.py
new file mode 100644
index 0000000..90a23b6
--- /dev/null
+++ b/dev-python/sqlite3dbm/files/conf.py
@@ -0,0 +1,221 @@
+# -*- coding: utf-8 -*-
+#
+# sqlite3dbm documentation build configuration file, created by
+# sphinx-quickstart on Mon Jan 24 18:44:50 2011.
+#
+# This file is execfile()d with the current directory set to its containing dir.
+#
+# Note that not all possible configuration values are present in this
+# autogenerated file.
+#
+# All configuration values have a default; values that are commented out
+# serve to show the default.
+
+import sys, os
+
+# If extensions (or modules to document with autodoc) are in another directory,
+# add these directories to sys.path here. If the directory is relative to the
+# documentation root, use os.path.abspath to make it absolute, like shown here.
+sys.path.insert(0, os.path.abspath('..'))
+import sqlite3dbm
+
+# -- General configuration -----------------------------------------------------
+
+# If your documentation needs a minimal Sphinx version, state it here.
+#needs_sphinx = '1.0'
+
+# Add any Sphinx extension module names here, as strings. They can be extensions
+# coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+extensions = ['sphinx.ext.autodoc', 'sphinx.ext.doctest', 'sphinx.ext.intersphinx', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.viewcode']
+
+# Add any paths that contain templates here, relative to this directory.
+templates_path = ['_templates']
+
+# The suffix of source filenames.
+source_suffix = '.rst'
+
+# The encoding of source files.
+#source_encoding = 'utf-8-sig'
+
+# The master toctree document.
+master_doc = 'index'
+
+# General information about the project.
+project = u'sqlite3dbm'
+copyright = u'2011, Yelp'
+
+# The version info for the project you're documenting, acts as replacement for
+# |version| and |release|, also used in various other places throughout the
+# built documents.
+#
+# The short X.Y version.
+version = sqlite3dbm.__version__.split('-')[0]
+# The full version, including alpha/beta/rc tags.
+version = sqlite3dbm.__version__
+
+# The language for content autogenerated by Sphinx. Refer to documentation
+# for a list of supported languages.
+#language = None
+
+# There are two options for replacing |today|: either, you set today to some
+# non-false value, then it is used:
+#today = ''
+# Else, today_fmt is used as the format for a strftime call.
+#today_fmt = '%B %d, %Y'
+
+# List of patterns, relative to source directory, that match files and
+# directories to ignore when looking for source files.
+exclude_patterns = ['_build']
+
+# The reST default role (used for this markup: `text`) to use for all documents.
+#default_role = None
+
+# If true, '()' will be appended to :func: etc. cross-reference text.
+#add_function_parentheses = True
+
+# If true, the current module name will be prepended to all description
+# unit titles (such as .. function::).
+#add_module_names = True
+
+# If true, sectionauthor and moduleauthor directives will be shown in the
+# output. They are ignored by default.
+#show_authors = False
+
+# The name of the Pygments (syntax highlighting) style to use.
+pygments_style = 'sphinx'
+
+# A list of ignored prefixes for module index sorting.
+#modindex_common_prefix = []
+
+
+# -- Options for HTML output ---------------------------------------------------
+
+# The theme to use for HTML and HTML Help pages. See the documentation for
+# a list of builtin themes.
+html_theme = 'default'
+
+# Theme options are theme-specific and customize the look and feel of a theme
+# further. For a list of options available for each theme, see the
+# documentation.
+#html_theme_options = {}
+
+# Add any paths that contain custom themes here, relative to this directory.
+#html_theme_path = []
+
+# The name for this set of Sphinx documents. If None, it defaults to
+# "<project> v<release> documentation".
+#html_title = None
+
+# A shorter title for the navigation bar. Default is the same as html_title.
+#html_short_title = None
+
+# The name of an image file (relative to this directory) to place at the top
+# of the sidebar.
+#html_logo = None
+
+# The name of an image file (within the static path) to use as favicon of the
+# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
+# pixels large.
+#html_favicon = None
+
+# Add any paths that contain custom static files (such as style sheets) here,
+# relative to this directory. They are copied after the builtin static files,
+# so a file named "default.css" will overwrite the builtin "default.css".
+html_static_path = ['_static']
+
+# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
+# using the given strftime format.
+#html_last_updated_fmt = '%b %d, %Y'
+
+# If true, SmartyPants will be used to convert quotes and dashes to
+# typographically correct entities.
+#html_use_smartypants = True
+
+# Custom sidebar templates, maps document names to template names.
+#html_sidebars = {}
+
+# Additional templates that should be rendered to pages, maps page names to
+# template names.
+#html_additional_pages = {}
+
+# If false, no module index is generated.
+#html_domain_indices = True
+
+# If false, no index is generated.
+#html_use_index = True
+
+# If true, the index is split into individual pages for each letter.
+#html_split_index = False
+
+# If true, links to the reST sources are added to the pages.
+html_show_sourcelink = True
+
+# If true, "Created using Sphinx" is shown in the HTML footer. Default is True.
+#html_show_sphinx = True
+
+# If true, "(C) Copyright ..." is shown in the HTML footer. Default is True.
+#html_show_copyright = True
+
+# If true, an OpenSearch description file will be output, and all pages will
+# contain a <link> tag referring to it. The value of this option must be the
+# base URL from which the finished HTML is served.
+#html_use_opensearch = ''
+
+# This is the file name suffix for HTML files (e.g. ".xhtml").
+#html_file_suffix = None
+
+# Output file base name for HTML help builder.
+htmlhelp_basename = 'sqlite3dbmdoc'
+
+
+# -- Options for LaTeX output --------------------------------------------------
+
+# The paper size ('letter' or 'a4').
+#latex_paper_size = 'letter'
+
+# The font size ('10pt', '11pt' or '12pt').
+#latex_font_size = '10pt'
+
+# Grouping the document tree into LaTeX files. List of tuples
+# (source start file, target name, title, author, documentclass [howto/manual]).
+latex_documents = [
+ ('index', 'sqlite3dbm.tex', u'sqlite3dbm Documentation',
+ u'Jason Fennell', 'manual'),
+]
+
+# The name of an image file (relative to this directory) to place at the top of
+# the title page.
+#latex_logo = None
+
+# For "manual" documents, if this is true, then toplevel headings are parts,
+# not chapters.
+#latex_use_parts = False
+
+# If true, show page references after internal links.
+#latex_show_pagerefs = False
+
+# If true, show URL addresses after external links.
+#latex_show_urls = False
+
+# Additional stuff for the LaTeX preamble.
+#latex_preamble = ''
+
+# Documents to append as an appendix to all manuals.
+#latex_appendices = []
+
+# If false, no module index is generated.
+#latex_domain_indices = True
+
+
+# -- Options for manual page output --------------------------------------------
+
+# One entry per manual page. List of tuples
+# (source start file, name, description, authors, manual section).
+man_pages = [
+ ('index', 'sqlite3dbm', u'sqlite3dbm Documentation',
+ [u'Jason Fennell'], 1)
+]
+
+
+# Example configuration for intersphinx: refer to the Python standard library.
+intersphinx_mapping = {'http://docs.python.org/': None}
diff --git a/dev-python/sqlite3dbm/metadata.xml b/dev-python/sqlite3dbm/metadata.xml
new file mode 100644
index 0000000..d02cc23
--- /dev/null
+++ b/dev-python/sqlite3dbm/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer><email>tampakrap@gentoo.org</email></maintainer>
+ <maintainer>
+ <email>della5@iinet.com.au</email>
+ <name>Ian Delaney aka idella4 proxy maintainer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/sqlite3dbm/sqlite3dbm-0.1.0.ebuild b/dev-python/sqlite3dbm/sqlite3dbm-0.1.0.ebuild
new file mode 100644
index 0000000..7f1c9aa
--- /dev/null
+++ b/dev-python/sqlite3dbm/sqlite3dbm-0.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_USE_WITH="sqlite"
+inherit distutils
+
+DESCRIPTION="An sqlite-backed dictionary"
+HOMEPAGE="http://pypi.python.org/pypi/sqlite3dbm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+IUSE="doc"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+REDEPEND=""
+DEPEND="${REDEPEND} dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+
+src_prepare() {
+ cp -R "${FILESDIR}"/conf.py docs || die
+}
+
+src_compile() {
+ use doc && emake -C docs text
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ docompress -x usr/share/doc/${P}/
+ dodoc -r docs/_build/{doctrees,text}
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize sqlite3dbm
+}
+
+pkg_postrm() {
+ python_mod_cleanup sqlite3dbm
+}