aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-19 16:50:28 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-19 16:50:28 +0800
commit64af587c39da40906e9a7c3d6af63c9324d5b643 (patch)
tree5b28e592e083940a212c1538a0931d82cf2c7bec /dev-python/xlutils
parentdev-python/[fabric,qserve,roman]] deleted, in the 'tree', Add testify (diff)
downloadimprovise-64af587c39da40906e9a7c3d6af63c9324d5b643.tar.gz
improvise-64af587c39da40906e9a7c3d6af63c9324d5b643.tar.bz2
improvise-64af587c39da40906e9a7c3d6af63c9324d5b643.zip
[dev-python/mwlib] Add mwlib, other cleanups, fixes
Diffstat (limited to 'dev-python/xlutils')
-rw-r--r--dev-python/xlutils/Manifest1
-rw-r--r--dev-python/xlutils/xlutils-1.5.1.ebuild23
-rw-r--r--dev-python/xlutils/xlutils-1.5.2.ebuild44
3 files changed, 65 insertions, 3 deletions
diff --git a/dev-python/xlutils/Manifest b/dev-python/xlutils/Manifest
index 0fba757..7266c59 100644
--- a/dev-python/xlutils/Manifest
+++ b/dev-python/xlutils/Manifest
@@ -1 +1,2 @@
DIST xlutils-1.5.1.tar.gz 41778 SHA256 0cc2ba30e218722d2ac6464d288c845c356515866f5c6c2ce0480d32905e47e1 SHA512 a8f747f342e566ba1de9208d5c2db181c600aa21a1cdaa4cabf21539b95eecbec763475805d476a923d12f24d1623f1d63f2224beeca2cd58ca702a3067f640c WHIRLPOOL 2b7d3c62f731b0f291a79a29e5c7d1672dd44e1e2984fa323cb228e79694f2a8b842a3be94a7d2594170447d19b9fb630dd3da26f2d868abd46238480653c416
+DIST xlutils-1.5.2.tar.gz 48579 SHA256 5b8f2bc41983722a63009c0ab6216227d6bbc0a0f945c9cab33cd1ebac7666d0 SHA512 5611b08516ebcfc08f43b7b5a793c0d53c9e0dfe12b597ea318f10e794d323f87b07df0f96f58b1d4542feb7339ab7c6527c956c7a7af7d8554e41dad85c63d8 WHIRLPOOL 7a1cc3ac03fbcd1c768de6a259adaaf33ca7827af8afc3d11fe03ba462797c0e173071214fbb791d497afb6ffe6577c9eca7a41577da2c51acdc88014d4587d4
diff --git a/dev-python/xlutils/xlutils-1.5.1.ebuild b/dev-python/xlutils/xlutils-1.5.1.ebuild
index ca2868e..0ec869c 100644
--- a/dev-python/xlutils/xlutils-1.5.1.ebuild
+++ b/dev-python/xlutils/xlutils-1.5.1.ebuild
@@ -6,6 +6,7 @@ EAPI=4
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="3.*"
+#DISTUTILS_SRC_TEST=setup.py
inherit distutils
DESCRIPTION="provides a collection of utilities for working with Excel files"
@@ -20,8 +21,24 @@ SLOT="0"
DOCS=( xlutils/readme.txt )
-RDEPEND="dev-python/xlwt
- dev-python/xlrd
+RDEPEND=">=dev-python/xlwt-0.7.3
+ >=dev-python/xlrd-0.7.3
dev-python/errorhandler"
DEPEND="${RDEPEND}
- dev-python/testfixtures"
+ >=dev-python/testfixtures-1.6.1
+ dev-python/mock"
+
+src_test() {
+ # https://github.com/python-excel/xlutils/issues/1
+ testing() {
+ pushd xlutils/tests > /dev/null
+ local exit_status=0
+ for test in test_*.py
+ do
+# PYTHONPATH="${S}":"${S}"/xlutils/tests/ nosetests $test
+ nosetests $test
+ done
+ popd > /dev/null
+ }
+ python_execute_function testing
+}
diff --git a/dev-python/xlutils/xlutils-1.5.2.ebuild b/dev-python/xlutils/xlutils-1.5.2.ebuild
new file mode 100644
index 0000000..e0ea557
--- /dev/null
+++ b/dev-python/xlutils/xlutils-1.5.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+#DISTUTILS_SRC_TEST=setup.py
+inherit distutils
+
+DESCRIPTION="provides a collection of utilities for working with Excel files"
+HOMEPAGE="http://pypi.python.org/pypi/xlutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+DOCS=( xlutils/readme.txt )
+
+RDEPEND=">=dev-python/xlwt-0.7.3
+ >=dev-python/xlrd-0.7.3
+ dev-python/errorhandler"
+DEPEND="${RDEPEND}
+ >=dev-python/testfixtures-1.6.1
+ dev-python/mock"
+
+src_test() {
+ # https://github.com/python-excel/xlutils/issues/1
+ testing() {
+ pushd xlutils/tests > /dev/null
+ local exit_status=0
+ for test in test_*.py
+ do
+ PYTHONPATH="${S}":"${S}"/xlutils/tests/ nosetests $test
+# nosetests $test
+ done
+ popd > /dev/null
+ }
+ python_execute_function testing
+}