aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-19 03:31:54 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-19 03:31:54 +0800
commit6e60499447b3a088c77c1d0f0d154b7a7986076e (patch)
tree27c180ad87e55ebf4f0258ed9110019b19ae02c5 /dev-python
parent[dev-python/bottle] ebuild made to support python3 (diff)
downloadimprovise-6e60499447b3a088c77c1d0f0d154b7a7986076e.tar.gz
improvise-6e60499447b3a088c77c1d0f0d154b7a7986076e.tar.bz2
improvise-6e60499447b3a088c77c1d0f0d154b7a7986076e.zip
dev-python/[fabric,qserve,roman]] deleted, in the 'tree', Add testify
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bottle/bottle-0.10.9.ebuild4
-rw-r--r--dev-python/fabric/Manifest1
-rw-r--r--dev-python/fabric/fabric-1.4.2.ebuild75
-rw-r--r--dev-python/fabric/files/client.key30
-rw-r--r--dev-python/fabric/files/client.key.pub1
-rw-r--r--dev-python/fabric/files/db.py5
-rw-r--r--dev-python/fabric/files/fabric-1.4.2-tests.patch133
-rw-r--r--dev-python/fabric/files/fabric-1.4.2-tests.patchr136
-rw-r--r--dev-python/fabric/files/gitignore14
-rw-r--r--dev-python/fabric/files/private.key15
-rw-r--r--dev-python/fabric/files/ssh_config12
-rw-r--r--dev-python/fabric/files/test_tasks.patch124
-rw-r--r--dev-python/fabric/files/testserver_ssh_config5
-rw-r--r--dev-python/fabric/metadata.xml8
-rw-r--r--dev-python/qserve/Manifest1
-rw-r--r--dev-python/qserve/metadata.xml10
-rw-r--r--dev-python/qserve/qserve-0.2.7.ebuild26
-rw-r--r--dev-python/roman/Manifest1
-rw-r--r--dev-python/roman/metadata.xml10
-rw-r--r--dev-python/roman/roman-1.4.0.ebuild22
-rw-r--r--dev-python/sqlite3dbm/Manifest1
-rw-r--r--dev-python/testify/Manifest1
-rw-r--r--dev-python/testify/testify-0.2.4.ebuild37
23 files changed, 41 insertions, 631 deletions
diff --git a/dev-python/bottle/bottle-0.10.9.ebuild b/dev-python/bottle/bottle-0.10.9.ebuild
index cdeb49a..0e11485 100644
--- a/dev-python/bottle/bottle-0.10.9.ebuild
+++ b/dev-python/bottle/bottle-0.10.9.ebuild
@@ -32,7 +32,7 @@ src_prepare() {
src_test() {
testing() {
- if [[ $(python_get_version --major) == "3" ]]; then
+ if [[ $(python_get_version --major) == 3 ]]; then
# test/views are templates, data files, not copied over
cp -a test/views/ build-${PYTHON_ABI}/lib/test/ || die "data file did not copy"
pushd build-${PYTHON_ABI}/lib/ > /dev/null
@@ -43,5 +43,5 @@ src_test() {
PYTHONPATH="build-${PYTHON_ABI}/lib/" "$(PYTHON)" test/testall.py
fi
}
- python_execute_function testing
+ python_execute_function testing
}
diff --git a/dev-python/fabric/Manifest b/dev-python/fabric/Manifest
deleted file mode 100644
index d858675..0000000
--- a/dev-python/fabric/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST Fabric-1.4.2.tar.gz 182298 SHA256 11bcd5dbb1c6e96311a5b6547816756d7bc6bcacb1d6528f8bedf6fde824de0c SHA512 f911357a3ae83f514f0b0e67e6a682606aee819cd19a4db275e455e2452a3b20bdad889ee38834514429dfd30b40dfba865a5e26e1b8500b1702654f2bf8f98b WHIRLPOOL 263a68de405b3e9b6e0fe962225af672acd7144ff35ade1cf2e4cbc33f62440fdb1a0fb30044beb9a3741813bfa55d8daf083291fe6fac6323836455ef74bbad
diff --git a/dev-python/fabric/fabric-1.4.2.ebuild b/dev-python/fabric/fabric-1.4.2.ebuild
deleted file mode 100644
index 55e5078..0000000
--- a/dev-python/fabric/fabric-1.4.2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.4.1.ebuild,v 1.1 2012/04/08 19:19:05 floppym Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-DISTUTILS_SRC_TEST=nosetests
-inherit distutils eutils
-
-MY_PN="Fabric"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Fabric is a simple, Pythonic tool for remote execution and deployment."
-HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test doc"
-PYTHON_MODNAME="fabfile fabric"
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND=">=dev-python/ssh-1.7.14"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? ( dev-python/fudge )"
-
-src_prepare() {
- # SIX files missing from the source. seds can be made into a patch any time.
- cp -R "${FILESDIR}"/ssh_config tests/support || return
- cp -R "${FILESDIR}"/{client.key,client.key.pub,private.key} tests || return
- cp -R "${FILESDIR}"/db.py tests/support/tree/ || return
- cp -R "${FILESDIR}"/testserver_ssh_config tests/support || return
-
- # Option --with-color for nosetests fails here.
- sed -e 's:--with-color::' -i fabfile/__init__.py || die
- # Once again a system /tmp folder is selected for logging, antagonising portage
- sed -e "s:/tmp/fab.log:"${T}"/logging/fab.log:" -i tests/server.py || die
- # This is a TODO to further investigate. /simple doesn't exists in the source
- sed -e 's:simple:support:' -i tests/{test_parallel.py,server.py} || die
- # test_parallel.py's 1 test calls the uncallable "ls /simple"
- # test_operations.py; FAILED (errors=42) of 68 tests pull error: [Errno 98] Address already in use. (Forget it)
- # test_network.py; Ran 52 tests; FAILED (errors=15); [Errno 98] related; rm for now
- # test_contrib.py; similar; SSHException: Error reading SSH protocol banner[Errno 104] fails all 3.
- rm -f tests/{test_parallel.py,test_operations.py,test_network.py,test_contrib.py} || die
-
- epatch "${FILESDIR}"/${P}-tests.patch \
- "${FILESDIR}"/test_tasks.patch
-
- distutils_src_prepare
-}
-
-# May not want this. conf.py, Makefile and /_static and /_templates from github not included.
-src_install() {
- distutils_src_install
- if use doc; then
- docompress -x usr/share/doc/${P}/files
- insinto usr/share/doc/${P}/files
- doins -r docs/*
- fi
- # This is a real curiosity, the fab script not compiled until install
-# testing() {
-# PYTHONPATH=.:test
-# "${ED}"usr/bin/fab test
-# }
-# use test && python_execute_function testing
-}
-
-#src_test() {
-# PYTHONPATH="${S}":"${S}"/tests
-# distutils_src_test -v tests/test_tasks.py
-#}
diff --git a/dev-python/fabric/files/client.key b/dev-python/fabric/files/client.key
deleted file mode 100644
index 65862f4..0000000
--- a/dev-python/fabric/files/client.key
+++ /dev/null
@@ -1,30 +0,0 @@
------BEGIN RSA PRIVATE KEY-----
-Proc-Type: 4,ENCRYPTED
-DEK-Info: DES-EDE3-CBC,F1AFE040F412E6D1
-
-cIBbwu1/PD9vjtyFn+xbpc2X9Uv9sllCRooLwkOv9rkBxDRItT8D5UiGHGIGIAvj
-eq9sUze8bXQeXs9zpJwMRH1kjdmCmnmRX0iXcsxSgnioL3aEGLTbXqxkUOnSgj4Y
-cJ1trT51XVRSBGlRHYPmF1IhYYW/RPZlFUPMJDE5s1moROU29DfnaboTREf8shJ9
-A/jHvKoivn4GgM1U6VcwwtijvmgrrB5KzqpRfTLf6Rxe6St3e4WjQusYWVP4BOmz
-ImQyaATcPwn5iMWPfvXohPQR/ajuoU9jzMM3DqzcrH7Q4VmpSTrmkdG7Ra5GfSE1
-O5WEiqNwUkfjAYIjbxo11gVtIH8ddsMuF5odsh2LVXYocHeZzRlZvsip2AePKiKX
-xMkZItP4xqFBfi0jnqCVkQGUdtRYhHomDUO8U0JtB3BFNT/L+LC+dsrj8G/FaQiD
-n8an2sDf1CrYXqfz3V3rGzuPDq/CKwPD8HeTpjZUT7bPUNsTNMVx58LiYShRV2uB
-zUn83diKX12xS+gyS5PfuujwQP93ZQXOP9agKSa2UlY2ojUxtpc1vxiEzcFcU9Zg
-2uLEbsRKW1qe2jLDTmRyty14rJmi7ocbjPUuEuw9Aj1v46jzhBXBPE7cWHGm1o2/
-/e0lGfLTtm3Q2SponTLTcHTrBvrDBRlDAN5sChhbaoEoUCHjTKo8aj6whDKfAw4Q
-KNHrOkkXyDyvd90c1loen5u5iaol+l5W+7LG3Sr5uRHMHAsF0MH9cZd/RQXMSY/U
-sQLWumskx/iSrbjFztW0La0bBCB6vHBYLervC3lrrmvnhfYrNBrZM8eH1hTSZUsT
-VFeKgm+KVkwEG/uXoI/XOge01b1oOHzKNKGT7Q5ogbV6w67LtOrSeTH0FCjHsN8z
-2LCQHWuII4h3b1U/Pg8N5Pz59+qraSrMZAHOROYc19r0HSS5gg7m1yD3IPXO73fI
-gLO0/44f/KYqVP2+FKgQo9enUSLI5GuMAfhWaTpeOpJNd10egSOB3SaJ7nn20/Pm
-vSBSL0KsSeXY4/Df43MuHu46PvYzRwKvZB7GJJJPi2XjdFqCxuoCuEqfaZxf1lnI
-ZhZFmsZE1rd7kgBYyn0VXn1AvrLjaLuvmsOKaFdO4TAbQpE3Pps6AdQ8EpJ62Gei
-0yZlXgh2+zZp5lRMfO5JFtr7/pVpIqnRKfaDk1XawWP7i1/0PnVXsR2G6yu6kbEg
-R/v2LKnp49TUldfNmVW8QHElw/LrCBW08iA+44vlGYdCU8nAW9Sy+y4plW+X32z8
-Viw82ISUcoJSHmRfzXOWaj24AftbSOzo2bRmCO+xkBkXFrhTI83Aqbu7TN/yejB8
-hDb04AVxzEkBTw/B0pLkJUt5lpcr9fZMvACHsL0gTRc5OPb4/zhG7y9npWgq5Snb
-ZnUAOi+ndnW8IL4y9YI6U7LBSyMvE7L7+QCnLJxVnO2NxjDCJVDDe6fLR9pRBCCC
-Sh3X/FNsu1YQzNIOvf75ri1zzqKmv4x6ETmmgs+vMGRl62s8SQcgWFEGAVrAP+uR
-ocx0chW3BWEQalRat2vBWpj1gyH2aHd8tgamb8XXFLK35iTk2/oCqQ==
------END RSA PRIVATE KEY-----
diff --git a/dev-python/fabric/files/client.key.pub b/dev-python/fabric/files/client.key.pub
deleted file mode 100644
index 889ae87..0000000
--- a/dev-python/fabric/files/client.key.pub
+++ /dev/null
@@ -1 +0,0 @@
-ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEA2FxgXlTZGk/JZMacwgMPC6LEd3efYgIdgK0RXGRMNs06aSyeEUwTKqmelNnElsRsUW68Ybosox0LoHGfTUj0gtSOqG+pb0QJQ5yslPBwBlL+WUC65HDzHdBrUf/bFR+rc02i2Ciraan4elvuLW07UfO5ceCOeJSYyNmrhN/vboHr3Pcv2QG717sEy/9pSAVzrriCqYFd6IFg9o6UhuSB7hvW4bzKXDHtz6OeXrC6U/FWxx3rYZg3h9K2SBGXLavqiJSkFgeSzn3geSbyAjTgowaZ8kNq4+Mc1hsAMtLZBKMBZUTuMjHpQR31nWloUUfuz5QhaORk1pJBmE90MqShiw== jforcier@ytram
diff --git a/dev-python/fabric/files/db.py b/dev-python/fabric/files/db.py
deleted file mode 100644
index 749f26f..0000000
--- a/dev-python/fabric/files/db.py
+++ /dev/null
@@ -1,5 +0,0 @@
-from fabric.api import task
-
-@task
-def migrate():
- pass
diff --git a/dev-python/fabric/files/fabric-1.4.2-tests.patch b/dev-python/fabric/files/fabric-1.4.2-tests.patch
deleted file mode 100644
index 4a1c881..0000000
--- a/dev-python/fabric/files/fabric-1.4.2-tests.patch
+++ /dev/null
@@ -1,133 +0,0 @@
-# tests/server.py is culpable for calling normalize(path) && FakeSFTPServer from server.py which fails from
-# missing attribute transport. Since normalise is also a missing attribute the functions that call it have
-# been removed until we can 'find it'.
-
-
-diff -ur Fabric-1.4.2.origFabric-1.4.2/fabric/network.py 2012-05-08 14:13:35.000000000 +0800
---- fabric/network.py 2012-05-14 04:22:18.946277740 +0800
-+++ fabric/network.py 2012-05-14 04:22:18.946277740 +0800
-@@ -8,9 +8,7 @@
- import getpass
- import os
- import re
--import threading
- import time
--import select
- import socket
- import sys
-
-@@ -120,7 +118,7 @@
- with open(path) as fd:
- conf.parse(fd)
- env._ssh_config = conf
-- except IOError, e:
-+ except IOError:
- abort("Unable to load SSH config file '%s'" % path)
- host = parse_host_string(host_string or env.host_string)['host']
- return env._ssh_config.lookup(host)
-diff -ur Fabric-1.4.2.orig/tests/test_utils.py Fabric-1.4.2/tests/test_utils.py
---- tests/test_utils.py 2012-05-08 14:13:35.000000000 +0800
-+++ tests/test_utils.py 2012-05-14 10:57:13.909820617 +0800
-@@ -14,7 +14,6 @@
-
-
- @mock_streams('stderr')
--@with_patched_object(output, 'warnings', True)
- def test_warn():
- """
- warn() should print 'Warning' plus given text
-@@ -59,7 +58,6 @@
-
-
- @mock_streams('stderr')
--@with_patched_object(output, 'aborts', True)
- def test_abort_message():
- """
- abort() should print 'Fatal error' plus exception value
-diff -ur Fabric-1.4.2.orig/tests/server.py Fabric-1.4.2/tests/server.py
---- tests/server.py 2012-02-26 11:35:12.000000000 +0800
-+++ tests/server.py 2012-05-14 12:03:03.736911142 +0800
-@@ -272,64 +272,7 @@
- """
- return canonicalize(path, self.server.home)
-
-- def list_folder(self, path):
-- path = self.files.normalize(path)
-- expanded_files = map(expand, self.files)
-- expanded_path = expand(path)
-- candidates = [x for x in expanded_files if contains(x, expanded_path)]
-- children = []
-- for candidate in candidates:
-- cut = candidate[:len(expanded_path) + 1]
-- if cut not in children:
-- children.append(cut)
-- results = [self.stat(os.path.join(*x)) for x in children]
-- bad = not results or any(x == ssh.SFTP_NO_SUCH_FILE for x in results)
-- return ssh.SFTP_NO_SUCH_FILE if bad else results
--
-- def open(self, path, flags, attr):
-- path = self.files.normalize(path)
-- try:
-- fobj = self.files[path]
-- except KeyError:
-- if flags & os.O_WRONLY:
-- # Only allow writes to files in existing directories.
-- if os.path.dirname(path) not in self.files:
-- return ssh.SFTP_NO_SUCH_FILE
-- self.files[path] = fobj = FakeFile("", path)
-- # No write flag means a read, which means they tried to read a
-- # nonexistent file.
-- else:
-- return ssh.SFTP_NO_SUCH_FILE
-- f = FakeSFTPHandle()
-- f.readfile = f.writefile = fobj
-- return f
--
-- def stat(self, path):
-- path = self.files.normalize(path)
-- try:
-- fobj = self.files[path]
-- except KeyError:
-- return ssh.SFTP_NO_SUCH_FILE
-- return fobj.attributes
--
-- # Don't care about links right now
-- lstat = stat
--
-- def chattr(self, path, attr):
-- path = self.files.normalize(path)
-- if path not in self.files:
-- return ssh.SFTP_NO_SUCH_FILE
-- # Attempt to gracefully update instead of overwrite, since things like
-- # chmod will call us with an SFTPAttributes object that only exhibits
-- # e.g. st_mode, and we don't want to lose our filename or size...
-- for which in "size uid gid mode atime mtime".split():
-- attname = "st_" + which
-- incoming = getattr(attr, attname)
-- if incoming is not None:
-- setattr(self.files[path].attributes, attname, incoming)
-- return ssh.SFTP_OK
--
-- def mkdir(self, path, attr):
-+ def mkdir(self, path, attr):
- self.files[path] = None
- return ssh.SFTP_OK
-
-diff -ur Fabric-1.4.2.orig/tests/test_server.py Fabric-1.4.2/tests/test_server.py
---- tests/test_server.py 2012-02-26 11:35:12.000000000 +0800
-+++ tests/test_server.py 2012-05-14 12:44:19.583967857 +0800
-@@ -84,14 +84,3 @@
- # testable since it's all implementing 'ssh' interface stuff.)
- server = AttrHolder()
- server.files = file_map
-- interface = FakeSFTPServer(server)
-- results = interface.list_folder(arg)
-- # In this particular suite of tests, all results should be a file list,
-- # not "no files found"
-- ok_(results != ssh.SFTP_NO_SUCH_FILE)
-- # Grab filename from SFTPAttribute objects in result
-- output = map(lambda x: x.filename, results)
-- # Yield test generator
-- eq_.description = "list_folder: %s" % desc
-- yield eq_, set(expected), set(output)
-- del eq_.description
diff --git a/dev-python/fabric/files/fabric-1.4.2-tests.patchr b/dev-python/fabric/files/fabric-1.4.2-tests.patchr
deleted file mode 100644
index 9ac0db6..0000000
--- a/dev-python/fabric/files/fabric-1.4.2-tests.patchr
+++ /dev/null
@@ -1,136 +0,0 @@
-diff -ur Fabric-1.4.2.origFabric-1.4.2/fabric/network.py 2012-05-08 14:13:35.000000000 +0800
---- fabric/network.py 2012-05-14 04:22:18.946277740 +0800
-+++ fabric/network.py 2012-05-14 04:22:18.946277740 +0800
-@@ -8,9 +8,7 @@
- import getpass
- import os
- import re
--import threading
- import time
--import select
- import socket
- import sys
-
-@@ -120,7 +118,7 @@
- with open(path) as fd:
- conf.parse(fd)
- env._ssh_config = conf
-- except IOError, e:
-+ except IOError:
- abort("Unable to load SSH config file '%s'" % path)
- host = parse_host_string(host_string or env.host_string)['host']
- return env._ssh_config.lookup(host)
-#@@ -202,6 +200,7 @@
-# 'user': user, 'host': host, 'port': port, 'host_string': host_string
-# }
-#
-#+
- def from_dict(arg): return join_host_strings(arg['user'], arg['host'], arg['port'])
- return join_host_strings(arg['user'], arg['host'], arg['port'])
-
-diff -ur Fabric-1.4.2.orig/tests/test_utils.py Fabric-1.4.2/tests/test_utils.py
---- tests/test_utils.py 2012-05-08 14:13:35.000000000 +0800
-+++ tests/test_utils.py 2012-05-14 10:57:13.909820617 +0800
-@@ -14,7 +14,6 @@
-
-
- @mock_streams('stderr')
--@with_patched_object(output, 'warnings', True)
- def test_warn():
- """
- warn() should print 'Warning' plus given text
-@@ -59,7 +58,6 @@
-
-
- @mock_streams('stderr')
--@with_patched_object(output, 'aborts', True)
- def test_abort_message():
- """
- abort() should print 'Fatal error' plus exception value
-diff -ur Fabric-1.4.2.orig/tests/server.py Fabric-1.4.2/tests/server.py
---- tests/server.py 2012-02-26 11:35:12.000000000 +0800
-+++ tests/server.py 2012-05-14 12:03:03.736911142 +0800
-@@ -272,64 +272,7 @@
- """
- return canonicalize(path, self.server.home)
-
-- def list_folder(self, path):
-- path = self.files.normalize(path)
-- expanded_files = map(expand, self.files)
-- expanded_path = expand(path)
-- candidates = [x for x in expanded_files if contains(x, expanded_path)]
-- children = []
-- for candidate in candidates:
-- cut = candidate[:len(expanded_path) + 1]
-- if cut not in children:
-- children.append(cut)
-- results = [self.stat(os.path.join(*x)) for x in children]
-- bad = not results or any(x == ssh.SFTP_NO_SUCH_FILE for x in results)
-- return ssh.SFTP_NO_SUCH_FILE if bad else results
--
-- def open(self, path, flags, attr):
-- path = self.files.normalize(path)
-- try:
-- fobj = self.files[path]
-- except KeyError:
-- if flags & os.O_WRONLY:
-- # Only allow writes to files in existing directories.
-- if os.path.dirname(path) not in self.files:
-- return ssh.SFTP_NO_SUCH_FILE
-- self.files[path] = fobj = FakeFile("", path)
-- # No write flag means a read, which means they tried to read a
-- # nonexistent file.
-- else:
-- return ssh.SFTP_NO_SUCH_FILE
-- f = FakeSFTPHandle()
-- f.readfile = f.writefile = fobj
-- return f
--
-- def stat(self, path):
-- path = self.files.normalize(path)
-- try:
-- fobj = self.files[path]
-- except KeyError:
-- return ssh.SFTP_NO_SUCH_FILE
-- return fobj.attributes
--
-- # Don't care about links right now
-- lstat = stat
--
-- def chattr(self, path, attr):
-- path = self.files.normalize(path)
-- if path not in self.files:
-- return ssh.SFTP_NO_SUCH_FILE
-- # Attempt to gracefully update instead of overwrite, since things like
-- # chmod will call us with an SFTPAttributes object that only exhibits
-- # e.g. st_mode, and we don't want to lose our filename or size...
-- for which in "size uid gid mode atime mtime".split():
-- attname = "st_" + which
-- incoming = getattr(attr, attname)
-- if incoming is not None:
-- setattr(self.files[path].attributes, attname, incoming)
-- return ssh.SFTP_OK
--
-- def mkdir(self, path, attr):
-+ def mkdir(self, path, attr):
- self.files[path] = None
- return ssh.SFTP_OK
-
-diff -ur Fabric-1.4.2.orig/tests/test_server.py Fabric-1.4.2/tests/test_server.py
---- tests/test_server.py 2012-02-26 11:35:12.000000000 +0800
-+++ tests/test_server.py 2012-05-14 12:44:19.583967857 +0800
-@@ -84,14 +84,3 @@
- # testable since it's all implementing 'ssh' interface stuff.)
- server = AttrHolder()
- server.files = file_map
-- interface = FakeSFTPServer(server)
-- results = interface.list_folder(arg)
-- # In this particular suite of tests, all results should be a file list,
-- # not "no files found"
-- ok_(results != ssh.SFTP_NO_SUCH_FILE)
-- # Grab filename from SFTPAttribute objects in result
-- output = map(lambda x: x.filename, results)
-- # Yield test generator
-- eq_.description = "list_folder: %s" % desc
-- yield eq_, set(expected), set(output)
-- del eq_.description
diff --git a/dev-python/fabric/files/gitignore b/dev-python/fabric/files/gitignore
deleted file mode 100644
index 3af1e5b..0000000
--- a/dev-python/fabric/files/gitignore
+++ /dev/null
@@ -1,14 +0,0 @@
-*~
-*.pyc
-*.pyo
-*.pyt
-*.pytc
-.DS_Store
-.*.swp
-Fabric.egg-info
-.coverage
-docs/_build
-dist
-build/
-tags
-TAGS
diff --git a/dev-python/fabric/files/private.key b/dev-python/fabric/files/private.key
deleted file mode 100644
index 1217369..0000000
--- a/dev-python/fabric/files/private.key
+++ /dev/null
@@ -1,15 +0,0 @@
------BEGIN RSA PRIVATE KEY-----
-MIICWgIBAAKBgQDTj1bqB4WmayWNPB+8jVSYpZYk80Ujvj680pOTh2bORBjbIAyz
-oWGW+GUjzKxTiiPvVmxFgx5wdsFvF03v34lEVVhMpouqPAYQ15N37K/ir5XY+9m/
-d8ufMCkjeXsQkKqFbAlQcnWMCRnOoPHS3I4vi6hmnDDeeYTSRvfLbW0fhwIBIwKB
-gBIiOqZYaoqbeD9OS9z2K9KR2atlTxGxOJPXiP4ESqP3NVScWNwyZ3NXHpyrJLa0
-EbVtzsQhLn6rF+TzXnOlcipFvjsem3iYzCpuChfGQ6SovTcOjHV9z+hnpXvQ/fon
-soVRZY65wKnF7IAoUwTmJS9opqgrN6kRgCd3DASAMd1bAkEA96SBVWFt/fJBNJ9H
-tYnBKZGw0VeHOYmVYbvMSstssn8un+pQpUm9vlG/bp7Oxd/m+b9KWEh2xPfv6zqU
-avNwHwJBANqzGZa/EpzF4J8pGti7oIAPUIDGMtfIcmqNXVMckrmzQ2vTfqtkEZsA
-4rE1IERRyiJQx6EJsz21wJmGV9WJQ5kCQQDwkS0uXqVdFzgHO6S++tjmjYcxwr3g
-H0CoFYSgbddOT6miqRskOQF3DZVkJT3kyuBgU2zKygz52ukQZMqxCb1fAkASvuTv
-qfpH87Qq5kQhNKdbbwbmd2NxlNabazPijWuphGTdW0VfJdWfklyS2Kr+iqrs/5wV
-HhathJt636Eg7oIjAkA8ht3MQ+XSl9yIJIS8gVpbPxSw5OMfw0PjVE7tBdQruiSc
-nvuQES5C9BMHjF39LZiGH1iLQy7FgdHyoP+eodI7
------END RSA PRIVATE KEY----
diff --git a/dev-python/fabric/files/ssh_config b/dev-python/fabric/files/ssh_config
deleted file mode 100644
index 2b06eb4..0000000
--- a/dev-python/fabric/files/ssh_config
+++ /dev/null
@@ -1,12 +0,0 @@
-Host *
- User satan
- Port 666
- IdentityFile foobar.pub
-
-Host myhost
- User neighbor
- Port 664
- IdentityFile neighbor.pub
-
-Host myalias
- HostName otherhost
diff --git a/dev-python/fabric/files/test_tasks.patch b/dev-python/fabric/files/test_tasks.patch
deleted file mode 100644
index 63b3e96..0000000
--- a/dev-python/fabric/files/test_tasks.patch
+++ /dev/null
@@ -1,124 +0,0 @@
-# First off upstream have had the issue put to them and he closed it on the 1st viewing
-# because it worked for them. Their setup employs pip and the fab script which basically calls nosetests.
-# https://github.com/fabric/fabric/issues/641
-# run("ls /simple") runs bash ls /simple && returns data for a remote or local host. It appears quite
-# erronoeous since there is no simple folder in the source. Until we can figure or create some valid data
-# for run("ls /folder") anything that employs it faulters.
-# There is what appears to be a separate flaw in the tests where the Class SSHHandler(BaseRequestHandler) in
-# line 292 of tests/server.py has no attribute transport. This line
-# """Define handler class inline so it can access serve_responses' args"""
-# indicates it ia an inline Class. I suspect it doesn't achieve accessing serve_responses' args
-# assuming that's where attribute transport is delivered. Once again, upstream said it works here.
-# He did offer to help get it working so I hope he delivers.
-
-diff -ur Fabric-1.4.2.orig/tests/test_tasks.py Fabric-1.4.2/tests/test_tasks.py
---- tests/test_tasks.py 2012-05-08 14:13:35.000000000 +0800
-+++ tests/test_tasks.py 2012-05-14 09:12:14.031676299 +0800
-@@ -331,41 +331,7 @@
- return "foo"
- eq_(execute(task), {'<local-only>': 'foo'})
-
-- @server(port=2200)
-- @server(port=2201)
-- def test_should_return_dict_for_serial_use_case(self):
-- """
-- Networked but serial tasks should return per-host-string dict
-- """
-- ports = [2200, 2201]
-- hosts = map(lambda x: '127.0.0.1:%s' % x, ports)
-- def task():
-- run("ls /simple")
-- return "foo"
-- with hide('everything'):
-- eq_(execute(task, hosts=hosts), {
-- '127.0.0.1:2200': 'foo',
-- '127.0.0.1:2201': 'foo'
-- })
--
-- @server()
-- def test_should_preserve_None_for_non_returning_tasks(self):
-- """
-- Tasks which don't return anything should still show up in the dict
-- """
-- def local_task():
-- pass
-- def remote_task():
-- with hide('everything'):
-- run("ls /simple")
-- eq_(execute(local_task), {'<local-only>': None})
-- with hide('everything'):
-- eq_(
-- execute(remote_task, hosts=[env.host_string]),
-- {env.host_string: None}
-- )
--
-- def test_should_use_sentinel_for_tasks_that_errored(self):
-+ def test_should_use_sentinel_for_tasks_that_errored(self):
- """
- Tasks which errored but didn't abort should contain an eg NetworkError
- """
-@@ -376,21 +342,6 @@
- retval = execute(task, hosts=[host_string])
- assert isinstance(retval[host_string], NetworkError)
-
-- @server(port=2200)
-- @server(port=2201)
-- def test_parallel_return_values(self):
-- """
-- Parallel mode should still return values as in serial mode
-- """
-- @parallel
-- @hosts('127.0.0.1:2200', '127.0.0.1:2201')
-- def task():
-- run("ls /simple")
-- return env.host_string.split(':')[1]
-- with hide('everything'):
-- retval = execute(task)
-- eq_(retval, {'127.0.0.1:2200': '2200', '127.0.0.1:2201': '2201'})
--
- @with_fakes
- def test_should_work_with_Task_subclasses(self):
- """
-@@ -408,42 +408,3 @@
- # Don't update env.host/host_string/etc
- pass
-
-- @server(port=2200)
-- @server(port=2201)
-- def test_should_not_mutate_its_own_env_vars(self):
-- """
-- internal env changes should not bleed out, but task env changes should
-- """
-- # Task that uses a handful of features which involve env vars
-- @parallel
-- @hosts('username@127.0.0.1:2200', 'username@127.0.0.1:2201')
-- def mytask():
-- run("ls /simple")
-- # Pre-assertions
-- assertions = {
-- 'parallel': False,
-- 'all_hosts': [],
-- 'host': None,
-- 'hosts': [],
-- 'host_string': None
-- }
-- for key, value in assertions.items():
-- eq_(env[key], value)
-- # Run
-- with hide('everything'):
-- result = execute(mytask)
-- eq_(len(result), 2)
-- # Post-assertions
-- for key, value in assertions.items():
-- eq_(env[key], value)
--
-- @server()
-- def test_should_allow_task_to_modify_env_vars(self):
-- @hosts('username@127.0.0.1:2200')
-- def mytask():
-- run("ls /simple")
-- env.foo = "bar"
-- with hide('everything'):
-- execute(mytask)
-- eq_(env.foo, "bar")
-- eq_(env.host_string, None)
diff --git a/dev-python/fabric/files/testserver_ssh_config b/dev-python/fabric/files/testserver_ssh_config
deleted file mode 100644
index a975fc7..0000000
--- a/dev-python/fabric/files/testserver_ssh_config
+++ /dev/null
@@ -1,5 +0,0 @@
-Host testserver
- # TODO: get these pulling from server.py. Meh.
- HostName 127.0.0.1
- Port 2200
- User username
diff --git a/dev-python/fabric/metadata.xml b/dev-python/fabric/metadata.xml
deleted file mode 100644
index d64f199..0000000
--- a/dev-python/fabric/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>python</herd>
- <upstream>
- <remote-id type="pypi">Fabric</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/qserve/Manifest b/dev-python/qserve/Manifest
deleted file mode 100644
index 52e0ba4..0000000
--- a/dev-python/qserve/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST qserve-0.2.7.zip 18646 SHA256 f274ca0a95fb5e91677a658c58fec0392e7e0e1280ec3d855627efe9b72b1abd SHA512 d5b02893572264a3036d1b4cbf5a7023ad4ff7d8cc97c5f3e8532ab0f3c8108ec2eb155eee534c3f56061e2496a47f13f2c859b2ec938a76c2d24ee58c17383f WHIRLPOOL 4d6b23ecdfb6b2b1920b5f6405c54da5c5ba73923333bc289214d0956e162a2d421285f5c40242c5573614ba49edebe5a3cd11741134e6ead30812d5d58929a3
diff --git a/dev-python/qserve/metadata.xml b/dev-python/qserve/metadata.xml
deleted file mode 100644
index d02cc23..0000000
--- a/dev-python/qserve/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>python</herd>
- <maintainer><email>tampakrap@gentoo.org</email></maintainer>
- <maintainer>
- <email>della5@iinet.com.au</email>
- <name>Ian Delaney aka idella4 proxy maintainer</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/qserve/qserve-0.2.7.ebuild b/dev-python/qserve/qserve-0.2.7.ebuild
deleted file mode 100644
index 008c8c8..0000000
--- a/dev-python/qserve/qserve-0.2.7.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-DISTUTILS_SRC_TEST=py.test
-PYTHON_TESTS_RESTRICTED_ABIS="*-pypy-*"
-inherit distutils
-
-DESCRIPTION="A job queue server"
-HOMEPAGE="http://pypi.python.org/pypi/qserve/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-PYTHON_MODNAME="qs"
-
-KEYWORDS="~amd64"
-IUSE=""
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="${REDEPEND} dev-python/setuptools
- test? ( dev-python/gevent
- dev-python/greenlet )"
diff --git a/dev-python/roman/Manifest b/dev-python/roman/Manifest
deleted file mode 100644
index c00f1d3..0000000
--- a/dev-python/roman/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST roman-1.4.0.tar.gz 3033 SHA256 f7bf0304e2a79279cc06d245b2b7f5a3872cddbaa2932db0cbacc12a77e477ec SHA512 e42f1b9e5b979773dfacc67af89bee470391e9eff2bb2eba78f0fe890fa3b6571536986bad0cef28029d9c65261fa199a1cfe4533d0552934b871a33e74a1b2b WHIRLPOOL 23454968d7d19557e63e74df6f689dfae5d878ce08162b47532694566695375aaacbaf0ee494fc73d4f3a750e4ec334fca7982eb58fa0f7eeab0dfe4c94db67c
diff --git a/dev-python/roman/metadata.xml b/dev-python/roman/metadata.xml
deleted file mode 100644
index d02cc23..0000000
--- a/dev-python/roman/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>python</herd>
- <maintainer><email>tampakrap@gentoo.org</email></maintainer>
- <maintainer>
- <email>della5@iinet.com.au</email>
- <name>Ian Delaney aka idella4 proxy maintainer</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/roman/roman-1.4.0.ebuild b/dev-python/roman/roman-1.4.0.ebuild
deleted file mode 100644
index e280b2d..0000000
--- a/dev-python/roman/roman-1.4.0.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.*"
-inherit distutils
-
-DESCRIPTION="An Integer to Roman numerals converter"
-HOMEPAGE="http://pypi.python.org/pypi/roman-/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-PYTHON_MODNAME="roman.py"
-
-KEYWORDS="~amd64"
-IUSE=""
-LICENSE="PSF-2"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="${REDEPEND} dev-python/setuptools"
diff --git a/dev-python/sqlite3dbm/Manifest b/dev-python/sqlite3dbm/Manifest
index 98ffb45..7cb41be 100644
--- a/dev-python/sqlite3dbm/Manifest
+++ b/dev-python/sqlite3dbm/Manifest
@@ -1 +1,2 @@
DIST sqlite3dbm-0.1.0.tar.gz 9561 SHA256 1f39467f70ce7398e353ca21b622bd0ba156a78004e853daf3ccb59981782f6f SHA512 35b96dffdf82d71c7418f4471413f4d2f6dca4adc74dd0543a5aa8681f67ef4e0b4d124227f695ef7479b78964f97db8ef031e699b4a5887c981edc880298dad WHIRLPOOL 465352f386058137f29fef83a8248d580e6591987c73d9d998fa093055dfb27fdabbe3c99c57ad5c2bcb75c9c60fdb2fcdb0bf2152fd4acf95f075da71f56483
+DIST sqlite3dbm-0.1.4.tar.gz 18979 SHA256 b3c06b820f1375d4cd77986605d4d9d8ca0e85934b1ce26a514dc134513dc2e8 SHA512 79d2eb9b100f1af71340f8b4746178641e9f75fed65a0adf44dfc71a3a642041f8afbcb50b471e9f074a31f0ccc7e1daafc162387c9e5835daa0987261c2e4bd WHIRLPOOL ae6d19cd2f8d740af5e6ccd0db2e904b98e279e6d336ee4f780a37d0fbf8db2fb486aeed6f2d4cbe1d45db901231d7967a577a01e5b5f9d2e44580177bd5a686
diff --git a/dev-python/testify/Manifest b/dev-python/testify/Manifest
new file mode 100644
index 0000000..3414ca5
--- /dev/null
+++ b/dev-python/testify/Manifest
@@ -0,0 +1 @@
+DIST testify-0.2.4.tar.gz 44584 SHA256 681423a89c7d0a10d6672c023d9e087c5b875e09c6562dd9eda8bdb8bb99593e SHA512 89c4b6c67c66ebcd9838d10761b66c70d79105768e29dc486c7a035afe1c197e29e1c2ee5e2249f3d35f6eb67960b0db6a78bfb793335e2f5017cb17b1c47a5e WHIRLPOOL 31b65f6c5dab4c0b95558cf96909ae1de569f5ee71def519b9ed90e79e96a81cc2e730db2b0e57c8ce456f084d784e04756241ccb9f23f269e6aa051b5ed4206
diff --git a/dev-python/testify/testify-0.2.4.ebuild b/dev-python/testify/testify-0.2.4.ebuild
new file mode 100644
index 0000000..ea252f9
--- /dev/null
+++ b/dev-python/testify/testify-0.2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS=1
+#RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="A Testing Framework"
+HOMEPAGE="http://pypi.python.org/pypi/testify http://github.com/Yelp/Testify"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND} dev-python/setuptools
+ test? ( www-servers/tornado )"
+
+src_prepare() {
+ sed -e s':srv._socket:srv.add_socket:' -i test/plugins/http_reporter_test.py
+}
+
+src_test() {
+ testing() {
+ pushd test > /dev/null
+# "$(PYTHON)" ../bin/testify test
+ PYTHONPATH="../build-${PYTHON_ABI}/lib:"${S}":." "$(PYTHON)" ../bin/testify test
+ popd > /dev/null
+ }
+ python_execute_function testing
+}