aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-auth-ldap/django-auth-ldap-1.0.19.ebuild')
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.0.19.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.0.19.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.0.19.ebuild
deleted file mode 100644
index ce836c4..0000000
--- a/dev-python/django-auth-ldap/django-auth-ldap-1.0.19.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-auth-ldap/django-auth-ldap-1.0.19.ebuild,v 1.2 2012/04/25 12:55:49 tampakrap Exp $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.*"
-inherit distutils
-
-DESCRIPTION="A flexible and capable API layer for Django utilising serialisers"
-HOMEPAGE="http://pypi.python.org/pypi/django-auth-ldap http://bitbucket.org/psagers/django-auth-ldap/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-LICENSE="BSD"
-SLOT="0"
-PYTHON_MODNAME="django_auth_ldap"
-
-RDEPEND=""
-DEPEND="${RDEPEND} >=dev-python/django-1.0
- dev-python/python-ldap
- doc? ( dev-python/sphinx )"
-
-src_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- # Since python3 not supported, this works for python2 && pypy
- # Tested, django_auth_ldap/tests.py IS being run
- testing() {
- PYTHONPATH=. "$(PYTHON)" django_auth_ldap/tests.py
- einfo "tests completed for python"$(python_get_version)
- }
- python_execute_function testing
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- emake -C docs html
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/*
- fi
-}