aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild')
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild
deleted file mode 100644
index b9fe653..0000000
--- a/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/egenix-mx-base-3.2.3.ebuild,v 1.3 2012/04/23 11:12:49 xarthisius Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-
-inherit distutils eutils
-
-DESCRIPTION="eGenix utils for Python"
-HOMEPAGE="http://www.egenix.com/products/python/mxBase http://pypi.python.org/pypi/egenix-mx-base"
-SRC_URI="http://downloads.egenix.com/python/${P}.tar.gz"
-
-LICENSE="eGenixPublic-1.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-PYTHON_MODNAME="mx"
-
-src_prepare() {
- distutils_src_prepare
-
- # Don't install documentation in site-packages directories.
- sed -e "/\/Doc\//d" -i egenix_mx_base.py || die "sed failed"
-
- # Avoid unnecessary overriding of settings. Distutils in Gentoo is patched in better way.
- sed -e 's/if compiler.compiler_type == "unix":/if False:/' -i mxSetup.py || die "sed failed"
-
- epatch "${FILESDIR}"/${P}-distutils.patch
-
- # Replace/disable stupid flawed therefore failing tests
-
- # testticks.py; print layout is wrong
- # testvlad.py, The test should pass to prove the point, not fail
- epatch "${FILESDIR}"/${P}-test.patch || die
-
- # testernesto.py;Chnage sys.argv[1] to sys.argv[0]; works
- sed -e 's:[1]:0:' -i mx/BeeBase/mxBeeBase/testernesto.py ||die
-
- # testrichard.py;Change print to sane syntax
- sed -e 's:print date + rubish:print date,rubish:' -i mx/DateTime/mxDateTime/testrichard.py || die
-
- # testsubclassing.py; derived class from mxDateTime appears plain wrong
- rm -rf mx/DateTime/mxDateTime/testsubclassing.py || die
-
- # Reads a file that does NOT exist
- rm -f mx/TextTools/mxTextTools/testkj.py
-
- # Calls a module that is not included, does NOT exist
- rm -f mx/Tools/mxTools/test_safecall.py || die
-
- # The only one I can't resolve
- rm -f mx/TextTools/mxTextTools/testPickleSegFault.py || die
-}
-
-src_compile() {
- # mxSetup.py uses BASECFLAGS variable.
- BASECFLAGS="${CFLAGS}" distutils_src_compile
-}
-
-src_test() {
- testing() {
- for test in $(find "build-${PYTHON_ABI}/" -name "*test*.py" | sort)
- do
- PYTHONPATH="build-${PYTHON_ABI}/lib/" \
- "$(PYTHON)" ${test}
- done
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dohtml -a html -r mx
- insinto /usr/share/doc/${PF}
- find -iname "*.pdf" | xargs doins
-
- installation_of_headers() {
- local header
- dodir "$(python_get_includedir)/mx" || return 1
- while read -d $'\0' header; do
- mv -f "${header}" "${ED}$(python_get_includedir)/mx" || return 1
- done < <(find "${ED}$(python_get_sitedir)/mx" -type f -name "*.h" -print0)
- }
- python_execute_function -q installation_of_headers
-}