aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testfixtures/testfixtures-2.3.4.ebuild')
-rw-r--r--dev-python/testfixtures/testfixtures-2.3.4.ebuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/dev-python/testfixtures/testfixtures-2.3.4.ebuild b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
index 4a84ad5..31cae10 100644
--- a/dev-python/testfixtures/testfixtures-2.3.4.ebuild
+++ b/dev-python/testfixtures/testfixtures-2.3.4.ebuild
@@ -35,10 +35,7 @@ src_prepare() {
src_compile() {
distutils_src_compile
- # Needs abs path
- if use doc; then
- PYTHONPATH="${S}" emake -C docs html
- fi
+ use doc && emake -C docs html
}
src_test() {
@@ -49,8 +46,5 @@ src_install() {
distutils_src_install
if use doc; then
dohtml -r docs/_build/html/
- docompress -x usr/share/doc/${P}/doctrees
- insinto usr/share/doc/${P}/
- doins -r docs/_build/doctrees/
fi
}