aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/veromix-plasmoid/veromix-plasmoid-0.13.1.ebuild')
-rw-r--r--dev-python/veromix-plasmoid/veromix-plasmoid-0.13.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/veromix-plasmoid/veromix-plasmoid-0.13.1.ebuild b/dev-python/veromix-plasmoid/veromix-plasmoid-0.13.1.ebuild
new file mode 100644
index 0000000..9e9ea50
--- /dev/null
+++ b/dev-python/veromix-plasmoid/veromix-plasmoid-0.13.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+#SUPPORT_PYTHON_ABIS="1"
+inherit python versionator
+
+MY_P="$(version_format_string '2011-09-15_$1.$2.$3')_veromix.plasmoid"
+DESCRIPTION="A Pulseaudio volume control written in python"
+HOMEPAGE="http://code.google.com/p/veromix-plasmoid"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P} -> ${PN}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkf_setup() {
+ python_set_active_version 2
+# python_pkg_setup
+}
+
+src_compile() {
+ :
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/kde4/apps/plasma/plasmoids/${PN}/contents/code
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/kde4/apps/plasma/plasmoids/${PN}/contents/code
+}