aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Broadhead <jamesbroadhead@gmail.com>2016-11-16 13:42:35 +0000
committerJames Broadhead <jamesbroadhead@gmail.com>2016-11-16 13:43:53 +0000
commit944c629ed1df23f39b751091010e93b657890b4e (patch)
tree9f785460cb9207ed75a48100bef4c3e206379cbb
parentupdate README (diff)
downloadjamesbroadhead-944c629ed1df23f39b751091010e93b657890b4e.tar.gz
jamesbroadhead-944c629ed1df23f39b751091010e93b657890b4e.tar.bz2
jamesbroadhead-944c629ed1df23f39b751091010e93b657890b4e.zip
Add pix, the linux-mint X-apps fork of gthumb
ebuild is a copy & update of the gthumb ebuild in the main tree
-rw-r--r--media-gfx/pix/Manifest3
-rw-r--r--media-gfx/pix/metadata.xml14
-rw-r--r--media-gfx/pix/pix-1.2.0.ebuild93
3 files changed, 110 insertions, 0 deletions
diff --git a/media-gfx/pix/Manifest b/media-gfx/pix/Manifest
new file mode 100644
index 0000000..47c7050
--- /dev/null
+++ b/media-gfx/pix/Manifest
@@ -0,0 +1,3 @@
+DIST 1.2.0.tar.gz 4711261 SHA256 b952171b8e2212cabd7063f12049c583c77b05aab4e86322d37444a434b2ac55 SHA512 d19fcb6dfda1f108c04905373dae5785d3d7730aa13b99287adbee1b234c83e5275c459461516db702cfc3e885c9890db675410607bba5a7855fb2b751aa9bb1 WHIRLPOOL 0f6cd3788d2fa4c7a5a99fed2330c51daf761b2e9814417b35380335a7721791218c8ce08c147a0367a6f5b9a7896d846b44c7cc0483295d5fa2ef13af2536ca
+EBUILD pix-1.2.0.ebuild 2411 SHA256 a24b83699e5f309e018c52c0b09edab11cda8a588ecc44d1aef4f14cda699a3f SHA512 ac1a9dc70d3f345f494ffc77106ff3d7a6988dcc7a947c37d2cdf082ed2863a9eacd1f76dac20f0c29ac61a11cf216aefe6b5e940387d97ea64d8f02cd732034 WHIRLPOOL eaca18ccd835934f7ad8fa5d6c1d0e9dfa7b8629baf26acf6fe7fe0de82b7bb88bba0976a4ae05dbcd6baf7f74c4df114d28ae99a8f0da163426493740de723a
+MISC metadata.xml 556 SHA256 6588f8411e37bfb0964d354d38bf449179e9c90ad995b2674f745ea49ebb3c7f SHA512 93979d481efa334ef94d23abc755ac4a333d327154c110da091d213a73f0c4d0ab216e73af0085b0842af7a782c25e4d69e4b9bd76fffc610272c043f37bad4b WHIRLPOOL f3234cd00233f3ebe79d2860470f69af4dc5157db95f403205863b791acd18c5a95c287034660e3a23f7925a673391618f5a0a8d6eec4eee0b6c078eb7a87148
diff --git a/media-gfx/pix/metadata.xml b/media-gfx/pix/metadata.xml
new file mode 100644
index 0000000..13064f9
--- /dev/null
+++ b/media-gfx/pix/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="http">Enable webservice integration through <pkg>net-libs/libsoup</pkg></flag>
+ <flag name="json">Compile code that uses the libjson-glib library</flag>
+ <flag name="slideshow">Enable slideshow plugin</flag>
+ <flag name="webp">Enable support for webp image format</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-gfx/pix/pix-1.2.0.ebuild b/media-gfx/pix/pix-1.2.0.ebuild
new file mode 100644
index 0000000..148870c
--- /dev/null
+++ b/media-gfx/pix/pix-1.2.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2
+
+DESCRIPTION="A viewer and browser utility (an X-Apps fork of gthumb)"
+HOMEPAGE="https://community.linuxmint.com/software/view/pix"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+SRC_URI="https://github.com/linuxmint/${PN}/archive/${PV}.tar.gz"
+
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cdr exif gnome-keyring gstreamer http jpeg json lcms raw slideshow svg tiff test webkit webp"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.36.0:2[dbus]
+ >=x11-libs/gtk+-3.10.0:3
+
+ media-libs/libpng:0=
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+
+ cdr? ( >=app-cdr/brasero-3.2 )
+ exif? ( >=media-gfx/exiv2-0.21:= )
+ gnome-keyring? ( >=app-crypt/libsecret-0.11 )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ http? ( >=net-libs/libsoup-2.42.0:2.4 )
+ jpeg? ( virtual/jpeg:0= )
+ json? ( >=dev-libs/json-glib-0.15.0 )
+ lcms? ( >=media-libs/lcms-2.6:2 )
+ slideshow? (
+ >=media-libs/clutter-1.12.0:1.0
+ >=media-libs/clutter-gtk-1:1.0 )
+ svg? ( >=gnome-base/librsvg-2.34 )
+ tiff? ( media-libs/tiff:= )
+ raw? ( >=media-libs/libopenraw-0.0.9 )
+ !raw? ( media-gfx/dcraw )
+ webkit? ( net-libs/webkit-gtk:4 )
+ webp? ( >=media-libs/libwebp-0.2.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-0.1.4
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ gnome-base/gnome-common
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ test? ( ~app-text/docbook-xml-dtd-4.1.2 )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ eautoreconf
+
+ # Remove unwanted CFLAGS added with USE=debug
+ sed -e 's/CFLAGS="$CFLAGS -g -O0 -DDEBUG"//' \
+ -i configure.ac -i configure || die
+
+}
+
+src_configure() {
+ # Upstream says in configure help that libchamplain support
+ # crashes frequently
+ gnome2_src_configure \
+ --disable-static \
+ --disable-libchamplain \
+ $(use_enable cdr libbrasero) \
+ $(use_enable exif exiv2) \
+ $(use_enable gnome-keyring libsecret) \
+ $(use_enable gstreamer) \
+ $(use_enable http libsoup) \
+ $(use_enable jpeg) \
+ $(use_enable json libjson-glib) \
+ $(use_enable raw libopenraw) \
+ $(use_enable slideshow clutter) \
+ $(use_enable svg librsvg) \
+ $(use_enable test test-suite) \
+ $(use_enable webkit webkit2) \
+ $(use_enable webp libwebp)
+}