summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2013-07-26 13:03:56 -0400
committerJustin Riley <justin.t.riley@gmail.com>2013-07-26 13:03:56 -0400
commit8de51b6fd2b945d33e6e8db041fa6094503616bc (patch)
tree3ef46ad137f693acc3c77d1489063d373d845379
parentmpd: patch for application/flv network streams (diff)
downloadjtriley-8de51b6fd2b945d33e6e8db041fa6094503616bc.tar.gz
jtriley-8de51b6fd2b945d33e6e8db041fa6094503616bc.tar.bz2
jtriley-8de51b6fd2b945d33e6e8db041fa6094503616bc.zip
add ebuild for latest hotot 0.9.9
-rw-r--r--net-misc/hotot/Manifest1
-rw-r--r--net-misc/hotot/files/hotot-0.9.9-it_IT.patch40
-rw-r--r--net-misc/hotot/hotot-0.9.9.ebuild68
3 files changed, 109 insertions, 0 deletions
diff --git a/net-misc/hotot/Manifest b/net-misc/hotot/Manifest
new file mode 100644
index 0000000..90d77fa
--- /dev/null
+++ b/net-misc/hotot/Manifest
@@ -0,0 +1 @@
+DIST hotot-0.9.9.tar.gz 1147026 SHA256 1026bb481d6d2197e7c108ced4d24ddb1adb3d1642a5a54d81c882cd9869a224 SHA512 186a58d63ffaeffd18907005a70d55e12382ae66c98000fd41f668fd7bbe9b24826683910120d745850bb4e9adcde239046a7f4d42aba8da0b5fe9d2ccb36bf9 WHIRLPOOL 25f4a82a2e89063080482a3cea977b436a2ca54f1500990b7778cd02c5b1d17eb9bf4ae270428072da48c1a364428907f6fd59367f7876691e764be7c2025cd5
diff --git a/net-misc/hotot/files/hotot-0.9.9-it_IT.patch b/net-misc/hotot/files/hotot-0.9.9-it_IT.patch
new file mode 100644
index 0000000..eb09199
--- /dev/null
+++ b/net-misc/hotot/files/hotot-0.9.9-it_IT.patch
@@ -0,0 +1,40 @@
+diff --git a/po/it_IT.po b/po/it_IT.po
+index 5c1d3a5..127c761 100644
+--- a/po/it_IT.po
++++ b/po/it_IT.po
+@@ -232,7 +232,7 @@ msgstr "_Visualizza"
+ #~ msgstr "'Cerca qualcuno che ti piace'"
+
+ #~ msgid "'Font Family'"
+-#~ msgstr "'Famiglia di font""
++#~ msgstr "'Famiglia di font'"
+
+ #~ msgid "'Font Size'"
+ #~ msgstr "'Dimensione del font'"
+@@ -337,7 +337,7 @@ msgstr "_Visualizza"
+ #~ msgstr "'Website'"
+
+ #~ msgid "'What is happening?'"
+-#~ msgstr "'Che c\'è di nuovo?'"
++#~ msgstr "'Che c'è di nuovo?'"
+
+ #~ msgid "- Credits -"
+ #~ msgstr "- Ringraziamenti -"
+@@ -533,7 +533,7 @@ msgstr "_Visualizza"
+ #~ msgstr "Abilita"
+
+ #~ msgid "Enter action mode"
+-#~ msgstr "Inserisci modalità d\'azione "
++#~ msgstr "Inserisci modalità d'azione"
+
+ #~ msgid "Enter compose mode"
+ #~ msgstr "Inserisci modalità di scrittura"
+@@ -1117,7 +1117,7 @@ msgstr "_Visualizza"
+ #~ msgid ""
+ #~ "You MUST restart Hotot for some changes below to take effect. And these "
+ #~ "changes will affect ALL accounts"
+-#~ msgstr "* Devi RIAVVIARE Hotot affinche\' le modifiche abbiano effetto. I cambiamenti influiranno su TUTTI gli account"
++#~ msgstr "* Devi RIAVVIARE Hotot affinche' le modifiche abbiano effetto. I cambiamenti influiranno su TUTTI gli account"
+
+ #~ msgid ""
+ #~ "You need to go to twitter.com to send a request before you can start "
diff --git a/net-misc/hotot/hotot-0.9.9.ebuild b/net-misc/hotot/hotot-0.9.9.ebuild
new file mode 100644
index 0000000..c63a964
--- /dev/null
+++ b/net-misc/hotot/hotot-0.9.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.8.8_pre.ebuild,v 1.1 2012/08/29 22:22:13 xmw Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="gtk? 2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit cmake-utils eutils python vcs-snapshot
+
+DESCRIPTION="lightweight & open source microblogging client"
+HOMEPAGE="http://hotot.org"
+SRC_URI="https://github.com/shellex/Hotot/tarball/d1ad4f714 -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chrome gtk kde qt4"
+
+RDEPEND="dev-python/dbus-python
+ gtk? ( dev-python/pywebkitgtk )
+ qt4? ( dev-qt/qtwebkit:4
+ kde? ( kde-base/kdelibs ) )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ qt4? ( x11-libs/qt-sql:4 )"
+
+REQUIRED_USE="|| ( chrome gtk qt4 )"
+
+pkg_setup() {
+ if ! use gtk ; then
+ if ! use qt4 ; then
+ ewarn "neither gtk not qt4 binaries will be build"
+ fi
+ fi
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-it_IT.patch
+ chmod +x "${WORKDIR}"/${P}/chrome/mk-chrome-app.sh
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} \
+ $(cmake-utils_use_with chrome CHROME) \
+ $(cmake-utils_use_with gtk GTK) \
+ $(cmake-utils_use_with kde KDE) \
+ $(cmake-utils_use_with qt4 QT) \
+ -DPYTHON_EXECUTABLE=$(PYTHON -2 -a)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ find "${D}" -name "*.pyc" -delete
+}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}