summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2012-01-30 23:32:07 -0500
committerJustin Riley <justin.t.riley@gmail.com>2012-01-30 23:32:07 -0500
commitb0867c2be4c22532caf1c66159f3db7623edfa0f (patch)
tree988048a0134021f1af5801fc84d0612933185b34
parentadd rtmapi 0.5 ebuild (diff)
downloadjtriley-b0867c2be4c22532caf1c66159f3db7623edfa0f.tar.gz
jtriley-b0867c2be4c22532caf1c66159f3db7623edfa0f.tar.bz2
jtriley-b0867c2be4c22532caf1c66159f3db7623edfa0f.zip
add gitflow 0.4.1 ebuild
-rw-r--r--dev-vcs/gitflow/gitflow-0.4.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-vcs/gitflow/gitflow-0.4.1.ebuild b/dev-vcs/gitflow/gitflow-0.4.1.ebuild
new file mode 100644
index 0000000..9246362
--- /dev/null
+++ b/dev-vcs/gitflow/gitflow-0.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Git extensions supporting an advanced branching model"
+GITHUB_USER="nvie"
+GITHUB_TAG="${PV}"
+HOMEPAGE="https://github.com/${GITHUB_USER}/${PN}"
+SRC_URI="https://github.com/${GITHUB_USER}/${PN}/tarball/${GITHUB_TAG} -> ${P}.tar.gz"
+
+LICENSE="AS-IS"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+completion"
+
+RDEPEND="completion? ( dev-vcs/git-flow-completion )
+ >=dev-libs/shflags-1.0.3"
+
+src_prepare() {
+ cd "${WORKDIR}"/${GITHUB_USER}-${PN}-*
+ S="$(pwd)"
+
+ sed -i \
+ -e '/^export GITFLOW_DIR=/s|$(dirname "$0")|/usr/libexec/git-flow|' \
+ -e "s|\$GITFLOW_DIR/gitflow-common|/usr/$(get_libdir)/gitflow-common|" \
+ -e "s|\$GITFLOW_DIR/gitflow-shFlags|/usr/$(get_libdir)/shflags|" \
+ git-flow || die "sed failed"
+
+}
+
+src_compile() { :; }
+
+src_install() {
+ exeinto /usr/bin
+ doexe git-flow || die "doexe failed"
+
+ insinto /usr/libexec/git-flow
+ doins git-flow-* || die "doins failed"
+
+ dolib gitflow-common || die "dolib failed"
+ dodoc README.mdown
+}