summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2014-09-04 10:34:11 -0400
committerJustin Riley <justin.t.riley@gmail.com>2014-09-04 10:34:11 -0400
commitc6c9a6e508deaeff24bfc0634d2bd7bfdf2701c5 (patch)
treeb55a41300c36678103b41898a9ac9fba245985ad
parentspotify: removed - ebuild fixed upstream (diff)
downloadjtriley-c6c9a6e508deaeff24bfc0634d2bd7bfdf2701c5.tar.gz
jtriley-c6c9a6e508deaeff24bfc0634d2bd7bfdf2701c5.tar.bz2
jtriley-c6c9a6e508deaeff24bfc0634d2bd7bfdf2701c5.zip
add hipchat 2.2.1163 ebuild
-rw-r--r--net-im/hipchat/Manifest2
-rw-r--r--net-im/hipchat/hipchat-2.2.1163.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/net-im/hipchat/Manifest b/net-im/hipchat/Manifest
new file mode 100644
index 0000000..6dde40a
--- /dev/null
+++ b/net-im/hipchat/Manifest
@@ -0,0 +1,2 @@
+DIST hipchat-2.2.1163-i686.pkg.tar.xz 43360760 SHA256 573b5a62410d13beb8353521e86c226b93f6c6d25d8a8d2f1f4507726dde1ea8 SHA512 45bdb7baa66910338013eed72c5c7e86a8817dec21d20e963dd4eb0e141fe9d06a6fe53d5ec744ff54a414e37ef1fafdc504f574ddda0e21993ba4d19e6b944d WHIRLPOOL 05a35cafaedd42266ac0ef399d54f8617885b7e9795f2a68481d857b09689d3fda07d5a2b2ddcc53a33a1e4debdcab78e79d919da69e43d102a74201317bb9f7
+DIST hipchat-2.2.1163-x86_64.pkg.tar.xz 43457636 SHA256 e8e95e9e049e2ead2a281a1320d342db9d2c88fa7da71f8c9c695b87918d4e79 SHA512 a6fd4498cc1832e4537467ae6d41cbe3aa432a9e8547366e4bfa06509be884587f0cc241862501ed1c407d84a1c59ec5d9b52e0c5963ee2b0503531f9f28cb87 WHIRLPOOL a036a3a3e8481056ff3827153f11a7344c8f7b6e3e61682e71bfc9e9e08a58b9546419d44d3b8a90353f1166d3faf813390f0f807d89a99daee14de9b3252f37
diff --git a/net-im/hipchat/hipchat-2.2.1163.ebuild b/net-im/hipchat/hipchat-2.2.1163.ebuild
new file mode 100644
index 0000000..2bc865b
--- /dev/null
+++ b/net-im/hipchat/hipchat-2.2.1163.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/hipchat/hipchat-2.2.1163.ebuild $
+
+EAPI="5"
+
+inherit eutils pax-utils unpacker
+
+DESCRIPTION="Group chat and video chat built for teams"
+HOMEPAGE="http://hipchat.com"
+SRC_URI="
+ amd64? (
+ http://downloads.hipchat.com/linux/arch/x86_64/hipchat-${PV}-x86_64.pkg.tar.xz
+ )
+ x86? (
+ http://downloads.hipchat.com/linux/arch/i686/hipchat-${PV}-i686.pkg.tar.xz
+ )
+"
+RESTRICT="mirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's/Icon=hipchat.png/Icon=hipchat/' usr/share/applications/hipchat.desktop || die "sed failed"
+ sed -i -e 's/Terminal=0/Terminal=false/' usr/share/applications/hipchat.desktop || die "sed failed"
+}
+
+src_install () {
+ foo=""
+ insinto $foo/usr
+ doins -r usr/share
+
+ insinto $foo/opt/HipChat/
+ exeinto $foo/opt/HipChat/bin
+ doins -r opt/HipChat/share
+ doins -r opt/HipChat/lib
+ doexe opt/HipChat/bin/*
+ dosym $foo/opt/HipChat/bin/hipchat $foo/usr/local/bin/hipchat
+ fperms 0755 $foo/opt/HipChat/lib/hipchat.bin
+}