summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2012-01-30 23:15:15 -0500
committerJustin Riley <justin.t.riley@gmail.com>2012-01-30 23:15:26 -0500
commit80db4ecd1545577b48913cba2b155ad8277ec57c (patch)
tree06803210139214e467994ae6a9efb168a17e9ee3 /dev-lua
parentadd shflags 1.0.3 ebuild (diff)
downloadjtriley-80db4ecd1545577b48913cba2b155ad8277ec57c.tar.gz
jtriley-80db4ecd1545577b48913cba2b155ad8277ec57c.tar.bz2
jtriley-80db4ecd1545577b48913cba2b155ad8277ec57c.zip
add lunatic-python live development ebuild
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lunatic-python/lunatic-python-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-lua/lunatic-python/lunatic-python-9999.ebuild b/dev-lua/lunatic-python/lunatic-python-9999.ebuild
new file mode 100644
index 0000000..fc39c7a
--- /dev/null
+++ b/dev-lua/lunatic-python/lunatic-python-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luasocket/luasocket-2.0.2.ebuild,v 1.1 2010/11/05 21:31:09 rafaelmartins Exp $
+
+EAPI=2
+PYTHON_DEPEND="2"
+
+inherit git multilib toolchain-funcs flag-o-matic eutils
+
+EGIT_REPO_URI="git://github.com/jtriley/Lunatic-Python.git"
+
+DESCRIPTION="Two-way bridge between Lua and Python"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE="LGPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/lua-5.1[deprecated]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ append-flags -fPIC
+
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC) -shared" \
+ || die
+}
+
+src_install() {
+ INSTALL_TOP_SHARE="${D}/$(pkg-config --variable INSTALL_LMOD lua)"
+ INSTALL_TOP_LIB="${D}/$(pkg-config --variable INSTALL_CMOD lua | sed -e "s:lib/:$(get_libdir)/:")"
+ dodoc NEW README || die
+ dohtml doc/* || die
+}