summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/neatx')
-rw-r--r--net-misc/neatx/ChangeLog38
-rw-r--r--net-misc/neatx/metadata.xml6
-rw-r--r--net-misc/neatx/neatx-9999.ebuild124
3 files changed, 0 insertions, 168 deletions
diff --git a/net-misc/neatx/ChangeLog b/net-misc/neatx/ChangeLog
deleted file mode 100644
index d5d6568..0000000
--- a/net-misc/neatx/ChangeLog
+++ /dev/null
@@ -1,38 +0,0 @@
-# ChangeLog for net-misc/neatx
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neatx/ChangeLog,v 1.7 2010/01/05 14:39:32 voyageur Exp $
-
-*neatx-0.3.1_p43-r2 (05 Jan 2010)
-
- 05 Jan 2010; Bernard Cafarelli <voyageur@gentoo.org>
- +neatx-0.3.1_p43-r2.ebuild:
- Fix documentation install path, bug #297971
-
- 25 Nov 2009; Markus Meier <maekke@gentoo.org> neatx-0.3.1_p43-r1.ebuild:
- x86 stable, bug #291619
-
- 10 Nov 2009; Richard Freeman <rich0@gentoo.org> neatx-0.3.1_p43-r1.ebuild:
- amd64 stable - 291619
-
- 30 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org>
- neatx-0.3.1_p43-r1.ebuild:
- Fix typo in RDEPEND, thanks to Tim Harder in bug #286903.
-
- 19 Sep 2009; Bernard Cafarelli <voyageur@gentoo.org>
- neatx-0.3.1_p43-r1.ebuild:
- Allow netcat6 too (with nc_path pointing to nc6), bug #285358
-
-*neatx-0.3.1_p43-r1 (15 Sep 2009)
-
- 15 Sep 2009; Bernard Cafarelli <voyageur@gentoo.org>
- -neatx-0.3.1_p43.ebuild, +neatx-0.3.1_p43-r1.ebuild:
- Revision bump to fix a few things: neatx.conf default options,
- netcat/gnu-netcat support, fix python objects precompilation. Thanks to
- calchan for review and pointers
-
-*neatx-0.3.1_p43 (09 Sep 2009)
-
- 09 Sep 2009; Bernard Cafarelli <voyageur@gentoo.org>
- +neatx-0.3.1_p43.ebuild, +metadata.xml:
- Initial commit from the NX overlay, ebuild by ikelos and me
-
diff --git a/net-misc/neatx/metadata.xml b/net-misc/neatx/metadata.xml
deleted file mode 100644
index 18f1f87..0000000
--- a/net-misc/neatx/metadata.xml
+++ /dev/null
@@ -1,6 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>nx</herd>
- <longdescription>Neatx is an Open Source NX server, similar to the commercial NX server from NoMachine, originally developed by Google for an internal project</longdescription>
-</pkgmetadata>
diff --git a/net-misc/neatx/neatx-9999.ebuild b/net-misc/neatx/neatx-9999.ebuild
deleted file mode 100644
index b9162d2..0000000
--- a/net-misc/neatx/neatx-9999.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neatx/neatx-0.3.1_p43-r2.ebuild,v 1.1 2010/01/05 14:39:32 voyageur Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils autotools distutils subversion
-
-ESVN_REPO_URI="http://neatx.googlecode.com/svn/trunk/"
-DESCRIPTION="Google implementation of NX server"
-HOMEPAGE="http://code.google.com/p/neatx/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-DEPEND="dev-python/docutils"
-RDEPEND="dev-python/pexpect
- dev-python/simplejson
- >=dev-python/pygtk-2.14
- >=dev-python/pygobject-2.14
- app-portage/portage-utils
- media-fonts/font-misc-misc
- media-fonts/font-cursor-misc
- || ( net-analyzer/gnu-netcat
- net-analyzer/netcat
- net-analyzer/netcat6 )
- net-misc/nx"
-
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}"
-
-src_prepare() {
- cd ${S}/${PN}
- sed -i -e "s/rst2html]/rst2html.py]/" configure.ac \
- || die "configure.ac sed failed"
- sed -e "s#/lib/neatx#/neatx#" \
- -e "/^docdir/s#\$(PACKAGE)#${PF}#" \
- -i Makefile.am \
- || die "Makefile.am sed failed"
- sed -e "/DATA_DIR =/s#/lib/neatx#/neatx#" \
- -i lib/constants.py || die "constants.py sed failed"
-
- eautoreconf
-}
-
-pkg_setup () {
- if [ -z "${NX_HOME_DIR}" ];
- then
- export NX_HOME_DIR=/var/lib/neatx/home
- fi
- enewuser nx -1 -1 ${NX_HOME_DIR}
-}
-
-src_configure() {
- cd ${S}/${PN}
- default_src_configure
-}
-
-src_compile() {
- cd ${S}/${PN}
- default_src_compile
-}
-
-src_install() {
- cd ${S}/${PN}
- emake install DESTDIR="${D}" || die "Failed to install"
- fperms 777 /var/lib/neatx/sessions
- dodir ${NX_HOME_DIR}/.ssh
- fowners nx:nx ${NX_HOME_DIR}
- fowners nx:nx ${NX_HOME_DIR}/.ssh
-
- insinto /etc
- newins doc/neatx.conf.example neatx.conf
-
- # nc or netcat6 or netcat?
- if has_version net-analyzer/gnu-netcat; then
- nc_path="/usr/bin/netcat"
- elif has_version net-analyzer/netcat6; then
- nc_path="/usr/bin/nc6"
- else
- nc_path="/usr/bin/nc"
- fi
- cat >> "${D}"/etc/neatx.conf << EOF
-
-netcat-path = ${nc_path}
-use-xsession = false
-start-gnome-command = /etc/X11/Sessions/Gnome
-EOF
-
- insinto ${NX_HOME_DIR}/.ssh
- insopts -m 600 -o nx
- newins extras/authorized_keys.nomachine authorized_keys
-}
-
-pkg_postinst () {
- distutils_pkg_postinst
-
- # Other NX servers ebuilds may have already created the nx account
- # However they use different login shell/home directory paths
- if [[ ${ROOT} == "/" ]]; then
- usermod -s /usr/$(get_libdir)/neatx/nxserver-login nx || die "Unable to set login shell of nx user!!"
- usermod -d ${NX_HOME_DIR} nx || die "Unable to set home directory of nx user!!"
- else
- elog "If you had another NX server installed before, please make sure"
- elog "the nx user account is correctly set to:"
- elog " * login shell: /usr/$(get_libdir)/neatx/nxserver-login"
- elog " * home directory: ${NX_HOME_DIR}"
- fi
-
- if ! built_with_use net-misc/openssh pam; then
- elog ""
- elog "net-misc/openssh was not built with PAM support"
- elog "You will need to unlock the nx account by setting a password for it"
- fi
-
- elog "If you want to use the default su authentication (rather than ssh)"
- elog "you must ensure that the nx user is a member of the wheel group."
- elog "You can add it via \"usermod -a -G wheel nx\""
-}