summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-09-16 21:38:24 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-09-16 21:38:24 +0200
commit856141589715b4057e5ca52f7cb08278713926ce (patch)
tree48e40ba54f15a0aaa3fa0be1e25850025001e665
parentuse bash-completion-r1 (diff)
downloadkeruspe-856141589715b4057e5ca52f7cb08278713926ce.tar.gz
keruspe-856141589715b4057e5ca52f7cb08278713926ce.tar.bz2
keruspe-856141589715b4057e5ca52f7cb08278713926ce.zip
bump gtkmm
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
-rw-r--r--dev-cpp/gtkmm/Manifest2
-rw-r--r--dev-cpp/gtkmm/gtkmm-3.1.90.ebuild63
-rw-r--r--profiles/categories1
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-cpp/gtkmm/Manifest b/dev-cpp/gtkmm/Manifest
new file mode 100644
index 00000000..cd542fe9
--- /dev/null
+++ b/dev-cpp/gtkmm/Manifest
@@ -0,0 +1,2 @@
+EBUILD gtkmm-3.1.90.ebuild 1416 RMD160 7a65b592de9ee5e13e6cc9615b38a8dd6da157fc SHA1 81018a6b96e5c451f3b60349b581cb5b3c58613c SHA256 786765c04d3cedc0c231c46ab6b446bca1fed025e5f11e4eb4a840a39ea7dd5a
+DIST gtkmm-3.1.90.tar.xz 11481796 RMD160 6ada077cb0a2d9b67ea1827d4199c36f1befb9b3 SHA1 ba96bdccd8c69c1189b35620f3825a3df65377bc SHA256 db54fad0a60d6463323f538837a213ad1838b0b7197d07359f268205b63685f9
diff --git a/dev-cpp/gtkmm/gtkmm-3.1.90.ebuild b/dev-cpp/gtkmm/gtkmm-3.1.90.ebuild
new file mode 100644
index 00000000..b1447df8
--- /dev/null
+++ b/dev-cpp/gtkmm/gtkmm-3.1.90.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="C++ interface for GTK+2"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc examples test"
+
+# glibmm-2.29.12 needed for Gio::Application
+RDEPEND="
+ >=dev-cpp/glibmm-2.29.12:2
+ >=x11-libs/gtk+-3.1.18:3
+ >=x11-libs/gdk-pixbuf-2.22.1:2
+ >=dev-cpp/atkmm-2.22.2
+ >=dev-cpp/cairomm-1.9.2.2
+ >=dev-cpp/pangomm-2.27.1:1.4
+ dev-libs/libsigc++:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ media-gfx/graphviz
+ dev-libs/libxslt
+ app-doc/doxygen )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog PORTING NEWS README"
+ G2CONF="${G2CONF}
+ --enable-api-atkmm
+ --disable-maintainer-mode
+ $(use_enable doc documentation)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed 1 failed"
+ fi
+
+ if ! use examples; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed 2 failed"
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}
diff --git a/profiles/categories b/profiles/categories
index 97891822..d711e2b7 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1,6 +1,7 @@
app-crypt
app-laptop
app-paludis
+dev-cpp
dev-java
dev-lang
dev-libs