summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/avahi/files')
-rw-r--r--net-dns/avahi/files/autoipd-openrc.sh32
-rw-r--r--net-dns/avahi/files/autoipd.sh52
-rw-r--r--net-dns/avahi/files/avahi-0.6.30-optional-gtk-utils.patch83
3 files changed, 0 insertions, 167 deletions
diff --git a/net-dns/avahi/files/autoipd-openrc.sh b/net-dns/avahi/files/autoipd-openrc.sh
deleted file mode 100644
index dec3aa05..00000000
--- a/net-dns/avahi/files/autoipd-openrc.sh
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright (C) 2004-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# Contributed by Sven Wegener (swegener@gentoo.org)
-
-_config_vars="$_config_vars autoipd"
-
-autoipd_depend() {
- program /usr/sbin/avahi-autoipd
- after interface
-}
-
-autoipd_start() {
- _exists true || return 1
-
- eval args=\$autoipd_${IFVAR}
-
- ebegin "Starting avahi-autoipd"
- /usr/sbin/avahi-autoipd --daemonize --syslog --wait ${args} "${IFACE}"
- eend "${?}" || return 1
-
- _show_address
-
- return 0
-}
-
-autoipd_stop() {
- /usr/sbin/avahi-autoipd --check --syslog "${IFACE}" || return 0
-
- ebegin "Stopping avahi-autoipd"
- /usr/sbin/avahi-autoipd --kill --syslog "${IFACE}"
- eend "${?}"
-}
diff --git a/net-dns/avahi/files/autoipd.sh b/net-dns/avahi/files/autoipd.sh
deleted file mode 100644
index 89d02e33..00000000
--- a/net-dns/avahi/files/autoipd.sh
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright (c) 2004-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# Contributed by Sven Wegener (swegener@gentoo.org)
-
-# void autoipd_depend(void)
-#
-# Sets up the dependencies for the module
-autoipd_depend() {
- after interface
-}
-
-# void autoipd_expose(void)
-#
-# Expose variables that can be configured
-autoipd_expose() {
- variables autoipd
-}
-
-# bool autoipd_start(char *iface)
-#
-# Tries to configure the interface via avahi-autoipd
-autoipd_start() {
- local iface="${1}" ifvar="$(bash_variable "${iface}")" opts="autoipd_${ifvar}" addr=""
-
- interface_exists "${iface}" true || return 1
-
- ebegin "Starting avahi-autoipd"
- if /usr/sbin/avahi-autoipd --daemonize --syslog --wait ${!opts} "${iface}"
- then
- eend 0
- addr="$(interface_get_address "${iface}")"
- einfo "${iface} received address ${addr}"
- return 0
- fi
-
- eend "${?}" "Failed to get address via avahi-autoipd!"
-}
-
-# bool autoipd_stop(char *iface)
-#
-# Stops a running avahi-autoipd instance
-autoipd_stop() {
- local iface="${1}"
-
- /usr/sbin/avahi-autoipd --check --syslog "${iface}" || return 0
-
- ebegin "Stopping avahi-autoipd"
- /usr/sbin/avahi-autoipd --kill --syslog "${iface}"
- eend "${?}" "Failed to stop running avahi-autoipd instance!"
-}
-
-# vim: set ts=4 :
diff --git a/net-dns/avahi/files/avahi-0.6.30-optional-gtk-utils.patch b/net-dns/avahi/files/avahi-0.6.30-optional-gtk-utils.patch
deleted file mode 100644
index 2c615a2b..00000000
--- a/net-dns/avahi/files/avahi-0.6.30-optional-gtk-utils.patch
+++ /dev/null
@@ -1,83 +0,0 @@
---- avahi-discover-standalone/Makefile.am
-+++ avahi-discover-standalone/Makefile.am
-@@ -23,7 +23,7 @@
- # This cool debug trap works on i386/gcc only
- AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
-
--if HAVE_GTK2OR3
-+if ENABLE_GTK_UTILS
- if HAVE_GLIB
- bin_PROGRAMS = \
- avahi-discover-standalone
---- avahi-ui/Makefile.am
-+++ avahi-ui/Makefile.am
-@@ -76,6 +76,7 @@
- libavahi_ui_gtk3_la_CFLAGS += -DDATABASE_FILE=\"$(pkglibdir)/service-types.db\"
- endif
-
-+if ENABLE_GTK_UTILS
- bin_PROGRAMS = bssh
- desktop_DATA += bssh.desktop bvnc.desktop
- @INTLTOOL_DESKTOP_RULE@
-@@ -102,6 +103,7 @@
- bvnc.desktop.in: bvnc.desktop.in.in
- $(AM_V_GEN)sed -e 's,@bindir\@,$(bindir),g' $< > $@
-
-+endif # ENABLE_GTK_UTILS
- endif # HAVE_GLIB
- endif
- endif
---- configure.ac
-+++ configure.ac
-@@ -564,7 +564,29 @@
- fi
- AM_CONDITIONAL(HAVE_GTK3, test "x$HAVE_GTK3" = "xyes")
-
--AM_CONDITIONAL(HAVE_GTK2OR3, test "x$HAVE_GTK3" = "xyes" -o "x$HAVE_GTK" = "xyes" )
-+#
-+# Check for GTK+ Utils
-+#
-+AC_ARG_ENABLE(gtk-utils,
-+ AS_HELP_STRING([--disable-gtk-utils],[Disable GTK+ utilities]),
-+ [case "${enableval}" in
-+ yes) WANT_GTK_UTILS=yes ;;
-+ no) WANT_GTK_UTILS=no ;;
-+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-gtk-utils) ;;
-+ esac],
-+ [WANT_GTK_UTILS=yes])
-+
-+ENABLE_GTK_UTILS=no
-+HAVE_GTK2OR3=no
-+if test "x$HAVE_GTK3" = "xyes" -o "x$HAVE_GTK" = "xyes"; then
-+ HAVE_GTK2OR3=yes
-+ if test "x$WANT_GTK_UTILS" = "xyes"; then
-+ ENABLE_GTK_UTILS=yes
-+ fi
-+fi
-+
-+AM_CONDITIONAL(HAVE_GTK2OR3, test "x$HAVE_GTK2OR3" = "xyes")
-+AM_CONDITIONAL(ENABLE_GTK_UTILS, test "x$ENABLE_GTK_UTILS" = "xyes")
-
- #
- # D-Bus
-@@ -1199,11 +1221,6 @@
- ENABLE_AUTOIPD="no (You need libdaemon!)"
- fi
-
--HAVE_GTK2OR3=no
--if test "x$HAVE_GTK" = "xyes" -o "x$HAVE_GTK3" = "xyes" ; then
-- HAVE_GTK2OR3=yes
--fi
--
- BUILD_UI="no"
- if test "x$HAVE_GTK2OR3" = "xyes" -a "x$BUILD_CLIENT" = "xyes" ; then
- BUILD_UI="yes"
-@@ -1223,7 +1240,7 @@
- Building avahi-python: ${BUILD_PYTHON}
- Building libavahi-glib: ${HAVE_GLIB}
- Building libavahi-gobject: ${BUILD_GOBJECT}
-- Building avahi-discover-standalone: ${HAVE_GTK2OR3}
-+ Building avahi-discover-standalone: ${ENABLE_GTK_UTILS}
- Building libavahi-qt3: ${HAVE_QT3}
- Building libavahi-qt4: ${HAVE_QT4}
- Building avahi-sharp: ${HAVE_MONO}