summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancisco Blas Izquierdo Riera (klondike) <klondike@xiscosoft.es>2011-03-14 07:21:13 +0100
committerFrancisco Blas Izquierdo Riera (klondike) <klondike@xiscosoft.es>2011-03-14 07:29:15 +0100
commit9afe00f835c655e2745e78cca9f4c17abd695fa0 (patch)
tree0e637d89af8c409b8897277988340ac643a24f64 /dev-haskell/random-stream/random-stream-0.1.1.ebuild
parentForgot to update the digest (diff)
downloadklondike-9afe00f835c655e2745e78cca9f4c17abd695fa0.tar.gz
klondike-9afe00f835c655e2745e78cca9f4c17abd695fa0.tar.bz2
klondike-9afe00f835c655e2745e78cca9f4c17abd695fa0.zip
Commiting some useful Haskell Packages
(Portage version: 2.1.9.42/git/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'dev-haskell/random-stream/random-stream-0.1.1.ebuild')
-rw-r--r--dev-haskell/random-stream/random-stream-0.1.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/random-stream/random-stream-0.1.1.ebuild b/dev-haskell/random-stream/random-stream-0.1.1.ebuild
new file mode 100644
index 0000000..84d3283
--- /dev/null
+++ b/dev-haskell/random-stream/random-stream-0.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="An infinite stream of random data"
+HOMEPAGE="http://hackage.haskell.org/package/random-stream"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="urandom openssl"
+
+#TODO: add winrandom?
+
+RDEPEND="dev-haskell/binary
+ >=dev-lang/ghc-6.8.2
+ openssl? ( dev-libs/openssl )"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ if use urandom; then
+ if use openssl; then
+ ewarn "This library only supports one random source. Disabling openssl."
+ fi
+ CABAL_CONFIGURE_FLAGS="--flags=have_urandom"
+ elif use openssl; then
+ CABAL_CONFIGURE_FLAGS="--flags=have_ssl"
+ else
+ die "You need one random source."
+ fi
+
+}