summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@bimsstein.(none)>2009-10-12 16:28:58 +0200
committerroot <root@bimsstein.(none)>2009-10-12 16:28:58 +0200
commit39002e5a25436e8df750aa15a275219603307c0a (patch)
tree1daba1671c81bf5c2fb5c988c3c1049218e5a54b
parentMerge branch 'master' into bardot (diff)
downloadkork-39002e5a25436e8df750aa15a275219603307c0a.tar.gz
kork-39002e5a25436e8df750aa15a275219603307c0a.tar.bz2
kork-39002e5a25436e8df750aa15a275219603307c0a.zip
media-video/ffmpeg2theora-0.25: Version bump from tree
-rw-r--r--media-video/ffmpeg2theora/Manifest2
-rw-r--r--media-video/ffmpeg2theora/ffmpeg2theora-0.25.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/media-video/ffmpeg2theora/Manifest b/media-video/ffmpeg2theora/Manifest
new file mode 100644
index 0000000..02f3f4d
--- /dev/null
+++ b/media-video/ffmpeg2theora/Manifest
@@ -0,0 +1,2 @@
+DIST ffmpeg2theora-0.25.tar.bz2 80165 RMD160 470ca8fab5d82a44054f86825782a42dceee597f SHA1 71c5bf86e7cfc1b5248730019b9d606df464366d SHA256 e4599cf17b9739909bbb15011ff4a5ee9061360ab4ab02f5354297735e0826eb
+EBUILD ffmpeg2theora-0.25.ebuild 1049 RMD160 1a65f4ce24928e743215ea2ded538e77a614adce SHA1 7efd772345915bf2ad9c0964037ee418f72e0fff SHA256 9404502d7cb2f16934a07ff83eb9ba4de6e6eb2980f00fc2b79532868aee6fee
diff --git a/media-video/ffmpeg2theora/ffmpeg2theora-0.25.ebuild b/media-video/ffmpeg2theora/ffmpeg2theora-0.25.ebuild
new file mode 100644
index 0000000..c266000
--- /dev/null
+++ b/media-video/ffmpeg2theora/ffmpeg2theora-0.25.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild,v 1.2 2009/09/07 09:06:29 hanno Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A simple converter to create Ogg Theora files."
+HOMEPAGE="http://www.v2v.cc/~j/ffmpeg2theora/index.html"
+SRC_URI="http://www.v2v.cc/~j/ffmpeg2theora/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ || ( <media-video/ffmpeg-0.5_p19787[vhook]
+ >=media-video/ffmpeg-0.5_p19787 )
+ >=media-libs/libvorbis-1.1
+ >=media-libs/libogg-1.1
+ >=media-libs/libtheora-1.0_beta1[encode]
+ media-libs/libkate"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/scons-1.0.0"
+
+src_compile() {
+ scons APPEND_CFLAGS="${CFLAGS}" APPEND_LINKFLAGS="${LDFLAGS}" || die "scons failed"
+}
+
+src_install() {
+ scons destdir="${D}" prefix=/usr mandir=PREFIX/share/man install || die "install failed"
+ dodoc AUTHORS ChangeLog README TODO || die
+}