summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@gmail.com>2009-04-11 11:38:50 +0200
committerHenry Gebhardt <hsggebhardt@gmail.com>2009-04-11 11:38:50 +0200
commit263fe5278d745767097f06cff28def9b51437a5a (patch)
treef4136288a39f2c782975d45076f0f737624ada7d /sci-astronomy/ftools/files
parentMerge branch 'master' of ssh://bardot/usr/local/portage/bardot (diff)
downloadkork-263fe5278d745767097f06cff28def9b51437a5a.tar.gz
kork-263fe5278d745767097f06cff28def9b51437a5a.tar.bz2
kork-263fe5278d745767097f06cff28def9b51437a5a.zip
sci-astronomy/ftools-6.6.1: First installing ebuild.
The installed software doesn't work, however.
Diffstat (limited to 'sci-astronomy/ftools/files')
-rw-r--r--sci-astronomy/ftools/files/hd_install-destdir.patch27
-rw-r--r--sci-astronomy/ftools/files/headas-init-destdir.patch38
-rw-r--r--sci-astronomy/ftools/files/lhea-fixperl-destdir.patch12
-rw-r--r--sci-astronomy/ftools/files/no-tk-docs.patch21
-rw-r--r--sci-astronomy/ftools/files/par2-destdir.patch14
5 files changed, 112 insertions, 0 deletions
diff --git a/sci-astronomy/ftools/files/hd_install-destdir.patch b/sci-astronomy/ftools/files/hd_install-destdir.patch
new file mode 100644
index 0000000..7508875
--- /dev/null
+++ b/sci-astronomy/ftools/files/hd_install-destdir.patch
@@ -0,0 +1,27 @@
+diff --git a/BUILD_DIR/hd_install.c b/BUILD_DIR/hd_install.c
+--- a/BUILD_DIR/hd_install.c
++++ b/BUILD_DIR/hd_install.c
+@@ -1459,6 +1459,7 @@ int HDinstall_file(int argc, char** argv, int status) {
+ char** nextArg;
+ char** tmpArg;
+ char* tmp_cp;
++ char* destdir;
+ InstallOptions opts = DEFAULT;
+
+ /* Process command line options which apply to this program. */
+@@ -1555,6 +1556,15 @@ int HDinstall_file(int argc, char** argv, int status) {
+ continue;
+ }
+
++ /* Prepend $DESTDIR if defined. */
++ if(NULL != (destdir = getenv("DESTDIR"))) {
++ char* newdest = NULL;
++ if(OK != (status = AppendPath(destdir, dest, &newdest, status)))
++ continue;
++ free(dest);
++ dest = newdest;
++ }
++
+ /* Give information. */
+ /* Perform installation. */
+ status = InstallFiles(src, dest, nextArg, &opts, status);
diff --git a/sci-astronomy/ftools/files/headas-init-destdir.patch b/sci-astronomy/ftools/files/headas-init-destdir.patch
new file mode 100644
index 0000000..213d67c
--- /dev/null
+++ b/sci-astronomy/ftools/files/headas-init-destdir.patch
@@ -0,0 +1,38 @@
+diff --git a/BUILD_DIR/Makefile.in b/BUILD_DIR/Makefile.in
+index f0a0fc0..bdfbb29 100644
+--- a/BUILD_DIR/Makefile.in
++++ b/BUILD_DIR/Makefile.in
+@@ -15,14 +15,18 @@ install: check-selection
+ @${MAKE} ${HD_SELECTED} HD_TARGET=$@
+ @./hd_install . ${HD_TOP_EXEC_PFX}/BUILD_DIR
+ @if [ -d ../glast ]; then \
+- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.csh \
++ ./hd_install -f \
++ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.csh \
+ ${HD_TOP_EXEC_PFX}/fermi-init.csh ${HD_LN_S}; \
+- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.sh \
++ ./hd_install -f \
++ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.sh \
+ ${HD_TOP_EXEC_PFX}/fermi-init.sh ${HD_LN_S}; \
+ else \
+- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.csh \
++ ./hd_install -f \
++ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.csh \
+ ${HD_TOP_EXEC_PFX}/headas-init.csh ${HD_LN_S}; \
+- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.sh \
++ ./hd_install -f \
++ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.sh \
+ ${HD_TOP_EXEC_PFX}/headas-init.sh ${HD_LN_S}; \
+ fi
+ @./hd_install -f hd_install${BSUF} ${HD_TOP_EXEC_PFX}/bin/hd_install${BSUF}
+@@ -34,8 +38,8 @@ install: check-selection
+ install-fguiparfiles:
+ @if [ -d ../ftools/guis/fgui ]; then \
+ echo "Creating .par2 files for fgui:"; \
+- HEADAS=${HD_TOP_EXEC_PFX}; export HEADAS; \
+- . ${HD_TOP_EXEC_PFX}/headas-init.sh; \
++ HEADAS=${DESTDIR}/${HD_TOP_EXEC_PFX}; export HEADAS; \
++ . ${DESTDIR}/${HD_TOP_EXEC_PFX}/headas-init.sh; \
+ echo "cd ../ftools/guis/fgui"; \
+ cd ../ftools/guis/fgui; \
+ echo "`which tclsh` convertpar.tcl ftools"; \
diff --git a/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch b/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch
new file mode 100644
index 0000000..625f12a
--- /dev/null
+++ b/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch
@@ -0,0 +1,12 @@
+diff --git a/heacore/BUILD_DIR/lhea-fixperl b/heacore/BUILD_DIR/lhea-fixperl
+index 927387b..e052b59 100755
+--- a/heacore/BUILD_DIR/lhea-fixperl
++++ b/heacore/BUILD_DIR/lhea-fixperl
+@@ -21,6 +21,7 @@ else
+ fi
+
+ for file in $filelist; do
++ file="$DESTDIR/$file"
+ if [ -f $file ]; then
+ if [ `grep -c '^#!.*perl' $file 2> /dev/null` -gt 0 ]; then
+ echo "Modifying $file to use Perl given by LHEAPERL at runtime."
diff --git a/sci-astronomy/ftools/files/no-tk-docs.patch b/sci-astronomy/ftools/files/no-tk-docs.patch
new file mode 100644
index 0000000..657c3c0
--- /dev/null
+++ b/sci-astronomy/ftools/files/no-tk-docs.patch
@@ -0,0 +1,21 @@
+diff --git a/tcltk/tk/unix/Makefile.in b/tcltk/tk/unix/Makefile.in
+--- a/tcltk/tk/unix/Makefile.in
++++ b/tcltk/tk/unix/Makefile.in
+@@ -600,7 +600,7 @@ gdb: wish
+ gdb ./wish --command=gdb.run
+ rm gdb.run
+
+-INSTALL_TARGETS = install-binaries install-libraries install-demos install-doc @EXTRA_INSTALL@
++INSTALL_TARGETS = install-binaries install-libraries install-demos @EXTRA_INSTALL@
+
+ install: $(INSTALL_TARGETS)
+
+@@ -1542,7 +1542,7 @@ package-config:
+ package-common:
+ cd $(DISTDIR)/unix/`arch`;\
+ $(MAKE); \
+- $(MAKE) install-libraries install-doc \
++ $(MAKE) install-libraries \
+ prefix=$(DISTDIR)/SUNWtcl/$(TCLVERSION) \
+ exec_prefix=$(DISTDIR)/SUNWtcl/$(TCLVERSION)/`arch`
+ mkdir -p $(DISTDIR)/SUNWtcl/$(TCLVERSION)/bin
diff --git a/sci-astronomy/ftools/files/par2-destdir.patch b/sci-astronomy/ftools/files/par2-destdir.patch
new file mode 100644
index 0000000..1d0fca5
--- /dev/null
+++ b/sci-astronomy/ftools/files/par2-destdir.patch
@@ -0,0 +1,14 @@
+diff --git a/BUILD_DIR/Makefile.in b/BUILD_DIR/Makefile.in
+--- a/BUILD_DIR/Makefile.in
++++ b/BUILD_DIR/Makefile.in
+@@ -34,8 +34,8 @@ install: check-selection
+ install-fguiparfiles:
+ @if [ -d ../ftools/guis/fgui ]; then \
+ echo "Creating .par2 files for fgui:"; \
+- HEADAS=${HD_TOP_EXEC_PFX}; export HEADAS; \
+- . ${HD_TOP_EXEC_PFX}/headas-init.sh; \
++ HEADAS=${DESTDIR}/${HD_TOP_EXEC_PFX}; export HEADAS; \
++ . ${DESTDIR}/${HD_TOP_EXEC_PFX}/headas-init.sh; \
+ echo "cd ../ftools/guis/fgui"; \
+ cd ../ftools/guis/fgui; \
+ echo "`which tclsh` convertpar.tcl ftools"; \