summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/bup/Manifest2
-rw-r--r--app-backup/bup/bup-0.25-r2.ebuild65
-rw-r--r--app-backup/bup/bup-9999.ebuild62
3 files changed, 0 insertions, 129 deletions
diff --git a/app-backup/bup/Manifest b/app-backup/bup/Manifest
deleted file mode 100644
index 36d7fdf..0000000
--- a/app-backup/bup/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST bup-0.25-man.tar.gz 26507 SHA256 9cdddf6031d823fff21b4635bf9708a0736b4a0e243b17e83671f2c1d4c772e3 SHA512 24dada8a30ab3dea3cb48fc8893b338c4acb6f14daa6c26d5817b7bd5b97bdd36540ce4ef76266d87e9803771bd6cb39ae7b6b4bea60217a91e311d8dc5a746c WHIRLPOOL a4bd316fb82352c078203cd4e0bf63507b25b6089fef8f71c5105cbcb6ad13e0881c6093e9942f9b0370f98ed7e74a002b9dd0ada7928897aa0a7d619450b245
-DIST bup-0.25.tar.gz 399332 SHA256 bf67c6fd77c94346876b942ec9e4b8b58020b5a7ed59647c27568d19dae0538c SHA512 bffb939639e18a7b1a3eb930003e5890af4c0e6f4a74bdacaa62a1bbe3bf3789e0a267271f704d75f7b1618dddf219fe65c3e80032590f99f2875552ccbcfe97 WHIRLPOOL 2627ba280e4032ea61aa068cb3c72e2a2de0f78dfc30f86c8b8430670f21cd218816bd626bddd6932af91a29a4db985e638be52739cd56e49ab19b8990e966bc
diff --git a/app-backup/bup/bup-0.25-r2.ebuild b/app-backup/bup/bup-0.25-r2.ebuild
deleted file mode 100644
index 39cf21b..0000000
--- a/app-backup/bup/bup-0.25-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-inherit eutils python
-
-DOC_COMMIT="bc21345a527cc446084369861655126f6b0ecd8a"
-
-DESCRIPTION="It backs things up based on the git packfile format"
-HOMEPAGE="http://github.com/bup/bup"
-SRC_URI="http://github.com/bup/bup/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz
- http://github.com/bup/bup/archive/${DOC_COMMIT}.tar.gz -> ${P}-man.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="|| (
- dev-lang/python:2.4
- dev-lang/python:2.5
- dev-lang/python:2.6
- dev-lang/python:2.7
- )
- dev-vcs/git
- app-arch/par2cmdline
- dev-python/fuse-python
- dev-python/pyxattr
- dev-python/pylibacl"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- mv "../bup-${DOC_COMMIT}" bup-man || die
- python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- echo "Nothing to configure..."
-}
-
-src_compile() {
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- doman "${S}"/bup-man/*
-
- dodoc "${D}/usr/share/doc/${PN}"/*
- rm -r "${D}/usr/share/doc/${PN}/" || die
-
- dodoc README README.md DESIGN
-}
-
-src_test() {
- emake test
-}
diff --git a/app-backup/bup/bup-9999.ebuild b/app-backup/bup/bup-9999.ebuild
deleted file mode 100644
index ac8e3f1..0000000
--- a/app-backup/bup/bup-9999.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-EGIT_REPO_URI="git://github.com/bup/${PN}.git
- http://github.com/bup/${PN}.git"
-inherit git-2 eutils python
-
-DESCRIPTION="It backs things up based on the git packfile format"
-HOMEPAGE="http://github.com/bup/bup"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="+doc"
-
-DEPEND="|| (
- dev-lang/python:2.4
- dev-lang/python:2.5
- dev-lang/python:2.6
- dev-lang/python:2.7
- )
- dev-vcs/git
- app-arch/par2cmdline
- dev-python/fuse-python
- dev-python/pyxattr
- dev-python/pylibacl
- doc? ( app-text/pandoc )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch_user
- python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- echo "Nothing to configure..."
-}
-
-src_compile() {
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- dodoc "${D}/usr/share/doc/${PN}"/*
- rm -r "${D}/usr/share/doc/${PN}/" || die
-
- dodoc README README.md DESIGN
-}
-
-src_test() {
- emake test
-}