summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/bup/bup-0.25_rc1.ebuild')
-rw-r--r--app-backup/bup/bup-0.25_rc1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-backup/bup/bup-0.25_rc1.ebuild b/app-backup/bup/bup-0.25_rc1.ebuild
index b73be0d..0107e7d 100644
--- a/app-backup/bup/bup-0.25_rc1.ebuild
+++ b/app-backup/bup/bup-0.25_rc1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=4
inherit eutils
DESCRIPTION="It backs things up based on the git packfile format"
@@ -32,17 +32,18 @@ src_unpack() {
}
src_compile() {
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
+ emake install DESTDIR="${D}"
- dodoc "${D}/usr/share/doc/${PN}"/* && rm -r "${D}/usr/share/doc/${PN}/"
+ dodoc "${D}/usr/share/doc/${PN}"/*
+ rm -r "${D}/usr/share/doc/${PN}/" || die
dodoc README DESIGN
}
src_test() {
- emake test || die "emake test failed"
+ emake test
}