summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/fpipe/fpipe-9999.ebuild')
-rw-r--r--sci-astronomy/fpipe/fpipe-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/sci-astronomy/fpipe/fpipe-9999.ebuild b/sci-astronomy/fpipe/fpipe-9999.ebuild
index 0c20f3e..7ee506d 100644
--- a/sci-astronomy/fpipe/fpipe-9999.ebuild
+++ b/sci-astronomy/fpipe/fpipe-9999.ebuild
@@ -22,6 +22,7 @@ DEPEND=">=x11-libs/gtk+-2.14
virtual/perl-Time-HiRes
perl-gcpan/IPC-XPA
virtual/libusb:1
+ virtual/latex-base
sci-astronomy/ftools"
pkg_setup() {
@@ -30,15 +31,7 @@ pkg_setup() {
src_prepare() {
cd software
- # Get the cfitsio version HEASOFT is using. Alternatively, we could just
- # depend on sci-libs/cfitsio and be done. But let's take what HEASOFT gives
- # us.
- local CFITSIO_VERSION="`ls "${HEADAS}"/lib/libcfitsio*.so`"
- CFITSIO_VERSION="`basename "${CFITSIO_VERSION}" .so`"
- CFITSIO_VERSION="${CFITSIO_VERSION##libcfitsio_}"
- sed -i -e "/ffopen/s:cfitsio:cfitsio cfitsio_${CFITSIO_VERSION}:" \
- configure.ac
- ./bootstrap.sh
+ ./bootstrap.sh || die "bootstrap failed"
}
src_configure() {
@@ -49,12 +42,16 @@ src_configure() {
--enable-fpimage \
--enable-fpixoacm2fits \
--enable-fpixosvm2fits \
+ --enable-fptemplate \
|| die "econf failed"
}
src_compile() {
cd software
emake || die "emake failed"
+
+ cd "${S}"/documents
+ emake || die "emake failed for documents"
}
src_install() {