summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/ftools/files')
-rw-r--r--sci-astronomy/ftools/files/hd-std-install-tasks.patch17
-rw-r--r--sci-astronomy/ftools/files/hd_install-DESTDIR.patch24
-rw-r--r--sci-astronomy/ftools/files/hd_install-destdir.patch27
-rw-r--r--sci-astronomy/ftools/files/headas-init-destdir.patch38
-rw-r--r--sci-astronomy/ftools/files/install-iwidgets-symlink-destdir.patch22
-rw-r--r--sci-astronomy/ftools/files/lhea-fixperl-destdir.patch12
-rw-r--r--sci-astronomy/ftools/files/lhea-fixpfiles-destdir.patch15
-rw-r--r--sci-astronomy/ftools/files/no-tk-docs.patch21
-rw-r--r--sci-astronomy/ftools/files/par2-destdir.patch14
9 files changed, 0 insertions, 190 deletions
diff --git a/sci-astronomy/ftools/files/hd-std-install-tasks.patch b/sci-astronomy/ftools/files/hd-std-install-tasks.patch
deleted file mode 100644
index 35ee894..0000000
--- a/sci-astronomy/ftools/files/hd-std-install-tasks.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/heacore/BUILD_DIR/Makefile-std b/heacore/BUILD_DIR/Makefile-std
-index 13a8d97..4e68256 100644
---- a/heacore/BUILD_DIR/Makefile-std
-+++ b/heacore/BUILD_DIR/Makefile-std
-@@ -479,10 +479,10 @@ ${HD_TARG_PFX}install-tasks:
- @for file in ${HD_INSTALL_TASKS} ${HD_INSTALL_ONLY_TASKS} .; do \
- if [ $$file = . ]; then continue; fi; \
- filepart=`echo $$file | sed 's%.*/%%'`; \
-- ${HD_INSTALL} $$file${BSUF} ${HD_BIN}/$$filepart${BSUF} ${HD_CP_P}; \
-+ ${HD_INSTALL} $$file${BSUF} ${DESTDIR}/${HD_BIN}/$$filepart${BSUF} ${HD_CP_P}; \
- status=$$?; if [ $$status -ne 0 ]; then exit $$status; fi; \
- if [ "x${HD_BIN}" != "x${HD_TOP_BIN}" ]; then \
-- ${HD_INSTALL} ${HD_BIN}/$$filepart${BSUF} ${HD_TOP_BIN}/$$filepart${BSUF} ${HD_LN_S}; \
-+ ${HD_INSTALL} ${HD_BIN}/$$filepart${BSUF} ${DESTDIR}/${HD_TOP_BIN}/$$filepart${BSUF} ${HD_LN_S}; \
- status=$$?; if [ $$status -ne 0 ]; then exit $$status; fi; \
- fi; \
- done
diff --git a/sci-astronomy/ftools/files/hd_install-DESTDIR.patch b/sci-astronomy/ftools/files/hd_install-DESTDIR.patch
deleted file mode 100644
index f0c47e5..0000000
--- a/sci-astronomy/ftools/files/hd_install-DESTDIR.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- heasoft-6.4.1.orig/BUILD_DIR/hd_install.c 2004-04-09 20:33:04.000000000 +0200
-+++ heasoft-6.4.1/BUILD_DIR/hd_install.c 2008-06-24 22:57:00.000000000 +0200
-@@ -1548,6 +1548,21 @@
- /* Next argument is required to be the name of the destination. */
- if(NULL != *nextArg && '\0' != **nextArg) {
- status = CleanPath(*nextArg, &dest, status);
-+
-+ /* add $DESTDIR to filename */
-+ char *newdest = NULL;
-+ char *destdir = getenv("DESTDIR");
-+ fprintf(stderr, "DESTDIR=%s.\n", destdir);
-+ fprintf(stderr, "dest=%s.\n", dest);
-+ if (NULL != destdir) {
-+ status = AppendPath(destdir, dest, &newdest, status);
-+ fprintf(stderr, "newdest=%s.\n", newdest);
-+ if (OK != status)
-+ continue;
-+ free(dest);
-+ dest = newdest;
-+ }
-+
- ++nextArg;
- } else {
- fprintf(stderr, sErrFmt, sBanner, usage);
diff --git a/sci-astronomy/ftools/files/hd_install-destdir.patch b/sci-astronomy/ftools/files/hd_install-destdir.patch
deleted file mode 100644
index 7508875..0000000
--- a/sci-astronomy/ftools/files/hd_install-destdir.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/BUILD_DIR/hd_install.c b/BUILD_DIR/hd_install.c
---- a/BUILD_DIR/hd_install.c
-+++ b/BUILD_DIR/hd_install.c
-@@ -1459,6 +1459,7 @@ int HDinstall_file(int argc, char** argv, int status) {
- char** nextArg;
- char** tmpArg;
- char* tmp_cp;
-+ char* destdir;
- InstallOptions opts = DEFAULT;
-
- /* Process command line options which apply to this program. */
-@@ -1555,6 +1556,15 @@ int HDinstall_file(int argc, char** argv, int status) {
- continue;
- }
-
-+ /* Prepend $DESTDIR if defined. */
-+ if(NULL != (destdir = getenv("DESTDIR"))) {
-+ char* newdest = NULL;
-+ if(OK != (status = AppendPath(destdir, dest, &newdest, status)))
-+ continue;
-+ free(dest);
-+ dest = newdest;
-+ }
-+
- /* Give information. */
- /* Perform installation. */
- status = InstallFiles(src, dest, nextArg, &opts, status);
diff --git a/sci-astronomy/ftools/files/headas-init-destdir.patch b/sci-astronomy/ftools/files/headas-init-destdir.patch
deleted file mode 100644
index 213d67c..0000000
--- a/sci-astronomy/ftools/files/headas-init-destdir.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/BUILD_DIR/Makefile.in b/BUILD_DIR/Makefile.in
-index f0a0fc0..bdfbb29 100644
---- a/BUILD_DIR/Makefile.in
-+++ b/BUILD_DIR/Makefile.in
-@@ -15,14 +15,18 @@ install: check-selection
- @${MAKE} ${HD_SELECTED} HD_TARGET=$@
- @./hd_install . ${HD_TOP_EXEC_PFX}/BUILD_DIR
- @if [ -d ../glast ]; then \
-- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.csh \
-+ ./hd_install -f \
-+ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.csh \
- ${HD_TOP_EXEC_PFX}/fermi-init.csh ${HD_LN_S}; \
-- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.sh \
-+ ./hd_install -f \
-+ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/fermi-init.sh \
- ${HD_TOP_EXEC_PFX}/fermi-init.sh ${HD_LN_S}; \
- else \
-- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.csh \
-+ ./hd_install -f \
-+ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.csh \
- ${HD_TOP_EXEC_PFX}/headas-init.csh ${HD_LN_S}; \
-- ./hd_install -f ${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.sh \
-+ ./hd_install -f \
-+ ${DESTDIR}/${HD_TOP_EXEC_PFX}/BUILD_DIR/headas-init.sh \
- ${HD_TOP_EXEC_PFX}/headas-init.sh ${HD_LN_S}; \
- fi
- @./hd_install -f hd_install${BSUF} ${HD_TOP_EXEC_PFX}/bin/hd_install${BSUF}
-@@ -34,8 +38,8 @@ install: check-selection
- install-fguiparfiles:
- @if [ -d ../ftools/guis/fgui ]; then \
- echo "Creating .par2 files for fgui:"; \
-- HEADAS=${HD_TOP_EXEC_PFX}; export HEADAS; \
-- . ${HD_TOP_EXEC_PFX}/headas-init.sh; \
-+ HEADAS=${DESTDIR}/${HD_TOP_EXEC_PFX}; export HEADAS; \
-+ . ${DESTDIR}/${HD_TOP_EXEC_PFX}/headas-init.sh; \
- echo "cd ../ftools/guis/fgui"; \
- cd ../ftools/guis/fgui; \
- echo "`which tclsh` convertpar.tcl ftools"; \
diff --git a/sci-astronomy/ftools/files/install-iwidgets-symlink-destdir.patch b/sci-astronomy/ftools/files/install-iwidgets-symlink-destdir.patch
deleted file mode 100644
index fb6f3c9..0000000
--- a/sci-astronomy/ftools/files/install-iwidgets-symlink-destdir.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/tcltk/BUILD_DIR/Makefile.in b/tcltk/BUILD_DIR/Makefile.in
-index a4f2be7..210bc10 100644
---- a/tcltk/BUILD_DIR/Makefile.in
-+++ b/tcltk/BUILD_DIR/Makefile.in
-@@ -158,7 +158,7 @@ install-iwidgets:
- ${MAKE} subdir-iwidgets HD_TARGET="install" \
- prefix=${HD_EXEC_PFX} exec_prefix=${HD_EXEC_PFX} \
- LD_LIBRARY_PATH="${TCL_DIR}:${LD_LIBRARY_PATH}"
-- @cd ${HD_TOP_LIB}; rm -f iwidgets; ln -sf ${IWIDGETS} iwidgets
-+ @cd "${DESTDIR}"/${HD_TOP_LIB}; rm -f iwidgets; ln -sf ${IWIDGETS} iwidgets
- #-------------------------------------------------------------------------------
-
- # Specializations for iwidgets2.2.0
-@@ -223,7 +223,7 @@ publish-tclreadline:
- install-tclreadline:
- ${MAKE} subdir-tclreadline HD_TARGET="install" \
- prefix=${HD_EXEC_PFX} exec_prefix=${HD_EXEC_PFX} TCLRL_DIR=${HD_LIB}/tclreadline${TCLREADLINE_VERS} TCLRL_LIBDIR=${HD_LIB} tclrldir=${HD_LIB}/tclreadline${TCLREADLINE_VERS}
-- @cd ${HD_TOP_LIB}; rm -f tclreadline; ln -sf tclreadline${TCLREADLINE_VERS} tclreadline
-+ @cd "${DESTDIR}"/${HD_TOP_LIB}; rm -f tclreadline; ln -sf tclreadline${TCLREADLINE_VERS} tclreadline
- @if [ "x${HD_LIB_STYLE}" = xstatic ]; then \
- ${HD_INSTALL} ${HD_LIB}/libtclreadline.a ${HD_LIB}/lib${TCLREADLINE}.a ${HD_LN_S}; \
- fi
diff --git a/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch b/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch
deleted file mode 100644
index 527bca9..0000000
--- a/sci-astronomy/ftools/files/lhea-fixperl-destdir.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/lhea-fixperl b/lhea-fixperl
-index 927387b..e052b59 100755
---- a/lhea-fixperl
-+++ b/lhea-fixperl
-@@ -21,6 +21,7 @@ else
- fi
-
- for file in $filelist; do
-+ file="$DESTDIR/$file"
- if [ -f $file ]; then
- if [ `grep -c '^#!.*perl' $file 2> /dev/null` -gt 0 ]; then
- echo "Modifying $file to use Perl given by LHEAPERL at runtime."
diff --git a/sci-astronomy/ftools/files/lhea-fixpfiles-destdir.patch b/sci-astronomy/ftools/files/lhea-fixpfiles-destdir.patch
deleted file mode 100644
index 1392dce..0000000
--- a/sci-astronomy/ftools/files/lhea-fixpfiles-destdir.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/ftools/BUILD_DIR/Makefile b/ftools/BUILD_DIR/Makefile
-index 67c72c4..9940349 100644
---- a/ftools/BUILD_DIR/Makefile
-+++ b/ftools/BUILD_DIR/Makefile
-@@ -43,8 +43,8 @@ install-BUILD_DIR:
- fixpfiles:
- @LHEA_DATA=${HD_TOP_REFDATA}; LHEA_HELP=${HD_TOP_HELP}; \
- export LHEA_DATA; export LHEA_HELP; \
-- if [ -d ${HD_PFILES} ]; then \
-- cd ${HD_PFILES}; lhea-fixpfiles; \
-+ if [ -d "${DESTDIR}"/${HD_PFILES} ]; then \
-+ cd "${DESTDIR}"/${HD_PFILES}; lhea-fixpfiles; \
- fi
-
- # Specializations for xspec (spectral dir) in case we only have xspec data:
diff --git a/sci-astronomy/ftools/files/no-tk-docs.patch b/sci-astronomy/ftools/files/no-tk-docs.patch
deleted file mode 100644
index 657c3c0..0000000
--- a/sci-astronomy/ftools/files/no-tk-docs.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/tcltk/tk/unix/Makefile.in b/tcltk/tk/unix/Makefile.in
---- a/tcltk/tk/unix/Makefile.in
-+++ b/tcltk/tk/unix/Makefile.in
-@@ -600,7 +600,7 @@ gdb: wish
- gdb ./wish --command=gdb.run
- rm gdb.run
-
--INSTALL_TARGETS = install-binaries install-libraries install-demos install-doc @EXTRA_INSTALL@
-+INSTALL_TARGETS = install-binaries install-libraries install-demos @EXTRA_INSTALL@
-
- install: $(INSTALL_TARGETS)
-
-@@ -1542,7 +1542,7 @@ package-config:
- package-common:
- cd $(DISTDIR)/unix/`arch`;\
- $(MAKE); \
-- $(MAKE) install-libraries install-doc \
-+ $(MAKE) install-libraries \
- prefix=$(DISTDIR)/SUNWtcl/$(TCLVERSION) \
- exec_prefix=$(DISTDIR)/SUNWtcl/$(TCLVERSION)/`arch`
- mkdir -p $(DISTDIR)/SUNWtcl/$(TCLVERSION)/bin
diff --git a/sci-astronomy/ftools/files/par2-destdir.patch b/sci-astronomy/ftools/files/par2-destdir.patch
deleted file mode 100644
index 1d0fca5..0000000
--- a/sci-astronomy/ftools/files/par2-destdir.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/BUILD_DIR/Makefile.in b/BUILD_DIR/Makefile.in
---- a/BUILD_DIR/Makefile.in
-+++ b/BUILD_DIR/Makefile.in
-@@ -34,8 +34,8 @@ install: check-selection
- install-fguiparfiles:
- @if [ -d ../ftools/guis/fgui ]; then \
- echo "Creating .par2 files for fgui:"; \
-- HEADAS=${HD_TOP_EXEC_PFX}; export HEADAS; \
-- . ${HD_TOP_EXEC_PFX}/headas-init.sh; \
-+ HEADAS=${DESTDIR}/${HD_TOP_EXEC_PFX}; export HEADAS; \
-+ . ${DESTDIR}/${HD_TOP_EXEC_PFX}/headas-init.sh; \
- echo "cd ../ftools/guis/fgui"; \
- cd ../ftools/guis/fgui; \
- echo "`which tclsh` convertpar.tcl ftools"; \