summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/ftools/ftools-6.5.ebuild')
-rw-r--r--sci-astronomy/ftools/ftools-6.5.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sci-astronomy/ftools/ftools-6.5.ebuild b/sci-astronomy/ftools/ftools-6.5.ebuild
new file mode 100644
index 0000000..3a4b95a
--- /dev/null
+++ b/sci-astronomy/ftools/ftools-6.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils fortran autotools
+
+# This package only includes the futils.
+
+DESCRIPTION="HEASOFT/HEADAS: The FTools (futils only) from NASA's GSFC for viewing and manipulating FITS files. Includes CFITSIO."
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/"
+SRC_URI="ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/heasoft${PV}src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# Recommend >=dev-lang/perl-5.6.0.
+# Possibly we can have cfitsio installed side-by-side.
+DEPEND=">=dev-lang/perl-5.6.0
+ x11-base/xorg-server
+ !sci-libs/cfitsio"
+RDEPEND="${DEPEND}"
+
+
+S="${WORKDIR}/heasoft-${PV}"
+
+# INSTDIR="${D}/headas-${PV}"
+# INSTDIR_ARCH="${INSTDIR}/<arch-and-lib>"
+
+INSTPREFIX=/usr/heasoft
+ARCHPREFIX=/usr
+
+pkg_setup() {
+ fortran_pkg_setup
+}
+
+# src_unpack() {
+ # unpack "${A}"
+
+ # # All occurrences of hd_install.c are the same, and need the same patch.
+ # # HD_INSTALL_C_DIR=". tcltk ftools heacore demo"
+ # # for rdir in ${HD_INSTALL_C_DIR}; do
+ # # cd "${S}/${rdir}"
+ # # einfo "Entering \"${rdir}\" ..."
+ # # EPATCH_OPTS="-p1" epatch "${FILESDIR}/hd_install-DESTDIR.patch"
+ # # done
+# }
+
+src_compile() {
+ cd "${S}/BUILD_DIR/"
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+
+src_install() {
+ cd "${S}/BUILD_DIR/"
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc "${S}/Release_Notes_6.4.1" || die "dodoc failed"
+}
+
+pkg_postinst() {
+ ewarn "In order to use heasoft and the ftools, put in your ~/.bashrc"
+ einfo
+ ewarn " export HEADAS=\"${INSTDIR_ARCH}\""
+ ewarn " alias heainit=\". $HEADAS/headas-init.sh"
+ einfo
+ ewarn "and initialize the ftools with"
+ einfo
+ ewarn " $ heainit"
+ einfo
+ ewarn "every time you start a new shell."
+ ewarn "This is necessary since heasoft does not comply exactly with"
+ ewarn "GNU software conventions."
+ elog "Happy fitsing."
+}