summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/ftools/ftools-6.6.1.ebuild')
-rw-r--r--sci-astronomy/ftools/ftools-6.6.1.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/sci-astronomy/ftools/ftools-6.6.1.ebuild b/sci-astronomy/ftools/ftools-6.6.1.ebuild
deleted file mode 100644
index c5607af..0000000
--- a/sci-astronomy/ftools/ftools-6.6.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-
-inherit eutils
-# A well-used example of an eclass function that needs eutils is epatch. If
-# your source needs patches applied, it's suggested to put your patch in the
-# 'files' directory and use:
-#
-# epatch "${FILESDIR}"/patch-name-here
-#
-# eclasses tend to list descriptions of how to use their functions properly.
-# take a look at /usr/portage/eclasses/ for more examples.
-
-DESCRIPTION="General-Use FTools for manipulating and inspecting FITS files"
-HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html"
-SRC_URI="heasoft${PV}src.tar.gz"
-LICENSE="GPLv2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-RESTRICT="test"
-
-DEPEND="x11-base/xorg-server"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/heasoft-${PV}/"
-
-
-src_prepare() {
- # The same source file hd_install.c occurs multiple times, and needs to
- # be patched to support $DESTDIR.
- for subdir in . demo tcltk ftools heacore heatools; do
- cd "${S}"/${subdir}/BUILD_DIR
- epatch "${FILESDIR}"/hd_install-destdir.patch || die "epatch failed"
- done
- cd "${S}"
- epatch "${FILESDIR}"/no-tk-docs.patch || die "epatch failed"
- epatch "${FILESDIR}"/lhea-fixperl-destdir.patch || die "epatch failed"
- epatch "${FILESDIR}"/headas-init-destdir.patch || die "epatch failed"
-}
-
-src_configure() {
- cd BUILD_DIR
- ./configure --prefix="/usr/heasoft-${PV}/" || die "configure failed"
-}
-
-src_compile() {
- cd BUILD_DIR
- make -j1 || die "make failed"
-}
-
-src_install() {
- cd BUILD_DIR
- make -j1 DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "make install failed"
-
- #emake \
- # prefix="${D}"/usr \
- # mandir="${D}"/usr/share/man \
- # infodir="${D}"/usr/share/info \
- # libdir="${D}"/usr/$(get_libdir) \
- # install || die "emake install failed"
-
- # The portage shortcut to the above command is simply:
- #
- #einstall || die "einstall failed"
-}