summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/redo')
-rw-r--r--sys-devel/redo/Manifest2
-rw-r--r--sys-devel/redo/redo-0.10.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-devel/redo/Manifest b/sys-devel/redo/Manifest
index 88115c0..f04701e 100644
--- a/sys-devel/redo/Manifest
+++ b/sys-devel/redo/Manifest
@@ -1,2 +1,4 @@
DIST redo-0.07.tar.gz 74818 RMD160 e7de16a626fd883e55e09f56a2d6c2dafc025cf9 SHA1 415b256c51d53812fae33b4dde7f5b3387ae905f SHA256 3c6ef47bec112d8f3a6d0dad5c2e95120b5c0a695b590799926678d9f9bdd934
+DIST redo-0.10.tar.gz 76556 RMD160 336af2ecefd5eb349d1fd1a885c1cc5a9bd741bb SHA1 b6a1386a964d9d97206f92fbdfbc762b3a58b774 SHA256 beeafb8f8d851408ad7efb407e195be9b881103f4470e226638da6ec328dcb02
EBUILD redo-0.07.ebuild 1258 RMD160 99bfc6fad32ce20dced68102701a41fb2f56e7cd SHA1 071e0cdc315b4c9bfc4833a9ee622e9cce9f7d1f SHA256 14f26de8e98050aa4a1fd34121ac51165fb4961a18689ec49c8c8e6e2933e072
+EBUILD redo-0.10.ebuild 1565 RMD160 fc6b84157c8094f5cb885800797e88f6abddf36a SHA1 132ed889b05782646a496979bc0f63c56d4f9b1c SHA256 50c9c70116ec36b8985bd773d9906a6a525ef5521345748cecc31179d2c9ee3a
diff --git a/sys-devel/redo/redo-0.10.ebuild b/sys-devel/redo/redo-0.10.ebuild
new file mode 100644
index 0000000..0e78485
--- /dev/null
+++ b/sys-devel/redo/redo-0.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit eutils bash-completion
+
+DESCRIPTION="Smaller, easier, more powerful, and more reliable than make. An implementation of djb's redo."
+HOMEPAGE="http://github.com/apenwarr/redo"
+SRC_URI="https://github.com/apenwarr/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# We list the possible shells here, because redo creates a symlink to the one
+# it favores.
+DEPEND="|| (
+ dev-lang/python:2.4
+ dev-lang/python:2.5
+ dev-lang/python:2.6
+ dev-lang/python:2.7
+ )
+ dev-python/markdown
+ || (
+ app-shells/dash
+ app-shells/ksh
+ app-shells/mksh
+ app-shells/pdksh
+ app-shells/bash
+ app-shells/zsh
+ sys-apps/busybox
+ )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv -v * "${S}" || die
+}
+
+# We use 'make' here, because then we can use 'emake'.
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ dobashcompletion contrib/bash_completion.d/redo
+
+ dodoc "${D}/usr/share/doc/${PN}"/* && rm -r "${D}/usr/share/doc/${PN}/"
+
+ dodoc README.md
+}
+
+src_test() {
+ emake test || die "emake test failed"
+}
+
+pkg_postinst() {
+ ewarn "redo changed the meaning of \$1, \$2, and \$3 to be compatible with"
+ ewarn "djb redo. Please take that into account, or use the --old-args"
+ ewarn "option until you do. Also, note that redo is still a very young"
+ ewarn "project where such disruptive changes may still happen."
+}