summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukas Elsner <open@mindrunner.de>2012-04-15 14:42:02 +0200
committerLukas Elsner <open@mindrunner.de>2012-04-15 14:42:02 +0200
commit0701ffb6aa11773788c68253b9aaa659dfca36c0 (patch)
treeff6dd78750dd55b72c34fd51580470387248e0b4 /gnome-extra
parent.. (diff)
downloadluman-0701ffb6aa11773788c68253b9aaa659dfca36c0.tar.gz
luman-0701ffb6aa11773788c68253b9aaa659dfca36c0.tar.bz2
luman-0701ffb6aa11773788c68253b9aaa659dfca36c0.zip
..
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/cinnamon/Manifest5
-rw-r--r--gnome-extra/cinnamon/cinnamon-1.4-r1.ebuild233
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-1.1.3-automagic-gnome-bluetooth.patch44
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch171
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-1.4-notification.patch115
5 files changed, 568 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon/Manifest b/gnome-extra/cinnamon/Manifest
new file mode 100644
index 0000000..bc4dcc6
--- /dev/null
+++ b/gnome-extra/cinnamon/Manifest
@@ -0,0 +1,5 @@
+AUX cinnamon-1.1.3-automagic-gnome-bluetooth.patch 1841 RMD160 4b57dfeb42f299ef74799409132778b60ddc7a09 SHA1 4acf93b0bda58660b6c7ed5c8fdb6b06df86c035 SHA256 df5f86858b8abc08225ffb7679e829250e05a419b439b2ecad0f02bd93b670b2
+AUX cinnamon-1.3.1-optional-networkmanager.patch 6649 RMD160 458403c896c245240207d034b74218031d71331d SHA1 2207b02f60694f267d4511fb4538565618873750 SHA256 37bb34e61dbf4700d1a7ff92a47b1544a35edf3fc4eb5d863c295e2372613f01
+AUX cinnamon-1.4-notification.patch 4214 RMD160 8cc8d5f1c64fbdb7b780255c21d2a43ccc6a2db9 SHA1 c9753919f012a04cf41d810e7302bac00f4a273b SHA256 3c88fc9ab18ab5d9203b631f3986ee54ef44a1963480aaa141eab16dc260c578
+DIST cinnamon-1.4.tar.gz 2639153 RMD160 2282c0adb00d199f8dbf11f9e5a35600784aa795 SHA1 405db74662f23e99cc5646e74d2b5581adc860b5 SHA256 26fa922bfd73d3b8f4c954e6b79b97450bd6be4875680acafd823814bfd6d20f
+EBUILD cinnamon-1.4-r1.ebuild 8072 RMD160 840ac6a74372abe0620e44b1ea1219dc4d493125 SHA1 e59b65149390d4ddb334d3f492dc4905a96b2a19 SHA256 6309d98f611ed502e7878cab81ab6f191dc8fb0f74f8f4780d2874623fc10b74
diff --git a/gnome-extra/cinnamon/cinnamon-1.4-r1.ebuild b/gnome-extra/cinnamon/cinnamon-1.4-r1.ebuild
new file mode 100644
index 0000000..62b28a3
--- /dev/null
+++ b/gnome-extra/cinnamon/cinnamon-1.4-r1.ebuild
@@ -0,0 +1,233 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/cinnamon/cinnamon-1.4.ebuild,v 1.1 2012/03/15 06:05:24 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="xml"
+
+inherit autotools eutils gnome2 multilib pax-utils python
+
+DESCRIPTION="A fork of GNOME Shell with layout similar to GNOME 2"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+
+SRC_URI="https://github.com/linuxmint/Cinnamon/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+bluetooth +networkmanager"
+KEYWORDS="~amd64 ~x86"
+
+# gnome-desktop-2.91.2 is needed due to header changes, db82a33 in gnome-desktop
+# latest gsettings-desktop-schemas is needed due to commit 602fa1c6
+# latest g-c-c is needed due to https://bugs.gentoo.org/show_bug.cgi?id=360057
+# libXfixes-5.0 needed for pointer barriers
+# gnome-menus-3.2.0.1-r1 needed for new 10-xdg-menu-gnome
+COMMON_DEPEND=">=dev-libs/glib-2.29.10:2
+ >=dev-libs/gjs-1.29.18
+ >=dev-libs/gobject-introspection-0.10.1
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.0.0:3[introspection]
+ >=media-libs/clutter-1.7.5:1.0[introspection]
+ app-misc/ca-certificates
+ >=dev-libs/folks-0.5.2
+ >=dev-libs/json-glib-0.13.2
+ >=gnome-base/gnome-desktop-2.91.2:3[introspection]
+ >=gnome-base/gsettings-desktop-schemas-2.91.91
+ >=gnome-extra/evolution-data-server-2.91.6
+ >=media-libs/gstreamer-0.10.16:0.10
+ >=media-libs/gst-plugins-base-0.10.16:0.10
+ >=net-im/telepathy-logger-0.2.4[introspection]
+ net-libs/libsoup:2.4[introspection]
+ >=net-libs/telepathy-glib-0.15.5[introspection]
+ >=sys-auth/polkit-0.100[introspection]
+ >=x11-wm/muffin-1.0.2[introspection]
+
+ dev-libs/dbus-glib
+ dev-libs/libxml2:2
+ x11-libs/pango[introspection]
+ >=dev-libs/libcroco-0.6.2:0.6
+
+ gnome-base/gconf:2[introspection]
+ >=gnome-base/gnome-menus-3.2.0.1-r1:3[introspection]
+ gnome-base/librsvg
+ media-libs/libcanberra
+ media-sound/pulseaudio
+
+ >=x11-libs/startup-notification-0.11
+ x11-libs/libX11
+ >=x11-libs/libXfixes-5.0
+ x11-apps/mesa-progs
+
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.1.0[introspection] )
+ networkmanager? (
+ gnome-base/libgnome-keyring
+ >=net-misc/networkmanager-0.8.999[introspection] )"
+# Runtime-only deps are probably incomplete and approximate.
+# Each block:
+# 2. Introspection stuff + dconf needed via imports.gi.*
+# 3. gnome-session is needed for gnome-session-quit
+# 4. Control shell settings
+# 5. accountsservice is needed for GdmUserManager (0.6.14 needed for fast
+# user switching with gdm-3.1.x)
+# 6. caribou needed for on-screen keyboard
+# 7. xdg-utils needed for xdg-open, used by extension tool
+# 8. gconf-python needed for cinnamon-settings
+# 9. gnome-icon-theme-symbolic needed for various icons
+# 10. pygtk and gnome-menus:0 needed for menu editor
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/dconf-0.4.1
+ >=gnome-base/libgnomekbd-2.91.4[introspection]
+ sys-power/upower[introspection]
+
+ >=gnome-base/gnome-session-3.2.1-r1
+
+ >=gnome-base/gnome-settings-daemon-2.91
+ >=gnome-base/gnome-control-center-2.91.92-r1
+
+ >=sys-apps/accountsservice-0.6.14[introspection]
+
+ >=app-accessibility/caribou-0.3
+
+ x11-misc/xdg-utils
+
+ dev-python/dbus-python
+ dev-python/gconf-python:2
+
+ x11-themes/gnome-icon-theme-symbolic
+
+ dev-python/pygtk
+ gnome-base/gnome-menus:0[python]
+
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data )"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/pkgconfig-0.22
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ !!=dev-lang/spidermonkey-1.8.2*"
+# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
+# https://bugs.gentoo.org/show_bug.cgi?id=360413
+
+S="${WORKDIR}/linuxmint-Cinnamon-a8b1a03"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README"
+ # Don't error out on warnings
+ G2CONF="${G2CONF}
+ --enable-compile-warnings=maximum
+ --disable-schemas-compile
+ --disable-jhbuild-wrapper-script
+ $(use_with bluetooth)
+ $(use_enable networkmanager)
+ --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
+ BROWSER_PLUGIN_DIR=${EPREFIX}/usr/$(get_libdir)/nsbrowser/plugins"
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Fix automagic gnome-bluetooth dep, bug #398145
+ epatch "${FILESDIR}/${PN}-1.1.3-automagic-gnome-bluetooth.patch"
+
+ # Make networkmanager optional, bug #398593
+ epatch "${FILESDIR}/${PN}-1.3.1-optional-networkmanager.patch"
+
+ # Fix notification issue
+ epatch "${FILESDIR}/${PN}-1.4-notification.patch"
+
+ # Gentoo uses /usr/libexec
+ sed -e "s:/usr/lib/gnome-session/gnome-session-check-accelerated:${EPREFIX}/usr/libexec/gnome-session-check-accelerated:" \
+ -i "files/usr/share/gnome-session/sessions/cinnamon.session" || die "sed 1 failed"
+
+ # Gentoo uses /usr/$(get_libdir), not /usr/lib even for python
+ sed -e "s:/usr/lib/:/usr/$(get_libdir)/:" \
+ -e 's:"/usr/lib":"/usr/'"$(get_libdir)"'":' \
+ -i files/usr/bin/cinnamon-menu-editor \
+ -i files/usr/bin/cinnamon-settings \
+ -i files/usr/lib/cinnamon-menu-editor/Alacarte/config.py \
+ -i files/usr/lib/cinnamon-settings/cinnamon-settings.py \
+ -i files/generate_desktop_files || die "sed 2 failed"
+ if [[ "$(get_libdir)" != lib ]]; then
+ mv files/usr/lib "files/usr/$(get_libdir)" || die "mv failed"
+ fi
+
+ if ! use bluetooth; then
+ rm -rv files/usr/share/cinnamon/applets/bluetooth@cinnamon.org || die
+ fi
+
+ if ! use networkmanager; then
+ rm -rv files/usr/share/cinnamon/applets/network@cinnamon.org || die
+ fi
+
+ eautoreconf
+ gnome2_src_prepare
+
+ # Drop G_DISABLE_DEPRECATED for sanity on glib upgrades; bug #384765
+ # Note: sed Makefile.in because it is generated from several Makefile.ams
+ sed -e 's/-DG_DISABLE_DEPRECATED//g' \
+ -i src/Makefile.in browser-plugin/Makefile.in || die "sed 3 failed"
+}
+
+src_install() {
+ gnome2_src_install
+ python_convert_shebangs 2 "${ED}usr/bin/cinnamon-extension-tool" \
+ "${ED}usr/bin/cinnamon-menu-editor" \
+ "${ED}usr/bin/cinnamon-settings" \
+ "${ED}usr/$(get_libdir)/cinnamon-settings/cinnamon-settings.py"
+
+ # Required for gnome-shell on hardened/PaX, bug #398941
+ pax-mark mr "${ED}usr/bin/cinnamon"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize "/usr/$(get_libdir)/"cinnamon-{menu-editor,settings}
+
+ if ! has_version '>=media-libs/gst-plugins-good-0.10.23' || \
+ ! has_version 'media-plugins/gst-plugins-vp8'; then
+ ewarn "To make use of Cinnamon's built-in screen recording utility,"
+ ewarn "you need to either install >=media-libs/gst-plugins-good-0.10.23"
+ ewarn "and media-plugins/gst-plugins-vp8, or use dconf-editor to change"
+ ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
+ fi
+
+ if ! has_version ">=x11-base/xorg-server-1.11"; then
+ ewarn "If you use multiple screens, it is highly recommended that you"
+ ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
+ ewarn "pointer barriers which will make it easier to use hot corners."
+ fi
+
+ if has_version "<x11-drivers/ati-drivers-12"; then
+ ewarn "Cinnamon has been reported to show graphical corruption under"
+ ewarn "x11-drivers/ati-drivers-11.*; you may want to use GNOME in"
+ ewarn "fallback mode, or switch to open-source drivers."
+ fi
+
+ if has_version "media-libs/mesa[video_cards_radeon]"; then
+ elog "Cinnamon is unstable under classic-mode r300/r600 mesa drivers."
+ elog "Make sure that gallium architecture for r300 and r600 drivers is"
+ elog "selected using 'eselect mesa'."
+ if ! has_version "media-libs/mesa[gallium]"; then
+ ewarn "You will need to emerge media-libs/mesa with USE=gallium."
+ fi
+ fi
+
+ if has_version "media-libs/mesa[video_cards_intel]"; then
+ elog "Cinnamon is unstable under gallium-mode i915/i965 mesa drivers."
+ elog "Make sure that classic architecture for i915 and i965 drivers is"
+ elog "selected using 'eselect mesa'."
+ if ! has_version "media-libs/mesa[classic]"; then
+ ewarn "You will need to emerge media-libs/mesa with USE=classic."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup "/usr/$(get_libdir)/"cinnamon-{menu-editor,settings}
+}
diff --git a/gnome-extra/cinnamon/files/cinnamon-1.1.3-automagic-gnome-bluetooth.patch b/gnome-extra/cinnamon/files/cinnamon-1.1.3-automagic-gnome-bluetooth.patch
new file mode 100644
index 0000000..ae23a6c
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-1.1.3-automagic-gnome-bluetooth.patch
@@ -0,0 +1,44 @@
+From 84568fa9454f279ff519a2a11174e112786e46db Mon Sep 17 00:00:00 2001
+From: root <admin@catmur.co.uk>
+Date: Sun, 8 Jan 2012 13:55:05 +0000
+Subject: [PATCH] Fix automagic gnome-bluetooth dependency
+
+https://bugs.gentoo.org/show_bug.cgi?id=398145
+
+Ed Catmur 2012-01-08 13:46:22 UTC
+libgnome-bluetooth-applet is a private library so they shouldn't be linking
+against it anyway. I tried to work out how to tell libtool to add it to rpath
+but got totally lost.
+
+I'll see if I can work out how to fix the automagic gnome-bluetooth dependency
+so I can at least merge USE=-bluetooth.
+---
+ configure.ac | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1c64122..a699838 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -127,6 +127,8 @@ PKG_CHECK_MODULES(GVC, libpulse libpulse-mainloop-glib gobject-2.0)
+ PKG_CHECK_MODULES(DESKTOP_SCHEMAS, gsettings-desktop-schemas >= 0.1.7)
+
+ AC_MSG_CHECKING([for bluetooth support])
++AC_ARG_WITH([bluetooth], AS_HELP_STRING([--without-bluetooth], [Build without gnome-bluetooth library (default: auto)]))
++AS_IF([test "x$with_bluetooth" != "xno"], [
+ PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
+ [BLUETOOTH_DIR=`$PKG_CONFIG --variable=applet_libdir gnome-bluetooth-1.0`
+ BLUETOOTH_LIBS=`$PKG_CONFIG --variable=applet_libs gnome-bluetooth-1.0`
+@@ -138,6 +140,9 @@ PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
+ [AC_DEFINE([HAVE_BLUETOOTH],[0])
+ AC_SUBST([HAVE_BLUETOOTH],[0])
+ AC_MSG_RESULT([no])])
++], [AC_DEFINE([HAVE_BLUETOOTH],[0])
++ AC_SUBST([HAVE_BLUETOOTH],[0])
++ AC_MSG_RESULT([no])])
+
+ PKG_CHECK_MODULES(CALENDAR_SERVER, libecal-1.2 >= $LIBECAL_MIN_VERSION libedataserver-1.2 >= $LIBEDATASERVER_MIN_VERSION libedataserverui-3.0 >= $LIBEDATASERVERUI_MIN_VERSION gio-2.0)
+ AC_SUBST(CALENDAR_SERVER_CFLAGS)
+--
+1.7.8.2
+
diff --git a/gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch b/gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch
new file mode 100644
index 0000000..6e2d431
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch
@@ -0,0 +1,171 @@
+From aebde5fad2f477f40b62c96118128011bd821be0 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 25 Jan 2012 01:58:07 -0500
+Subject: [PATCH] Make NM optional
+
+Derived from a patch for gnome-shell by Michael Biebl <biebl@debian.org>
+(see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=652482#29)
+---
+ configure.ac | 48 ++++++++++++++++++++++++++++++++++++++++++++++--
+ js/misc/config.js.in | 2 ++
+ js/ui/main.js | 7 +++++--
+ src/Makefile.am | 13 ++++++++-----
+ 4 files changed, 61 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 49b5401..508a8cd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -94,8 +94,40 @@ PKG_CHECK_MODULES(CINNAMON, gio-2.0 >= $GIO_MIN_VERSION
+ libcanberra
+ telepathy-glib >= $TELEPATHY_GLIB_MIN_VERSION
+ telepathy-logger-0.2 >= $TELEPATHY_LOGGER_MIN_VERSION
+- polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes
+- libnm-glib libnm-util gnome-keyring-1)
++ polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes)
++
++##########################
++# Check for NetworkManager
++##########################
++NM_MIN_VERSION=0.9
++AC_ARG_ENABLE(networkmanager,
++ AS_HELP_STRING([--disable-networkmanager],
++ [disable NetworkManager support @<:@default=auto@:>@]),,
++ [enable_networkmanager=auto])
++
++if test "x$enable_networkmanager" != "xno"; then
++ PKG_CHECK_MODULES(NETWORKMANAGER,
++ [libnm-glib libnm-util gnome-keyring-1],
++ [have_networkmanager=yes],
++ [have_networkmanager=no])
++
++ CINNAMON_CFLAGS="$CINNAMON_CFLAGS $NETWORKMANAGER_CFLAGS"
++ CINNAMON_LIBS="$CINNAMON_LIBS $NETWORKMANAGER_LIBS"
++else
++ have_networkmanager="no (disabled)"
++fi
++
++if test "x$have_networkmanager" = "xyes"; then
++ AC_DEFINE(HAVE_NETWORKMANAGER, [1], [Define if we have NetworkManager])
++ AC_SUBST([HAVE_NETWORKMANAGER], [1])
++else
++ if test "x$enable_networkmanager" = "xyes"; then
++ AC_MSG_ERROR([Couldn't find NetworkManager.])
++ fi
++ AC_SUBST([HAVE_NETWORKMANAGER], [0])
++fi
++
++AM_CONDITIONAL(HAVE_NETWORKMANAGER, test "$have_networkmanager" = "yes")
+
+ PKG_CHECK_MODULES(CINNAMON_PERF_HELPER, gtk+-3.0 gio-2.0)
+
+@@ -250,3 +282,15 @@ AC_CONFIG_FILES([
+ files/Makefile
+ ])
+ AC_OUTPUT
++
++echo "
++Build configuration:
++
++ Prefix: ${prefix}
++ Source code location: ${srcdir}
++ Compiler: ${CC}
++ Compiler Warnings: $enable_compile_warnings
++
++ Support for NetworkManager: $have_networkmanager
++ Support for GStreamer recording: $build_recorder
++"
+diff --git a/js/misc/config.js.in b/js/misc/config.js.in
+index 704989b..df7e014 100644
+--- a/js/misc/config.js.in
++++ b/js/misc/config.js.in
+@@ -8,5 +8,7 @@ const PACKAGE_VERSION = '@PACKAGE_VERSION@';
+ const GJS_VERSION = '@GJS_VERSION@';
+ /* 1 if gnome-bluetooth is available, 0 otherwise */
+ const HAVE_BLUETOOTH = @HAVE_BLUETOOTH@;
++/* 1 if networkmanager is available, 0 otherwise */
++const HAVE_NETWORKMANAGER = @HAVE_NETWORKMANAGER@;
+ /* The system TLS CA list */
+ const CINNAMON_SYSTEM_CA_FILE = '@CINNAMON_SYSTEM_CA_FILE@';
+diff --git a/js/ui/main.js b/js/ui/main.js
+index ae15997..803e6f4 100644
+--- a/js/ui/main.js
++++ b/js/ui/main.js
+@@ -14,6 +14,7 @@ const St = imports.gi.St;
+
+ const AutomountManager = imports.ui.automountManager;
+ const AutorunManager = imports.ui.autorunManager;
++const Config = imports.misc.config;
+ const EndSessionDialog = imports.ui.endSessionDialog;
+ const PolkitAuthenticationAgent = imports.ui.polkitAuthenticationAgent;
+ const Environment = imports.ui.environment;
+@@ -27,7 +28,7 @@ const PlacesManager = imports.ui.placesManager;
+ const RunDialog = imports.ui.runDialog;
+ const Layout = imports.ui.layout;
+ const LookingGlass = imports.ui.lookingGlass;
+-const NetworkAgent = imports.ui.networkAgent;
++const NetworkAgent = Config.HAVE_NETWORKMANAGER ? imports.ui.networkAgent : null;
+ const NotificationDaemon = imports.ui.notificationDaemon;
+ const WindowAttentionHandler = imports.ui.windowAttentionHandler;
+ const Scripting = imports.ui.scripting;
+@@ -88,7 +89,9 @@ function _createUserSession() {
+ placesManager = new PlacesManager.PlacesManager();
+ automountManager = new AutomountManager.AutomountManager();
+ autorunManager = new AutorunManager.AutorunManager();
+- networkAgent = new NetworkAgent.NetworkAgent();
++ if (Config.HAVE_NETWORKMANAGER) {
++ networkAgent = new NetworkAgent.NetworkAgent();
++ }
+ }
+
+ function _createGDMSession() {
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 182bf17..54770e7 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -108,9 +108,7 @@ cinnamon_public_headers_h = \
+ cinnamon-generic-container.h \
+ cinnamon-gtk-embed.h \
+ cinnamon-global.h \
+- cinnamon-mobile-providers.h \
+ cinnamon-mount-operation.h \
+- cinnamon-network-agent.h \
+ cinnamon-perf-log.h \
+ cinnamon-slicer.h \
+ cinnamon-stack.h \
+@@ -145,9 +143,7 @@ libcinnamon_la_SOURCES = \
+ cinnamon-generic-container.c \
+ cinnamon-gtk-embed.c \
+ cinnamon-global.c \
+- cinnamon-mobile-providers.c \
+ cinnamon-mount-operation.c \
+- cinnamon-network-agent.c \
+ cinnamon-perf-log.c \
+ cinnamon-polkit-authentication-agent.h \
+ cinnamon-polkit-authentication-agent.c \
+@@ -161,6 +157,10 @@ libcinnamon_la_SOURCES = \
+ cinnamon-wm.c \
+ cinnamon-xfixes-cursor.c
+
++if HAVE_NETWORKMANAGER
++libcinnamon_la_SOURCES += cinnamon-mobile-providers.h cinnamon-mobile-providers.c cinnamon-network-agent.h cinnamon-network-agent.c
++endif
++
+ libcinnamon_la_gir_sources = \
+ $(filter-out %-private.h $(cinnamon_recorder_non_gir_sources), $(cinnamon_public_headers_h) $(libcinnamon_la_SOURCES))
+
+@@ -272,7 +272,10 @@ libcinnamon_la_LIBADD = \
+ libcinnamon_la_CPPFLAGS = $(cinnamon_cflags)
+
+ Cinnamon-0.1.gir: libcinnamon.la St-1.0.gir
+-Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 TelepathyLogger-0.2 Soup-2.4 GMenu-3.0 NetworkManager-1.0 NMClient-1.0 Folks-0.6
++Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 TelepathyLogger-0.2 Soup-2.4 GMenu-3.0 Folks-0.6
++if HAVE_NETWORKMANAGER
++Cinnamon_0_1_gir_INCLUDES += NetworkManager-1.0 NMClient-1.0
++endif
+ Cinnamon_0_1_gir_CFLAGS = $(libcinnamon_la_CPPFLAGS) -I $(srcdir)
+ Cinnamon_0_1_gir_LIBS = libcinnamon.la
+ Cinnamon_0_1_gir_FILES = $(libcinnamon_la_gir_sources)
+--
+1.7.8.4
+
diff --git a/gnome-extra/cinnamon/files/cinnamon-1.4-notification.patch b/gnome-extra/cinnamon/files/cinnamon-1.4-notification.patch
new file mode 100644
index 0000000..83d6938
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-1.4-notification.patch
@@ -0,0 +1,115 @@
+From 3af53231970861564c01c5f64fe18fe128d2e246 Mon Sep 17 00:00:00 2001
+From: Lukas Elsner <open@mindrunner.de>
+Date: Sun, 15 Apr 2012 14:33:34 +0200
+Subject: [PATCH] implemented rat4's patch
+
+---
+ data/org.cinnamon.gschema.xml | 6 ++++
+ data/org.cinnamon.gschema.xml.in | 5 ++++
+ js/ui/windowAttentionHandler.js | 48 +++++++++++++++++++++++++++++++++++--
+ 3 files changed, 56 insertions(+), 3 deletions(-)
+
+diff --git a/data/org.cinnamon.gschema.xml b/data/org.cinnamon.gschema.xml
+index a413619..28ad28b 100644
+--- a/data/org.cinnamon.gschema.xml
++++ b/data/org.cinnamon.gschema.xml
+@@ -127,6 +127,12 @@
+ <description>Layout styles: traditional (1 panel at the bottom), flipped (1 panel on top), classic (1 panel on top, 1 panel at the bottom)</description>
+ </key>
+
++ <key type="i" name="notification-style">
++ <range min="0" max="2"/>
++ <default>2</default>
++ <summary>Notification style</summary>
++ </key>
++
+ <key type="s" name="date-format">
+ <default>"YYYY-MM-DD"</default>
+ <summary>Auto-hide panel</summary>
+diff --git a/data/org.cinnamon.gschema.xml.in b/data/org.cinnamon.gschema.xml.in
+index c496c3d..e598146 100644
+--- a/data/org.cinnamon.gschema.xml.in
++++ b/data/org.cinnamon.gschema.xml.in
+@@ -175,6 +175,11 @@
+ </_description>
+ </key>
+
++ <key type="i" name="notification-style">
++ <default>2</default>
++ <_summary>Notification style</_summary>
++ </key>
++
+ <key name="date-format" type="s">
+ <default>"YYYY-MM-DD"</default>
+ <_summary>Auto-hide panel</_summary>
+diff --git a/js/ui/windowAttentionHandler.js b/js/ui/windowAttentionHandler.js
+index a81f10c..7594ed0 100644
+--- a/js/ui/windowAttentionHandler.js
++++ b/js/ui/windowAttentionHandler.js
+@@ -12,8 +12,18 @@ function WindowAttentionHandler() {
+
+ WindowAttentionHandler.prototype = {
+ _init : function() {
+- this._tracker = Cinnamon.WindowTracker.get_default();
+- global.display.connect('window-demands-attention', Lang.bind(this, this._onWindowDemandsAttention));
++ this.notification_style = global.settings.get_int("notification-style");
++ global.settings.connect("changed::notification-style", Lang.bind(this, function() {
++ this.notification_style = global.settings.get_int("notification-style");
++ }));
++ this._tracker = Cinnamon.WindowTracker.get_default();
++ global.display.connect('window-demands-attention', Lang.bind(this, this._onWindowDemandsAttention));
++ },
++
++ _getTitleAndBanner: function(app, window) {
++ let title = app.get_name();
++ let banner = _("'%s' is ready").format(window.get_title());
++ return [title, banner]
+ },
+
+ _onWindowDemandsAttention : function(display, window) {
+@@ -28,9 +38,41 @@ WindowAttentionHandler.prototype = {
+ if (!window || window.has_focus() || window.is_skip_taskbar())
+ return;
+
+- if (this._tracker.is_window_interesting(window)) {
++ switch (this.notification_style) {
++ case 0:
++ break;
++ case 1:
++ this.bringToFront(window);
++ break;
++ case 2:
++ this.showBanner(window);
++ break;
++ default:
++ global.log('Unknown notification style: ' + this.notification_style);
++ }
++
++ },
++
++ bringToFront : function(window) {
++ if (this._tracker.is_window_interesting(window)) {
+ window.activate(global.get_current_time());
+ }
++ },
++
++ showBanner : function(window) {
++ let app = this._tracker.get_window_app(window);
++ let source = new Source(app, window);
++ if (Main.messageTray) Main.messageTray.add(source);
++
++ let [title, banner] = this._getTitleAndBanner(app, window);
++
++ let notification = new MessageTray.Notification(source, title, banner);
++ source.notify(notification);
++
++ source.signalIDs.push(window.connect('notify::title', Lang.bind(this, function() {
++ let [title, banner] = this._getTitleAndBanner(app, window);
++ notification.update(title, banner);
++ })));
+ }
+ };
+
+--
+1.7.8.5
+