aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel de Oliveira <menelkir@itroll.org>2010-05-31 10:20:07 -0300
committerDaniel de Oliveira <menelkir@itroll.org>2010-05-31 10:20:07 -0300
commit1c803c36125ff6b9994a13d8a8f477139e307c27 (patch)
tree3ddeb53f73c908c5bf1b4cf9268293816f8d2f4d
parent deleted: test (diff)
downloadmenelkir-1c803c36125ff6b9994a13d8a8f477139e307c27.tar.gz
menelkir-1c803c36125ff6b9994a13d8a8f477139e307c27.tar.bz2
menelkir-1c803c36125ff6b9994a13d8a8f477139e307c27.zip
new file: app-admin/usermin/ChangeLog
new file: app-admin/usermin/Manifest new file: app-admin/usermin/files/init.d.usermin new file: app-admin/usermin/files/usermin-1.080-safestop.patch new file: app-admin/usermin/files/usermin-1.150-setup-nocheck.patch new file: app-admin/usermin/files/usermin.pam-include.1 new file: app-admin/usermin/usermin-1.440.ebuild
-rw-r--r--app-admin/usermin/ChangeLog9
-rw-r--r--app-admin/usermin/Manifest7
-rw-r--r--app-admin/usermin/files/init.d.usermin38
-rw-r--r--app-admin/usermin/files/usermin-1.080-safestop.patch12
-rw-r--r--app-admin/usermin/files/usermin-1.150-setup-nocheck.patch22
-rw-r--r--app-admin/usermin/files/usermin.pam-include.111
-rw-r--r--app-admin/usermin/usermin-1.440.ebuild85
7 files changed, 184 insertions, 0 deletions
diff --git a/app-admin/usermin/ChangeLog b/app-admin/usermin/ChangeLog
new file mode 100644
index 0000000..b24e0fc
--- /dev/null
+++ b/app-admin/usermin/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-admin/webmin
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.188 2010/01/08 17:50:14 a3li Exp $
+
+*usermin-1.440 (31 May 2010)
+
+ 31 May 2010; Daniel Oliveira <menelkir@itroll.org> +usermin-1.440.ebuild:
+ Bump (unmaintained by official tree)
+
diff --git a/app-admin/usermin/Manifest b/app-admin/usermin/Manifest
new file mode 100644
index 0000000..b171953
--- /dev/null
+++ b/app-admin/usermin/Manifest
@@ -0,0 +1,7 @@
+AUX init.d.usermin 825 RMD160 e3b471844d7dfdfaaa00d3da73d679514f29e5a0 SHA1 65701d01c9b880587d279f8b77711e3551ef175e SHA256 b1103d5c733a0c49a19c407a718617454342b19c34f238f11dc20be3356d38bf
+AUX usermin-1.080-safestop.patch 620 RMD160 2d15ab821d0dd70236260c5a5de3dbd09654cb9b SHA1 bf5a1e75346e5550365dcb6b1646b9e64368c2a2 SHA256 cd4ed0f18303bfd518791993f413a9b338a5e621a9ee17367f5590d1a970ea98
+AUX usermin-1.150-setup-nocheck.patch 998 RMD160 2ca2541b8c71bea584ef2b69364c3a564ef95b3a SHA1 9e6d31f76bea67845b54e69e394484bc79cbc0d6 SHA256 e7d550caed8dc773102ca1330fb51de7f82c3763c1a70a1df8cebad7da0afb27
+AUX usermin.pam-include.1 210 RMD160 8933bcb2018ff43b9b5ee2124fc1a87fbfafc8bb SHA1 525a78c675402c3ddc4ab49da9ffe3fbe2c475d2 SHA256 facea91616049551f44655a7f8a270c61dd571e860284abc972fd3430a9b8d50
+DIST usermin-1.440.tar.gz 6082587 RMD160 dfd1d25bc90377d29c6e9f696e861fd37322fdf7 SHA1 148d0a3ca5855df9cd3c5fcdd55751ecdf2d3beb SHA256 29399732338c173133d0841a6b1842be92cf7eff6023d8a5ab1e49037aa87637
+EBUILD usermin-1.440.ebuild 2243 RMD160 466b8b9a91586bab69c7516168ee0ef015893cd5 SHA1 12a2808f60d0a33468c074d9b644a39d3bc763f5 SHA256 e3e110cbf7066c54d2971230e7c35efe76a7280cf7d25558507329349371aafe
+MISC ChangeLog 351 RMD160 78ed0e50cdf125d236842e5f72cf96d0197028fd SHA1 b8b780543d0cc43e6e511c20ed79d94087662195 SHA256 fbe2ec912e411502dfff3ba0cbebb892a18931bbcd7a291b5af7c57dc627ebab
diff --git a/app-admin/usermin/files/init.d.usermin b/app-admin/usermin/files/init.d.usermin
new file mode 100644
index 0000000..05cfb9f
--- /dev/null
+++ b/app-admin/usermin/files/init.d.usermin
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/files/init.d.usermin,v 1.6 2005/08/17 21:02:30 eradicator Exp $
+
+depend() {
+ use net logger
+}
+
+
+checkconfig() {
+ if [ -f /etc/usermin/config ]; then
+ return 0;
+ else
+ eerror "Error starting usermin. Have you run '/usr/libexec/usermin/setup.sh'?"
+ return 1;
+ fi
+}
+
+start() { # copied from /etc/usermin/start
+ checkconfig || return 1
+ ebegin "Starting Usermin"
+
+ LANG=
+ export LANG
+
+ unset PERLIO
+ export PERLIO
+ start-stop-daemon --start --quiet \
+ --exec /usr/libexec/usermin/miniserv.pl -- /etc/usermin/miniserv.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Usermin"
+ start-stop-daemon --stop --pidfile /var/run/usermin.pid --quiet
+ eend $?
+}
diff --git a/app-admin/usermin/files/usermin-1.080-safestop.patch b/app-admin/usermin/files/usermin-1.080-safestop.patch
new file mode 100644
index 0000000..2cfd7e2
--- /dev/null
+++ b/app-admin/usermin/files/usermin-1.080-safestop.patch
@@ -0,0 +1,12 @@
+diff -Naur usermin-1.080.orig/setup.sh usermin-1.080/setup.sh
+--- usermin-1.080.orig/setup.sh 2004-06-03 16:18:07.000000000 -0700
++++ usermin-1.080/setup.sh 2004-07-26 01:27:23.959104711 -0700
+@@ -487,7 +487,7 @@
+ echo "#!/bin/sh" >>$config_dir/stop
+ echo "echo Stopping Usermin server in $wadir" >>$config_dir/stop
+ echo "pidfile=\`grep \"^pidfile=\" $config_dir/miniserv.conf | sed -e 's/pidfile=//g'\`" >>$config_dir/stop
+-echo "kill \`cat \$pidfile\`" >>$config_dir/stop
++echo "test -z \"\$pidfile\" || kill \`cat \$pidfile\`" >>$config_dir/stop
+ chmod 755 $config_dir/start $config_dir/stop
+ echo "..done"
+ echo ""
diff --git a/app-admin/usermin/files/usermin-1.150-setup-nocheck.patch b/app-admin/usermin/files/usermin-1.150-setup-nocheck.patch
new file mode 100644
index 0000000..6b4a06f
--- /dev/null
+++ b/app-admin/usermin/files/usermin-1.150-setup-nocheck.patch
@@ -0,0 +1,22 @@
+diff -Naurp usermin-1.150.orig/setup.sh usermin-1.150/setup.sh
+--- usermin-1.150.orig/setup.sh 2005-09-03 16:19:50.000000000 -0700
++++ usermin-1.150/setup.sh 2005-09-03 16:21:01.000000000 -0700
+@@ -342,12 +342,12 @@ else
+ echo ""
+ exit 12
+ fi
+- $perl -e 'use Socket; socket(FOO, PF_INET, SOCK_STREAM, getprotobyname("tcp")); setsockopt(FOO, SOL_SOCKET, SO_REUSEADDR, pack("l", 1)); bind(FOO, pack_sockaddr_in($ARGV[0], INADDR_ANY)) || exit(1); exit(0);' $port
+- if [ $? != "0" ]; then
+- echo "ERROR: TCP port $port is already in use by another program"
+- echo ""
+- exit 13
+- fi
++ #$perl -e 'use Socket; socket(FOO, PF_INET, SOCK_STREAM, getprotobyname("tcp")); setsockopt(FOO, SOL_SOCKET, SO_REUSEADDR, pack("l", 1)); bind(FOO, pack_sockaddr_in($ARGV[0], INADDR_ANY)) || exit(1); exit(0);' $port
++ #if [ $? != "0" ]; then
++ # echo "ERROR: TCP port $port is already in use by another program"
++ # echo ""
++ # exit 13
++ #fi
+
+ # Ask the user if SSL should be used
+ if [ "$ssl" = "" ]; then
diff --git a/app-admin/usermin/files/usermin.pam-include.1 b/app-admin/usermin/files/usermin.pam-include.1
new file mode 100644
index 0000000..50d360c
--- /dev/null
+++ b/app-admin/usermin/files/usermin.pam-include.1
@@ -0,0 +1,11 @@
+#%PAM-1.0
+
+auth required pam_securetty.so
+auth required pam_nologin.so
+auth include system-auth
+
+account include system-auth
+
+password include system-auth
+
+session include system-auth
diff --git a/app-admin/usermin/usermin-1.440.ebuild b/app-admin/usermin/usermin-1.440.ebuild
new file mode 100644
index 0000000..2ec8024
--- /dev/null
+++ b/app-admin/usermin/usermin-1.440.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/usermin-1.430.ebuild,v 1.1 2009/12/09 14:55:25 patrick Exp $
+
+IUSE="ssl"
+
+inherit eutils pam
+
+DESCRIPTION="a web-based user administration interface"
+HOMEPAGE="http://www.webmin.com/index6.html"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/perl"
+
+RDEPEND="${DEPEND}
+ sys-process/lsof
+ ssl? ( dev-perl/Net-SSLeay )"
+
+# pam? ( dev-perl/Authen-PAM )
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # Point to the correct mysql location
+ sed -i -e "s:/usr/local/mysql:/usr:g" mysql/config
+
+ epatch "${FILESDIR}"/${PN}-1.080-safestop.patch
+ epatch "${FILESDIR}"/${PN}-1.150-setup-nocheck.patch
+}
+
+src_install() {
+ # Change /usr/local/bin/perl references
+ find . -type f | xargs sed -i -e 's:^#!.*/usr/local/bin/perl:#!/usr/bin/perl:'
+
+ dodir /usr/libexec/usermin
+ cp -pR * "${D}"/usr/libexec/usermin
+
+ newinitd "${FILESDIR}"/init.d.usermin usermin
+
+ newpamd "${FILESDIR}"/${PN}.pam-include.1 ${PN}
+
+ # Fix ownership
+ chown -R root:0 "${D}"
+
+ dodir /etc/usermin
+ dodir /var/log/usermin
+
+ config_dir=${D}/etc/usermin
+ var_dir=${D}/var/log/usermin
+ perl=/usr/bin/perl
+ autoos=1
+ port=20000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ "${D}"/usr/libexec/usermin/setup.sh > "${T}"/usermin-setup.out 2>&1 || die "Failed to create initial usermin configuration."
+
+ # Fixup the config files to use their real locations
+ sed -i -e "s:^pidfile=.*$:pidfile=/var/run/usermin.pid:" "${D}"/etc/usermin/miniserv.conf
+ find "${D}"/etc/usermin -type f | xargs sed -i -e "s:${D}:/:g"
+
+ # Cleanup from the config script
+ rm -rf "${D}"/var/log/usermin
+ keepdir /var/log/usermin/
+}
+
+pkg_postinst() {
+ elog "To make usermin start at boot time, run: 'rc-update add usermin default'."
+ elog "Point your web browser to https://localhost:20000 to use usermin."
+}