summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@rakete.triemli>2011-09-13 17:39:13 +0200
committerroot <root@rakete.triemli>2011-09-13 17:39:13 +0200
commitdac30fdad4f30287464179a57122bde8a1f7f009 (patch)
treeaddd271aca993f96f33e6daa9b2ea265292204b5
parentadded libspnav (3dconnexion space navigator driver) (diff)
downloadmistafunk-dac30fdad4f30287464179a57122bde8a1f7f009.tar.gz
mistafunk-dac30fdad4f30287464179a57122bde8a1f7f009.tar.bz2
mistafunk-dac30fdad4f30287464179a57122bde8a1f7f009.zip
initial ebuild for perceptualdiff
-rw-r--r--media-gfx/pdiff/Manifest3
-rw-r--r--media-gfx/pdiff/files/pdiff-1.1.1-cstdio.patch11
-rw-r--r--media-gfx/pdiff/pdiff-1.1.1.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/pdiff/Manifest b/media-gfx/pdiff/Manifest
new file mode 100644
index 0000000..7b2573b
--- /dev/null
+++ b/media-gfx/pdiff/Manifest
@@ -0,0 +1,3 @@
+AUX pdiff-1.1.1-cstdio.patch 401 RMD160 65f8b6c41aa82df10c0e5939cad11964234a30a0 SHA1 d334c214af62f18087a0bbaa1969562bf0a8930f SHA256 03dd8bedd6afe0bea89053bbf3e75b20c28742295117b6ccf92f88c2a8b5e82a
+DIST perceptualdiff-1.1.1-src.tar.gz 17440 RMD160 06a97f30eb2489188750b62e6792c65f61bff4f2 SHA1 45be238e657313aed9977f43e5a7fde6e55dddc7 SHA256 ab349279a63018663930133b04852bde2f6a373cc175184b615944a10c1c7c6a
+EBUILD pdiff-1.1.1.ebuild 643 RMD160 eaa111dce091a260648f26361673a27ed75cc4a7 SHA1 21f8405275bd3564d43a9cb045fe20b651507fd0 SHA256 32ceb74b89c4f24c3d3345c01206273d2eafd58e801871a7c5c67fc833f4412e
diff --git a/media-gfx/pdiff/files/pdiff-1.1.1-cstdio.patch b/media-gfx/pdiff/files/pdiff-1.1.1-cstdio.patch
new file mode 100644
index 0000000..c01f569
--- /dev/null
+++ b/media-gfx/pdiff/files/pdiff-1.1.1-cstdio.patch
@@ -0,0 +1,11 @@
+diff -urN /var/tmp/portage/media-gfx/pdiff-1.1.1/work//Metric.cpp /tmp/pdiffwork//Metric.cpp
+--- /var/tmp/portage/media-gfx/pdiff-1.1.1/work//Metric.cpp 2009-05-22 23:27:14.000000000 +0200
++++ /tmp/pdiffwork//Metric.cpp 2011-09-13 17:32:38.956622998 +0200
+@@ -19,6 +19,7 @@
+ #include "RGBAImage.h"
+ #include "LPyramid.h"
+ #include <math.h>
++#include <cstdio>
+
+ #ifndef M_PI
+ #define M_PI 3.14159265f
diff --git a/media-gfx/pdiff/pdiff-1.1.1.ebuild b/media-gfx/pdiff/pdiff-1.1.1.ebuild
new file mode 100644
index 0000000..9eeb127
--- /dev/null
+++ b/media-gfx/pdiff/pdiff-1.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="PerceptualDiff is an image comparison utility that makes use of a computational model of the human visual system to compare two images."
+HOMEPAGE="http://http://pdiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pdiff/pdiff/perceptualdiff-${PV}/perceptualdiff-${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PF}-cstdio.patch" )
+
+S=${WORKDIR}
+
+#src_install() {
+#${CMAKE_BUILD_DIR}
+#}