summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Haegler <simon.haegler@mistafunk.ch>2011-11-27 19:33:29 +0100
committerSimon Haegler <simon.haegler@mistafunk.ch>2011-11-27 19:33:29 +0100
commit306c17e14aaf2c2a8a2d8de04961df164a220054 (patch)
treedeab88848385957b10f6b5133846bdb29815fe22 /media-libs/spacenav/spacenav-9999.ebuild
parenttest (diff)
parentuse flag fixes & manifest updates (diff)
downloadmistafunk-306c17e14aaf2c2a8a2d8de04961df164a220054.tar.gz
mistafunk-306c17e14aaf2c2a8a2d8de04961df164a220054.tar.bz2
mistafunk-306c17e14aaf2c2a8a2d8de04961df164a220054.zip
Merge branch 'master' of /home/shaegler/dev/gentoo/mistafunk-gentoo-overlay
Diffstat (limited to 'media-libs/spacenav/spacenav-9999.ebuild')
-rw-r--r--media-libs/spacenav/spacenav-9999.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/spacenav/spacenav-9999.ebuild b/media-libs/spacenav/spacenav-9999.ebuild
new file mode 100644
index 0000000..019e7bf
--- /dev/null
+++ b/media-libs/spacenav/spacenav-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+EAPI=3
+
+DESCRIPTION="Spacenavd is a free software replacement user-space driver (daemon), for 3Dconnexion's space-something 6dof input devices."
+HOMEPAGE="http://spacenav.sourceforge.net/"
+ESVN_REPO_URI="https://spacenav.svn.sourceforge.net/svnroot/spacenav/trunk"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ pushd spacenavd
+ sed -i "/CFLAGS =/s/$/ ${CFLAGS}/" Makefile.in
+ sed -i "/DAEMON=/s/\/local\//\//" init_script
+ econf --prefix="${D}/usr" || die "configure spacenavd failed"
+ popd
+ pushd spnavcfg
+ sed -i "/CFLAGS =/s/$/ ${CFLAGS}/" Makefile.in
+ econf --prefix="${D}/usr" || die "configure spnavcfg failed"
+ popd
+ pushd libspnav
+ sed -i "/CFLAGS =/s/$/ ${CFLAGS}/" Makefile.in
+ econf --prefix="${D}/usr" || die "configure libspnav failed"
+ popd
+}
+
+src_compile() {
+ pushd spacenavd
+ emake || die "compiling spacenavd failed"
+ popd
+ pushd spnavcfg
+ emake || die "compiling spnavcfg failed"
+ popd
+ pushd libspnav
+ emake || die "compilinge libspnav failed"
+ popd
+}
+
+src_install() {
+ pushd spacenavd
+ emake install || die "install failed"
+ newinitd init_script ${PN}
+ popd
+ pushd spnavcfg
+ emake install || die "installing spnavcfg failed"
+ popd
+ pushd libspnav
+ emake install || die "installing libspnav failed"
+ popd
+}