summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/levmar/files/2.5-cmake.patch')
-rw-r--r--sci-libs/levmar/files/2.5-cmake.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/sci-libs/levmar/files/2.5-cmake.patch b/sci-libs/levmar/files/2.5-cmake.patch
new file mode 100644
index 0000000..f74e21f
--- /dev/null
+++ b/sci-libs/levmar/files/2.5-cmake.patch
@@ -0,0 +1,15 @@
+--- levmar-2.5/CMakeLists.txt.orig 2010-05-28 10:55:27.000000000 +0200
++++ levmar-2.5/CMakeLists.txt 2010-05-28 10:57:30.000000000 +0200
+@@ -2,7 +2,11 @@
+ # http://www.insightsoftwareconsortium.org/wiki/index.php/CMake_Tutorial
+
+ PROJECT(LEVMAR)
+-#CMAKE_MINIMUM_REQUIRED(VERSION 1.4)
++CMAKE_MINIMUM_REQUIRED(VERSION 1.4)
++
++if(COMMAND cmake_policy)
++ cmake_policy(SET CMP0003 NEW)
++endif(COMMAND cmake_policy)
+
+ # compiler flags
+ #ADD_DEFINITIONS(-DLINSOLVERS_RETAIN_MEMORY) # do not free memory between linear solvers calls