summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-07-10 22:54:25 +0200
committerMartin Väth <martin@mvath.de>2016-07-10 22:54:25 +0200
commita1abfb43d8489e0987413a277748ec39857246e6 (patch)
tree1efe335bfef557837d5a1d779c16411dcfee3b7b
parentnet-print/foo2zjs: Version bump (diff)
downloadmv-a1abfb43d8489e0987413a277748ec39857246e6.tar.gz
mv-a1abfb43d8489e0987413a277748ec39857246e6.tar.bz2
mv-a1abfb43d8489e0987413a277748ec39857246e6.zip
Bump to EAPI=6
-rw-r--r--app-shells/command-not-found/command-not-found-0.4.5.ebuild6
-rw-r--r--app-text/stardict/stardict-3.0.6-r2.ebuild6
-rw-r--r--sci-mathematics/genius/genius-1.0.19.ebuild27
3 files changed, 20 insertions, 19 deletions
diff --git a/app-shells/command-not-found/command-not-found-0.4.5.ebuild b/app-shells/command-not-found/command-not-found-0.4.5.ebuild
index 8fd98465..75bd2719 100644
--- a/app-shells/command-not-found/command-not-found-0.4.5.ebuild
+++ b/app-shells/command-not-found/command-not-found-0.4.5.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
RESTRICT="mirror"
-inherit cmake-utils eutils flag-o-matic multilib
+inherit cmake-utils flag-o-matic multilib
DESCRIPTION="search ARCH database for packages with similar commands"
HOMEPAGE="https://github.com/metti/command-not-found/"
@@ -31,7 +31,7 @@ src_prepare() {
CMakeLists.txt || die
sed -i -e "s/function[[:space:]]*\([^[:space:](]*\)[[:space:]]*(/\1(/" \
cnf.sh || die
- epatch_user
+ eapply_user
}
src_install() {
diff --git a/app-text/stardict/stardict-3.0.6-r2.ebuild b/app-text/stardict/stardict-3.0.6-r2.ebuild
index 0ef73996..517d15ae 100644
--- a/app-text/stardict/stardict-3.0.6-r2.ebuild
+++ b/app-text/stardict/stardict-3.0.6-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
# NOTE: Even though the *.dict.dz are the same as dictd/freedict's files,
# their indexes seem to be in a different format. So we'll keep them
@@ -11,9 +11,8 @@ EAPI=5
# NOTE: Festival plugin crashes, bug 188684. Disable for now.
GNOME2_LA_PUNT=yes
-GCONF_DEBUG=no
-inherit autotools eutils flag-o-matic gnome2
+inherit autotools flag-o-matic gnome2
DESCRIPTION="A international dictionary supporting fuzzy and glob style matching"
HOMEPAGE="http://stardict-4.sourceforge.net/"
@@ -58,6 +57,7 @@ DEPEND="${COMMON_DEPEND}
"
src_prepare() {
+ eapply_user
if ! use gnome
then sed -i \
-e 's/GNOME_DOC_INIT/GNOME_DOC_INIT([0.32],[:],[:])/' \
diff --git a/sci-mathematics/genius/genius-1.0.19.ebuild b/sci-mathematics/genius/genius-1.0.19.ebuild
index 90ab0af5..e7fb7b00 100644
--- a/sci-mathematics/genius/genius-1.0.19.ebuild
+++ b/sci-mathematics/genius/genius-1.0.19.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit autotools eutils gnome2
+EAPI=6
+inherit autotools gnome2
DESCRIPTION="Genius Mathematics Tool and the GEL Language"
HOMEPAGE="http://www.jirka.org/genius.html"
@@ -38,27 +38,28 @@ DEPEND="${RDEPEND}
sys-devel/flex
nls? ( sys-devel/gettext )"
+DOCS=(AUTHORS ChangeLog NEWS README TODO)
+
src_prepare() {
+ eapply_user
if ! use gnome
- then sed -i \
- -e "/GNOME_DOC_INIT/d" \
- configure.in
+ then sed -e "/GNOME_DOC_INIT/d" \
+ configure.in >configure.ac
+ rm configure.in
sed -i \
-e '/gnome-doc-utils\.make/d' \
help/Makefile.am
eautoreconf
fi
- G2CONF="${G2CONF} $(use_enable gnome) $(use_enable nls) \
+}
+
+src_configure() {
+ gnome2_src_configure $(use_enable gnome) $(use_enable nls) \
--disable-update-mimedb --disable-scrollkeeper \
- --disable-extra-gcc-optimization"
- # gnome2.eclass adds --disable-gtk-doc or --enable-gtk-doc to G2CONF
- # if there is the USE flag doc, thus leading to QA warnings
- GCONF_DEBUG="no"
- DOCS="AUTHORS ChangeLog NEWS README TODO"
- USE_DESTDIR="1"
+ --disable-extra-gcc-optimization
}
src_install() {
- use doc && DOCS+=" ${DISTDIR}/${PN}-reference.pdf"
+ use doc && dodoc "${DISTDIR}/${PN}-reference.pdf"
gnome2_src_install
}