summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-02-19 17:30:57 +0100
committerMartin Väth <martin@mvath.de>2017-02-19 17:37:04 +0100
commitae534027c4d06007a2bf89380fd2dfc10161f343 (patch)
treed42b510040f34f536b6bd73e621f57f99ffaa832
parentwww-plugins/epubreader: Version bump (diff)
downloadmv-ae534027c4d06007a2bf89380fd2dfc10161f343.tar.gz
mv-ae534027c4d06007a2bf89380fd2dfc10161f343.tar.bz2
mv-ae534027c4d06007a2bf89380fd2dfc10161f343.zip
games-board/chessproblem: Version bumps, slotting
-rw-r--r--games-board/chessproblem/Manifest3
-rw-r--r--games-board/chessproblem/chessproblem-1.6.ebuild (renamed from games-board/chessproblem/chessproblem-1.5.ebuild)3
-rw-r--r--games-board/chessproblem/chessproblem-2.0.ebuild40
-rw-r--r--games-board/chessproblem/metadata.xml1
-rw-r--r--profiles/use.local.desc1
5 files changed, 46 insertions, 2 deletions
diff --git a/games-board/chessproblem/Manifest b/games-board/chessproblem/Manifest
index 8fd6c4fd..cee12872 100644
--- a/games-board/chessproblem/Manifest
+++ b/games-board/chessproblem/Manifest
@@ -1 +1,2 @@
-DIST chessproblem-1.5.tar.gz 38411 SHA256 cd8084921a5af33e532c512c801360fda368b3aa2d1f993c9895562c1d1d30cc
+DIST chessproblem-1.6.tar.gz 38634 SHA256 ac18c46754b0bc2af97ee42d94dbae5efb427f540efd04120c9858120ec9f97c
+DIST chessproblem-2.0.tar.gz 42361 SHA256 e8bf5b2088925abdc52543ee6d5cf9178ca232183e4ae388fa321774ce68212f
diff --git a/games-board/chessproblem/chessproblem-1.5.ebuild b/games-board/chessproblem/chessproblem-1.6.ebuild
index be265981..11390471 100644
--- a/games-board/chessproblem/chessproblem-1.5.ebuild
+++ b/games-board/chessproblem/chessproblem-1.6.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://github.com/vaeth/chessproblem/"
SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="nothreads"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
IUSE="debug optimization strong-optimization"
@@ -33,6 +33,7 @@ src_configure() {
src_install() {
default
+ mv -- "${ED}/usr/bin/chessproblem"{,-nothreads}
exeinto "/usr/share/doc/${PF}/"
doexe contrib/test.pl
docompress -x "/usr/share/doc/${PF}/test.pl"
diff --git a/games-board/chessproblem/chessproblem-2.0.ebuild b/games-board/chessproblem/chessproblem-2.0.ebuild
new file mode 100644
index 00000000..2c04c745
--- /dev/null
+++ b/games-board/chessproblem/chessproblem-2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+WANT_LIBTOOL=none
+AT_NOELIBTOOLIZE=yes
+inherit autotools vcs-snapshot
+
+DESCRIPTION="Find solutions of chess problems (mate, selfmate, and helpmate) with cooks"
+HOMEPAGE="https://github.com/vaeth/chessproblem/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="debug +multithreading optimization strong-optimization"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- contrib/test.pl || die
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with multithreading) \
+ $(use_enable debug debugging) \
+ $(use_enable optimization) \
+ $(use_enable strong-optimization)
+}
+
+src_install() {
+ default
+ exeinto "/usr/share/doc/${PF}/"
+ doexe contrib/test.pl
+ docompress -x "/usr/share/doc/${PF}/test.pl"
+}
diff --git a/games-board/chessproblem/metadata.xml b/games-board/chessproblem/metadata.xml
index 0a1f21fc..bfe1a9b8 100644
--- a/games-board/chessproblem/metadata.xml
+++ b/games-board/chessproblem/metadata.xml
@@ -15,6 +15,7 @@
</upstream>
<use>
<flag name="debug">Build with upstream's CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.</flag>
+ <flag name="multithreading">Install multithreading version</flag>
<flag name="optimization">Accept upstream's choices for CXXFLAGS/LDFLAGS for optimization. Absense of this USE flag does not strip user's *FLAGS</flag>
<flag name="strong-optimization">Adds several more agressive CXXFLAGS/LDFLAGS for optimization like graphite (if available). May cause trouble with some buggy compiler versions. Absense of this USE flag does not strip user's *FLAGS</flag>
</use>
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 5c1b26fe..a8e7e23f 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -154,6 +154,7 @@ app-text/stardict:wordnet - Enable wordnet plugin to find similar English words
app-text/stardict:xdxfparse - Enable plugin to parse dictionaries in xdxf (XML Dictionary eXchange Format)
app-text/stardict:youdaodict - Enable youdao.com network plugin (for Chinese language)
games-board/chessproblem:debug - Build with upstream's CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.
+games-board/chessproblem:multithreading - Install multithreading version
games-board/chessproblem:optimization - Accept upstream's choices for CXXFLAGS/LDFLAGS for optimization. Absense of this USE flag does not strip user's *FLAGS
games-board/chessproblem:strong-optimization - Adds several more agressive CXXFLAGS/LDFLAGS for optimization like graphite (if available). May cause trouble with some buggy compiler versions. Absense of this USE flag does not strip user's *FLAGS
games-emulation/xmame:bundled-libs - Use bundled version of dev-libs/expat