summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-05-14 18:59:46 +0200
committerMartin Väth <martin@mvath.de>2017-05-14 18:59:46 +0200
commitb50b6f2017e1dbbca02105f9f1608e937d9c204a (patch)
treeae50d6588b805d9a1f68e8cc57fa35365f0bdd22
parentx11-themes/fvwm-crystal: Remove since it is main gentoo repository (diff)
downloadmv-b50b6f2017e1dbbca02105f9f1608e937d9c204a.tar.gz
mv-b50b6f2017e1dbbca02105f9f1608e937d9c204a.tar.bz2
mv-b50b6f2017e1dbbca02105f9f1608e937d9c204a.zip
games-action/gltron: Remove since fix is now in the gentoo repository
-rw-r--r--games-action/gltron/Manifest2
-rw-r--r--games-action/gltron/files/gltron-0.70-configure.patch24
-rw-r--r--games-action/gltron/files/gltron-0.70-debian.patch35
-rw-r--r--games-action/gltron/files/gltron-0.70-gcc49.patch13
-rw-r--r--games-action/gltron/files/gltron-0.70-prototypes.patch24
-rw-r--r--games-action/gltron/gltron-0.70-r1.ebuild55
-rw-r--r--games-action/gltron/metadata.xml11
7 files changed, 0 insertions, 164 deletions
diff --git a/games-action/gltron/Manifest b/games-action/gltron/Manifest
deleted file mode 100644
index 6865d017..00000000
--- a/games-action/gltron/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST gltron-0.70-source.tar.gz 2182440 SHA256 e0c8ebb41a18a1f8d7302a9c2cb466f5b1dd63e9a9966c769075e6b6bdad8bb0
-DIST gltron.png 7570 SHA256 1f7262feb4f3bdff36573fe51dedd93905feb2ec9a54a3f8ec0a964489c40abd
diff --git a/games-action/gltron/files/gltron-0.70-configure.patch b/games-action/gltron/files/gltron-0.70-configure.patch
deleted file mode 100644
index 91414b39..00000000
--- a/games-action/gltron/files/gltron-0.70-configure.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-configure.in is written poorly so it just stomps all over CFLAGS
-
---- configure
-+++ configure
-@@ -2805,7 +2805,7 @@
- RANLIB="$ac_cv_prog_RANLIB"
- fi
-
--CFLAGS="-DSEPARATOR=\"'/'\""
-+CFLAGS="$CFLAGS -DSEPARATOR=\"'/'\""
-
- # Check whether --enable-warn or --disable-warn was given.
- if test "${enable_warn+set}" = set; then
-@@ -2852,10 +2852,6 @@
- else
- enable_optimize=s
- fi;
--if test "x$enable_optimize" ; then
-- CFLAGS="$CFLAGS -O$enable_optimize"
-- CXXFLAGS="$CXXFLAGS -O$enable_optimize"
--fi
-
- # Check whether --with-sdl-prefix or --without-sdl-prefix was given.
- if test "${with_sdl_prefix+set}" = set; then
diff --git a/games-action/gltron/files/gltron-0.70-debian.patch b/games-action/gltron/files/gltron-0.70-debian.patch
deleted file mode 100644
index 464cf592..00000000
--- a/games-action/gltron/files/gltron-0.70-debian.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Ripped from Debian patchset 6
-
---- src/include/game/game_data.h
-+++ src/include/game/game_data.h
-@@ -71,7 +71,7 @@
- typedef struct AI {
- int active;
- int tdiff;
-- long lasttime;
-+ unsigned int lasttime;
- segment2 left, right, front, backleft;
- } AI;
-
---- src/include/video/fonttex.h
-+++ src/include/video/fonttex.h
-@@ -10,7 +10,7 @@
- int lower; /* lowest ascii character (normally: 32) */
- int upper; /* highest ascii character (normally: 126) */
-
-- int *texID;
-+ unsigned int *texID;
-
- char *fontname;
- char *bitmapname;
---- src/video/trail.c
-+++ src/video/trail.c
-@@ -19,7 +19,7 @@
- n[1] = s->vStart.v[1] - s->vDirection.v[0];
- tmp[0] = eye[0] - s->vStart.v[0];
- tmp[1] = eye[1] - s->vStart.v[1];
-- if(n[0] == n[1] == 0) return length(tmp);
-+ if(n[0] == 0 && n[1] == 0) return length(tmp);
- return abs(scalarprod2(n, tmp) / length(n));
- }
-
diff --git a/games-action/gltron/files/gltron-0.70-gcc49.patch b/games-action/gltron/files/gltron-0.70-gcc49.patch
deleted file mode 100644
index 4a1d5cbe..00000000
--- a/games-action/gltron/files/gltron-0.70-gcc49.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- 1/lua/src/lib/liolib.c
-+++ 1/lua/src/lib/liolib.c
-@@ -6,9 +6,9 @@
- */
-
-
-+#define __USE_MISC /* for mkstemp() */
- #include <ctype.h>
- #include <stdio.h>
--#define __USE_MISC /* for mkstemp() */
- #include <stdlib.h>
- #include <string.h>
- #include <time.h>
diff --git a/games-action/gltron/files/gltron-0.70-prototypes.patch b/games-action/gltron/files/gltron-0.70-prototypes.patch
deleted file mode 100644
index d697f1ad..00000000
--- a/games-action/gltron/files/gltron-0.70-prototypes.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-scripting.h declares these params as const so make sure they're the same.
-
---- nebu/scripting/scripting.c
-+++ nebu/scripting/scripting.c
-@@ -169,16 +169,16 @@
- return status;
- }
-
--void scripting_RunFile(char *name) {
-+void scripting_RunFile(const char *name) {
- lua_dofile(L, name);
- }
-
--void scripting_Run(char *command) {
-+void scripting_Run(const char *command) {
- /* fprintf(stderr, "[command] %s\n", command); */
- lua_dostring(L, command);
- }
-
--void scripting_RunFormat(char *format, ... ) {
-+void scripting_RunFormat(const char *format, ... ) {
- char buf[4096];
- va_list ap;
- va_start(ap, format);
diff --git a/games-action/gltron/gltron-0.70-r1.ebuild b/games-action/gltron/gltron-0.70-r1.ebuild
deleted file mode 100644
index 5aa79fe1..00000000
--- a/games-action/gltron/gltron-0.70-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools eutils
-
-DESCRIPTION="3d tron, just like the movie"
-HOMEPAGE="http://gltron.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz
- mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="virtual/opengl
- media-libs/libpng:0
- media-libs/libsdl[sound,video]
- media-libs/sdl-mixer[vorbis]
- media-libs/sdl-sound[vorbis,mikmod]
- media-libs/smpeg
- media-libs/libmikmod"
-RDEPEND=${DEPEND}
-
-src_prepare() {
- eapply -p0 "${FILESDIR}"/${P}-configure.patch
- eapply -p0 "${FILESDIR}"/${P}-prototypes.patch
- eapply -p0 "${FILESDIR}"/${P}-debian.patch
- eapply "${FILESDIR}"/${P}-gcc49.patch
- sed -i \
- -e '/^gltron_LINK/s/$/ $(LDFLAGS)/' \
- Makefile.in || die
- mv configure.in configure.ac || die
- sed -i -e 's/ #/#/' "${S}/nebu/scripting/Makefile.am" || die
- eapply_user
- eautoreconf
-}
-
-src_configure() {
- # warn/debug/profile just modify CFLAGS, they aren't
- # real options, so don't utilize USE flags here
- econf \
- --datadir=/usr/share/games \
- --datarootdir=/usr/share \
- --disable-warn \
- --disable-debug \
- --disable-profile
-}
-
-src_install() {
- default
- doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry ${PN} GLtron
-}
diff --git a/games-action/gltron/metadata.xml b/games-action/gltron/metadata.xml
deleted file mode 100644
index 06123063..00000000
--- a/games-action/gltron/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">gltron</remote-id>
- </upstream>
-</pkgmetadata>