summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-01-15 06:41:10 +0100
committerMartin Väth <martin@mvath.de>2022-01-15 06:41:10 +0100
commitb6672b84d90dddab08c1f9765edb1da9773a99db (patch)
treec1301edf79a8a113363f243a072e0f85a98cb5f4
parentapp-portage/eix sys-block/zram-init: Version bumps (diff)
downloadmv-b6672b84d90dddab08c1f9765edb1da9773a99db.tar.gz
mv-b6672b84d90dddab08c1f9765edb1da9773a99db.tar.bz2
mv-b6672b84d90dddab08c1f9765edb1da9773a99db.zip
app-portage/etcat: EAPI bump. Create missing stardict.eclass
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--app-portage/etcat/etcat-1.0.2.ebuild6
-rw-r--r--app-portage/etcat/etcat-99999999.ebuild6
-rw-r--r--eclass/stardict.eclass71
3 files changed, 77 insertions, 6 deletions
diff --git a/app-portage/etcat/etcat-1.0.2.ebuild b/app-portage/etcat/etcat-1.0.2.ebuild
index 36229c17..e89d69ac 100644
--- a/app-portage/etcat/etcat-1.0.2.ebuild
+++ b/app-portage/etcat/etcat-1.0.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2016-2021 Martin V\"ath
+# Copyright 2016-2022 Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{7,8,9,10} )
@@ -26,7 +26,7 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
-RDEPEND=$(python_gen_cond_dep 'app-portage/gentoolkit[${PYTHON_MULTI_USEDEP}]')
+RDEPEND=$(python_gen_cond_dep 'app-portage/gentoolkit[${PYTHON_USEDEP}]')
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_prepare() {
diff --git a/app-portage/etcat/etcat-99999999.ebuild b/app-portage/etcat/etcat-99999999.ebuild
index 36229c17..e89d69ac 100644
--- a/app-portage/etcat/etcat-99999999.ebuild
+++ b/app-portage/etcat/etcat-99999999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2016-2021 Martin V\"ath
+# Copyright 2016-2022 Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{7,8,9,10} )
@@ -26,7 +26,7 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
-RDEPEND=$(python_gen_cond_dep 'app-portage/gentoolkit[${PYTHON_MULTI_USEDEP}]')
+RDEPEND=$(python_gen_cond_dep 'app-portage/gentoolkit[${PYTHON_USEDEP}]')
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_prepare() {
diff --git a/eclass/stardict.eclass b/eclass/stardict.eclass
new file mode 100644
index 00000000..0967ad75
--- /dev/null
+++ b/eclass/stardict.eclass
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# @ECLASS: stardict.eclass
+# @MAINTAINER:
+# No maintainer <maintainer-needed@gentoo.org>
+# @AUTHOR:
+# Alastair Tse <liquidx@gentoo.org>
+# @BLURB: Convenience class to do stardict dictionary installations.
+# @DESCRIPTION:
+# Usage:
+# - Variables to set :
+# * FROM_LANG - From this language
+# * TO_LANG - To this language
+# * DICT_PREFIX - SRC_URI prefix, like "dictd_www.mova.org_"
+# * DICT_SUFFIX - SRC_URI after the prefix.
+
+EXPORT_FUNCTIONS src_compile src_install
+
+if [[ -z ${_STARDICT_ECLASS} ]] ; then
+_STARDICT_ECLASS=1
+
+RESTRICT="strip"
+
+[ -z "${DICT_SUFFIX}" ] && DICT_SUFFIX=${PN#stardict-[[:lower:]]*-}
+[ -z "${DICT_P}" ] && DICT_P=stardict-${DICT_PREFIX}${DICT_SUFFIX}-${PV}
+
+if [ -n "${FROM_LANG}" -a -n "${TO_LANG}" ]; then
+ DESCRIPTION="Stardict Dictionary ${FROM_LANG} to ${TO_LANG}"
+elif [ -z "${DESCRIPTION}" ]; then
+ DESCRIPTION="Another Stardict Dictionary"
+fi
+
+HOMEPAGE="http://stardict.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stardict/${DICT_P}.tar.bz2"
+S="${WORKDIR}"/${DICT_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+zlib"
+
+DEPEND="
+ || (
+ >=app-text/stardict-2.4.2
+ app-text/sdcv
+ app-text/goldendict
+ )
+ zlib? (
+ app-arch/gzip
+ app-text/dictd
+ )"
+
+stardict_src_compile() {
+ if use zlib; then
+ for file in *.idx; do
+ [[ -f $file ]] && gzip ${file}
+ done
+ for file in *.dict; do
+ [[ -f $file ]] && dictzip ${file}
+ done
+ fi
+}
+
+stardict_src_install() {
+ insinto /usr/share/stardict/dic
+ doins *.dict.dz*
+ doins *.idx*
+ doins *.ifo
+}
+
+fi