summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-08-30 16:17:10 +0200
committerMartin Väth <martin@mvath.de>2017-08-30 16:17:52 +0200
commiteec17460cc5a083a432eb5d42c70bba42c408685 (patch)
tree42e3e42c11d55c90b3d098a7fb3d161ad51c2395
parentapp-portage/eix: Alpha version bump (diff)
downloadmv-eec17460cc5a083a432eb5d42c70bba42c408685.tar.gz
mv-eec17460cc5a083a432eb5d42c70bba42c408685.tar.bz2
mv-eec17460cc5a083a432eb5d42c70bba42c408685.zip
app-shells/zsh: Remove since support in gentoo repository is good
-rw-r--r--app-shells/zsh/Manifest2
-rw-r--r--app-shells/zsh/files/prompt_gentoo_setup-133
-rw-r--r--app-shells/zsh/files/zprofile-241
-rw-r--r--app-shells/zsh/files/zsh-init.d-gentoo-r1.diff31
-rw-r--r--app-shells/zsh/metadata.xml34
-rw-r--r--app-shells/zsh/zsh-5.4.1.ebuild306
-rw-r--r--app-shells/zsh/zsh-99999999.ebuild306
-rw-r--r--metadata/pkg_desc_index1
-rw-r--r--profiles/use.local.desc13
9 files changed, 0 insertions, 767 deletions
diff --git a/app-shells/zsh/Manifest b/app-shells/zsh/Manifest
deleted file mode 100644
index 0b31a011..00000000
--- a/app-shells/zsh/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST zsh-5.4.1-doc.tar.xz 3197560 SHA256 b8b1a40aeec852806ad2b74b0a0c534320bf517e2fe2a087c0c9d39e75dc29f1
-DIST zsh-5.4.1.tar.xz 2972824 SHA256 94cbd57508287e8faa081424509738d496f5f41e32ed890e3a5498ce05d3633b
diff --git a/app-shells/zsh/files/prompt_gentoo_setup-1 b/app-shells/zsh/files/prompt_gentoo_setup-1
deleted file mode 100644
index 046e2d87..00000000
--- a/app-shells/zsh/files/prompt_gentoo_setup-1
+++ /dev/null
@@ -1,33 +0,0 @@
-# gentoo prompt theme
-
-prompt_gentoo_help () {
- cat <<'EOF'
-This prompt is color-scheme-able. You can invoke it thus:
-
- prompt gentoo [<promptcolor> [<usercolor> [<rootcolor>]]]
-
-EOF
-}
-
-prompt_gentoo_setup () {
- local prompt_gentoo_prompt=${1:-'blue'}
- local prompt_gentoo_user=${2:-'green'}
- local prompt_gentoo_root=${3:-'red'}
-
- if [ "$USER" = 'root' ]
- then
- local base_prompt="%B%F{$prompt_gentoo_root}%m%k "
- else
- local base_prompt="%B%F{$prompt_gentoo_user}%n@%m%k "
- fi
- local post_prompt="%b%f%k"
-
- #setopt noxtrace localoptions
-
- local path_prompt="%B%F{$prompt_gentoo_prompt}%1~"
- typeset -g PS1="$base_prompt$path_prompt %# $post_prompt"
- typeset -g PS2="$base_prompt$path_prompt %_> $post_prompt"
- typeset -g PS3="$base_prompt$path_prompt ?# $post_prompt"
-}
-
-prompt_gentoo_setup "$@"
diff --git a/app-shells/zsh/files/zprofile-2 b/app-shells/zsh/files/zprofile-2
deleted file mode 100644
index 9c4313c4..00000000
--- a/app-shells/zsh/files/zprofile-2
+++ /dev/null
@@ -1,41 +0,0 @@
-# @GENTOO_PORTAGE_EPREFIX@/etc/zsh/zprofile
-
-# Load environment settings from profile.env, which is created by
-# env-update from the files in /etc/env.d
-if [ -e "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.env ] ; then
- . "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.env
-fi
-
-# You should override these in your ~/.zprofile (or equivalent) for per-user
-# settings. For system defaults, you can add a new file in /etc/profile.d/.
-export EDITOR=${EDITOR:-/bin/nano}
-export PAGER=${PAGER:-/usr/bin/less}
-
-# 077 would be more secure, but 022 is generally quite realistic
-umask 022
-
-# Set up PATH depending on whether we're root or a normal user.
-# There's no real reason to exclude sbin paths from the normal user,
-# but it can make tab-completion easier when they aren't in the
-# user's PATH to pollute the executable namespace.
-#
-# It is intentional in the following line to use || instead of -o.
-# This way the evaluation can be short-circuited and calling whoami is
-# avoided.
-if [ "$EUID" = "0" ] || [ "$USER" = "root" ] ; then
- @ZSH_NOPREFIX@PATH="${ROOTPATH}"
- @ZSH_PREFIX@PATH="@GENTOO_PORTAGE_EPREFIX@/usr/sbin:@GENTOO_PORTAGE_EPREFIX@/usr/bin:@GENTOO_PORTAGE_EPREFIX@/sbin:@GENTOO_PORTAGE_EPREFIX@/bin:${ROOTPATH}:/usr/sbin:/usr/bin:/sbin:/bin"
-@ZSH_PREFIX@else
- @ZSH_PREFIX@PATH="@GENTOO_PORTAGE_EPREFIX@/usr/bin:@GENTOO_PORTAGE_EPREFIX@/bin:${PATH}:/usr/bin:/bin"
-fi
-export PATH
-unset ROOTPATH
-
-shopts=$-
-setopt nullglob
-for sh in "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.d/*.sh ; do
- [ -r "$sh" ] && . "$sh"
-done
-unsetopt nullglob
-set -$shopts
-unset sh shopts
diff --git a/app-shells/zsh/files/zsh-init.d-gentoo-r1.diff b/app-shells/zsh/files/zsh-init.d-gentoo-r1.diff
deleted file mode 100644
index 9deafd0d..00000000
--- a/app-shells/zsh/files/zsh-init.d-gentoo-r1.diff
+++ /dev/null
@@ -1,31 +0,0 @@
---- zsh-5.3/Completion/Unix/Command/_init_d
-+++ zsh-5.3/Completion/Unix/Command/_init_d
-@@ -1,6 +1,6 @@
- #compdef -p */(init|rc[0-9S]#).d/*
-
--local cmds script
-+local cmds script opts
- local -a flags
-
- _compskip=all
-@@ -102,10 +102,18 @@
-
- script=$words[1]
- [[ $script = */* ]] || script="$(_init_d_fullpath "$script")"
-+[[ ! -f $script ]] &&
-+ { _message "${words[1]:t} is not an init script" && return }
-+
-
- cmds=( $(_init_d_get_cmds) ) || return 1
-
--(( $#cmds )) || zstyle -a ":completion:${curcontext}:commands" commands cmds ||
-- cmds=(start stop)
-+(( $#cmds )) || zstyle -a ":completion:${curcontext}:commands" commands cmds
-+opts=(start stop restart pause zap status ineed iuse needsme usesme broken)
-+
-+# If we didn't get $cmds from a zstyle, then read init script for opts.
-+# If script doesn't specify opts, then default to the standard opts.
-+(( $#cmds )) || cmds=( ${(eQz)${(M)${(f)"$( <$script)"}:#[[:blank:]]#opts=*}#*=} )
-+(( $#cmds )) || cmds=($opts)
-
- _arguments -s -A "-*" $flags ':init.d command:_sub_commands $cmds'
diff --git a/app-shells/zsh/metadata.xml b/app-shells/zsh/metadata.xml
deleted file mode 100644
index fb14f11a..00000000
--- a/app-shells/zsh/metadata.xml
+++ /dev/null
@@ -1,34 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- <description>maintainer of the updates in the mv overlay</description>
- </maintainer>
- <maintainer type="person">
- <email>radhermit@gentoo.org</email>
- <name>Tim Harder</name>
- </maintainer>
- <longdescription>
- Zsh is a shell designed for interactive use, although it is also a
- powerful scripting language. Many of the useful features of bash, ksh,
- and tcsh were incorporated into zsh; many original features were
- added.
-</longdescription>
- <use>
- <flag name="compile">Byte-compile. This costs disk space and may make things faster or slower. Do not use this if you are cross-compiling</flag>
- <flag name="completion_AIX">Install zsh completions for AIX</flag>
- <flag name="completion_BSD">Install zsh completions for BSD</flag>
- <flag name="completion_Cygwin">Install zsh completions for Cygwin</flag>
- <flag name="completion_Darwin">Install zsh completions for Darwin</flag>
- <flag name="completion_Debian">Install zsh completions for Debian</flag>
- <flag name="completion_Linux">Install zsh completions for Linux</flag>
- <flag name="completion_Mandriva">Install zsh completions for Mandriva</flag>
- <flag name="completion_openSUSE">Install zsh completions for openSUSE</flag>
- <flag name="completion_Redhat">Install zsh completions for Redhat</flag>
- <flag name="completion_Solaris">Install zsh completions for Solaris</flag>
- <flag name="completion_Unix">Install zsh completions for Unix</flag>
- <flag name="completion_X">Install zsh completions for X</flag>
-</use>
-</pkgmetadata>
diff --git a/app-shells/zsh/zsh-5.4.1.ebuild b/app-shells/zsh/zsh-5.4.1.ebuild
deleted file mode 100644
index 6e496f0f..00000000
--- a/app-shells/zsh/zsh-5.4.1.ebuild
+++ /dev/null
@@ -1,306 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic prefix readme.gentoo-r1
-
-MY_PV=${PV/_p/-dev-}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-zsh_ftp="http://www.zsh.org/pub"
-
-ZSH_URI="${zsh_ftp}/${PN}-${MY_PV}.tar.xz"
-ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.xz"
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-case ${PV} in
-9999*)
- SRC_URI=""
- EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
- inherit git-r3
- WANT_LIBTOOL="none"
- inherit autotools
- KEYWORDS=""
-# Creating help files needs util-linux for colcrt.
-# Please let me know if you have an arch where "colcrt" (or at least "col")
-# is provided by a different package.
- DEPEND="app-text/yodl
- dev-lang/perl
- sys-apps/man
- sys-apps/util-linux
- doc? (
- sys-apps/texinfo
- app-text/texi2html
- virtual/latex-base
- )"
- PROPERTIES="live"
- LIVE=:;;
-*)
- SRC_URI="${ZSH_URI}
- doc? ( ${ZSH_DOC_URI} )"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- #KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ~ppc64 ~s390 ~sh sparc x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- DEPEND=""
- LIVE=false;;
-esac
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-IUSE="caps compile"
-COMPLETIONS="AIX BSD Cygwin Darwin Debian +Linux Mandriva openSUSE Redhat Solaris +Unix +X"
-for curr in ${COMPLETIONS}
-do case ${curr} in
- [+-]*)
- IUSE+=" ${curr%%[!+-]*}completion_${curr#?}"
- continue;;
- esac
- IUSE+=" completion_${curr}"
-done
-IUSE+=" debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
- >=sys-libs/ncurses-5.1:0=
- static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
- caps? ( sys-libs/libcap )
- pcre? (
- >=dev-libs/libpcre-3.9
- static? ( >=dev-libs/libpcre-3.9[static-libs] )
- )
- gdbm? ( sys-libs/gdbm )
- !<sys-apps/baselayout-2.4.1
-"
-DEPEND+="
- sys-apps/groff
- ${RDEPEND}"
-PDEPEND="
- examples? ( app-doc/zsh-lovers )
-"
-
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="
-If you want to enable Portage completions and Gentoo prompt,
-emerge app-shells/gentoo-zsh-completion and add
- autoload -U compinit promptinit
- compinit
- promptinit; prompt gentoo
-to your ~/.zshrc
-
-Also, if you want to enable cache for the completions, add
- zstyle ':completion::complete:*' use-cache 1
-to your ~/.zshrc
-
-If you want to use run-help add to your ~/.zshrc
- unalias run-help
- autoload -Uz run-help
-
-Note that a system zprofile startup file is installed. This will override
-PATH and possibly other variables that a user may set in ~/.zshenv.
-Custom PATH settings and similar overridden variables can be moved
-to ~/.zprofile or other user startup files that are sourced after the
-system zprofile.
-
-If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,
-one method is to use a separate path-setting file that is conditionally sourced
-in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the
-zshenv example in "${EROOT}"/usr/share/doc/${PF}/StartupFiles/.
-
-See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation.
-"
-
-fix_soelim() {
- # fix zshall problem with soelim
- ln -s Doc man1 || die
- mv Doc/zshall.1 Doc/zshall.1.soelim || die
- soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
-}
-
-src_prepare() {
- ${LIVE} || fix_soelim
-
- ${LIVE} || eapply "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
-
- cp "${FILESDIR}"/zprofile-2 "${T}"/zprofile || die
- eprefixify "${T}"/zprofile || die
- if use prefix ; then
- sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
- else
- sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
- fi
- set --
- file='Src/Zle/complete.mdd'
- for i in ${COMPLETIONS}
- do case ${i} in
- [+-]*)
- i=${i#?};;
- esac
- grep -q "Completion\/${i}" -- "${S}/${file}" \
- || die "${file} does not contain Completion/${i}"
- use completion_${i} || set -- "${@}" -e "s/Completion\/${i}[^ ']*//"
- done
- [ ${#} -eq 0 ] || sed -i "${@}" -- "${S}/${file}" \
- || die "patching ${file} failed"
- eapply_user
- ! ${LIVE} || eautoreconf
- PVPATH=$(. "${S}"/Config/version.mk && printf '%s' "${VERSION}") && \
- [ -n "${PVPATH}" ] || PVPATH=${PV}
-}
-
-src_configure() {
- local myconf
- myconf=()
-
- if use static ; then
- myconf+=( --disable-dynamic )
- append-ldflags -static
- fi
- if use debug ; then
- myconf+=(
- --enable-zsh-debug
- --enable-zsh-mem-debug
- --enable-zsh-mem-warning
- --enable-zsh-secure-free
- --enable-zsh-hash-debug
- )
- fi
-
- if [[ ${CHOST} == *-darwin* ]]; then
- myconf+=( --enable-libs=-liconv )
- append-ldflags -Wl,-x
- fi
-
- econf \
- --bindir="${EPREFIX}"/bin \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --enable-etcdir="${EPREFIX}"/etc/zsh \
- --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/"${PVPATH}"/help \
- --enable-fndir="${EPREFIX}"/usr/share/zsh/"${PVPATH}"/functions \
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --with-tcsetpgrp \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps cap) \
- $(use_enable unicode multibyte) \
- $(use_enable gdbm ) \
- "${myconf[@]}"
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- # removed cap and curses because linking failes
- sed -e "s,link=no,link=static,g" \
- -e "/^name=zsh\/cap/s,link=static,link=no," \
- -e "/^name=zsh\/curses/s,link=static,link=no," \
- -i "${S}"/config.modules || die
- if ! use gdbm ; then
- sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
- "${S}"/config.modules || die
- fi
- fi
-}
-
-src_compile() {
- default
- ! ${LIVE} || ! use doc || emake -C Doc everything
- ! ${LIVE} || fix_soelim
-}
-
-src_test() {
- addpredict /dev/ptmx
- local i
- for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
- done
- emake check
-}
-
-zcompile_dirs() {
- use compile || return 0
- einfo "compiling modules"
- local i
- i="${S}/Src/zshpaths.h"
- test -f "${i}" || die "cannot find ${i}"
- # We need this directory also in pkg_postinst
- FPATH_DIR="$(sed -n -e \
- 's/^#define FPATH_DIR .*\"\(.*\)\".*$/\1/p' -- "${i}" 2>/dev/null)" \
- || FPATH_DIR=
- [ -n "${FPATH_DIR}" ] || die "cannot parse ${i}"
- pushd -- "${ED}" >/dev/null || die
- test -d ".${FPATH_DIR}" || die "parsing ${i} gave strange result ${FPATH_DIR}"
- find ".${FPATH_DIR}" -type d -exec "${ED}bin/zsh" -fc 'setopt nullglob
-for i
-do a=(${i}/*(.))
- [[ ${#a} -eq 0 ]] && continue
- echo "Compiling ${i#.}.zwc"
- zcompile -U -M ${i}.zwc ${a} || exit
-done' zsh '{}' '+' || die 'compiling failed. If you are cross-compiling set USE=-compile'
- popd >/dev/null
-}
-
-touch_zwc() {
- use compile || return 0
- einfo "touching *.zwc files"
- # Make a sanity check that variables are preserved after zcompile_dirs:
- # If the package mangler is not faulty, this *must* succeeed.
- [ -n "${FPATH_DIR}" ] && test -d "${FPATH_DIR}" || die "strange FPATH_DIR"
- # Now the actual action
- find "${EPREFIX}${FPATH_DIR}" -type f -name '*.zwc' \
- -exec "$(command -v touch)" -- '{}' '+'
-}
-
-src_install() {
- # install.info needs texinfo unless the doc tarball is available
- emake DESTDIR="${ED}" install $(usex doc "install.info" "")
-
- insinto /etc/zsh
- doins "${T}"/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/"${PVPATH}"/functions/Prompts
- newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
- local i
-
- # install miscellaneous scripts (bug #54520)
- sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
- -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
- -i "${S}"/{Util,Misc}/* || die
- for i in Util Misc ; do
- insinto /usr/share/zsh/"${PVPATH}"/${i}
- doins ${i}/*
- done
-
- # install header files (bug #538684)
- insinto /usr/include/zsh
- doins config.h Src/*.epro
- for i in Src/{zsh.mdh,*.h} ; do
- sed -e 's@\.\./config\.h@config.h@' \
- -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
- -i "${i}"
- doins "${i}"
- done
-
- dodoc ChangeLog* META-FAQ NEWS README config.modules
- readme.gentoo_create_doc
-
- if use doc ; then
- pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
- dodoc Doc/zsh.{dvi,pdf}
- docinto html
- dodoc Doc/*.html
- popd >/dev/null
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-
- zcompile_dirs
-
- rm -vf -- "${ED}"/bin/zsh?*
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
- touch_zwc
-}
diff --git a/app-shells/zsh/zsh-99999999.ebuild b/app-shells/zsh/zsh-99999999.ebuild
deleted file mode 100644
index 6e496f0f..00000000
--- a/app-shells/zsh/zsh-99999999.ebuild
+++ /dev/null
@@ -1,306 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic prefix readme.gentoo-r1
-
-MY_PV=${PV/_p/-dev-}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-zsh_ftp="http://www.zsh.org/pub"
-
-ZSH_URI="${zsh_ftp}/${PN}-${MY_PV}.tar.xz"
-ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.xz"
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-case ${PV} in
-9999*)
- SRC_URI=""
- EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
- inherit git-r3
- WANT_LIBTOOL="none"
- inherit autotools
- KEYWORDS=""
-# Creating help files needs util-linux for colcrt.
-# Please let me know if you have an arch where "colcrt" (or at least "col")
-# is provided by a different package.
- DEPEND="app-text/yodl
- dev-lang/perl
- sys-apps/man
- sys-apps/util-linux
- doc? (
- sys-apps/texinfo
- app-text/texi2html
- virtual/latex-base
- )"
- PROPERTIES="live"
- LIVE=:;;
-*)
- SRC_URI="${ZSH_URI}
- doc? ( ${ZSH_DOC_URI} )"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- #KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ~ppc64 ~s390 ~sh sparc x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- DEPEND=""
- LIVE=false;;
-esac
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-IUSE="caps compile"
-COMPLETIONS="AIX BSD Cygwin Darwin Debian +Linux Mandriva openSUSE Redhat Solaris +Unix +X"
-for curr in ${COMPLETIONS}
-do case ${curr} in
- [+-]*)
- IUSE+=" ${curr%%[!+-]*}completion_${curr#?}"
- continue;;
- esac
- IUSE+=" completion_${curr}"
-done
-IUSE+=" debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
- >=sys-libs/ncurses-5.1:0=
- static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
- caps? ( sys-libs/libcap )
- pcre? (
- >=dev-libs/libpcre-3.9
- static? ( >=dev-libs/libpcre-3.9[static-libs] )
- )
- gdbm? ( sys-libs/gdbm )
- !<sys-apps/baselayout-2.4.1
-"
-DEPEND+="
- sys-apps/groff
- ${RDEPEND}"
-PDEPEND="
- examples? ( app-doc/zsh-lovers )
-"
-
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="
-If you want to enable Portage completions and Gentoo prompt,
-emerge app-shells/gentoo-zsh-completion and add
- autoload -U compinit promptinit
- compinit
- promptinit; prompt gentoo
-to your ~/.zshrc
-
-Also, if you want to enable cache for the completions, add
- zstyle ':completion::complete:*' use-cache 1
-to your ~/.zshrc
-
-If you want to use run-help add to your ~/.zshrc
- unalias run-help
- autoload -Uz run-help
-
-Note that a system zprofile startup file is installed. This will override
-PATH and possibly other variables that a user may set in ~/.zshenv.
-Custom PATH settings and similar overridden variables can be moved
-to ~/.zprofile or other user startup files that are sourced after the
-system zprofile.
-
-If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,
-one method is to use a separate path-setting file that is conditionally sourced
-in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the
-zshenv example in "${EROOT}"/usr/share/doc/${PF}/StartupFiles/.
-
-See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation.
-"
-
-fix_soelim() {
- # fix zshall problem with soelim
- ln -s Doc man1 || die
- mv Doc/zshall.1 Doc/zshall.1.soelim || die
- soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
-}
-
-src_prepare() {
- ${LIVE} || fix_soelim
-
- ${LIVE} || eapply "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
-
- cp "${FILESDIR}"/zprofile-2 "${T}"/zprofile || die
- eprefixify "${T}"/zprofile || die
- if use prefix ; then
- sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
- else
- sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
- fi
- set --
- file='Src/Zle/complete.mdd'
- for i in ${COMPLETIONS}
- do case ${i} in
- [+-]*)
- i=${i#?};;
- esac
- grep -q "Completion\/${i}" -- "${S}/${file}" \
- || die "${file} does not contain Completion/${i}"
- use completion_${i} || set -- "${@}" -e "s/Completion\/${i}[^ ']*//"
- done
- [ ${#} -eq 0 ] || sed -i "${@}" -- "${S}/${file}" \
- || die "patching ${file} failed"
- eapply_user
- ! ${LIVE} || eautoreconf
- PVPATH=$(. "${S}"/Config/version.mk && printf '%s' "${VERSION}") && \
- [ -n "${PVPATH}" ] || PVPATH=${PV}
-}
-
-src_configure() {
- local myconf
- myconf=()
-
- if use static ; then
- myconf+=( --disable-dynamic )
- append-ldflags -static
- fi
- if use debug ; then
- myconf+=(
- --enable-zsh-debug
- --enable-zsh-mem-debug
- --enable-zsh-mem-warning
- --enable-zsh-secure-free
- --enable-zsh-hash-debug
- )
- fi
-
- if [[ ${CHOST} == *-darwin* ]]; then
- myconf+=( --enable-libs=-liconv )
- append-ldflags -Wl,-x
- fi
-
- econf \
- --bindir="${EPREFIX}"/bin \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --enable-etcdir="${EPREFIX}"/etc/zsh \
- --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/"${PVPATH}"/help \
- --enable-fndir="${EPREFIX}"/usr/share/zsh/"${PVPATH}"/functions \
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --with-tcsetpgrp \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps cap) \
- $(use_enable unicode multibyte) \
- $(use_enable gdbm ) \
- "${myconf[@]}"
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- # removed cap and curses because linking failes
- sed -e "s,link=no,link=static,g" \
- -e "/^name=zsh\/cap/s,link=static,link=no," \
- -e "/^name=zsh\/curses/s,link=static,link=no," \
- -i "${S}"/config.modules || die
- if ! use gdbm ; then
- sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
- "${S}"/config.modules || die
- fi
- fi
-}
-
-src_compile() {
- default
- ! ${LIVE} || ! use doc || emake -C Doc everything
- ! ${LIVE} || fix_soelim
-}
-
-src_test() {
- addpredict /dev/ptmx
- local i
- for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
- done
- emake check
-}
-
-zcompile_dirs() {
- use compile || return 0
- einfo "compiling modules"
- local i
- i="${S}/Src/zshpaths.h"
- test -f "${i}" || die "cannot find ${i}"
- # We need this directory also in pkg_postinst
- FPATH_DIR="$(sed -n -e \
- 's/^#define FPATH_DIR .*\"\(.*\)\".*$/\1/p' -- "${i}" 2>/dev/null)" \
- || FPATH_DIR=
- [ -n "${FPATH_DIR}" ] || die "cannot parse ${i}"
- pushd -- "${ED}" >/dev/null || die
- test -d ".${FPATH_DIR}" || die "parsing ${i} gave strange result ${FPATH_DIR}"
- find ".${FPATH_DIR}" -type d -exec "${ED}bin/zsh" -fc 'setopt nullglob
-for i
-do a=(${i}/*(.))
- [[ ${#a} -eq 0 ]] && continue
- echo "Compiling ${i#.}.zwc"
- zcompile -U -M ${i}.zwc ${a} || exit
-done' zsh '{}' '+' || die 'compiling failed. If you are cross-compiling set USE=-compile'
- popd >/dev/null
-}
-
-touch_zwc() {
- use compile || return 0
- einfo "touching *.zwc files"
- # Make a sanity check that variables are preserved after zcompile_dirs:
- # If the package mangler is not faulty, this *must* succeeed.
- [ -n "${FPATH_DIR}" ] && test -d "${FPATH_DIR}" || die "strange FPATH_DIR"
- # Now the actual action
- find "${EPREFIX}${FPATH_DIR}" -type f -name '*.zwc' \
- -exec "$(command -v touch)" -- '{}' '+'
-}
-
-src_install() {
- # install.info needs texinfo unless the doc tarball is available
- emake DESTDIR="${ED}" install $(usex doc "install.info" "")
-
- insinto /etc/zsh
- doins "${T}"/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/"${PVPATH}"/functions/Prompts
- newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
- local i
-
- # install miscellaneous scripts (bug #54520)
- sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
- -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
- -i "${S}"/{Util,Misc}/* || die
- for i in Util Misc ; do
- insinto /usr/share/zsh/"${PVPATH}"/${i}
- doins ${i}/*
- done
-
- # install header files (bug #538684)
- insinto /usr/include/zsh
- doins config.h Src/*.epro
- for i in Src/{zsh.mdh,*.h} ; do
- sed -e 's@\.\./config\.h@config.h@' \
- -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
- -i "${i}"
- doins "${i}"
- done
-
- dodoc ChangeLog* META-FAQ NEWS README config.modules
- readme.gentoo_create_doc
-
- if use doc ; then
- pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
- dodoc Doc/zsh.{dvi,pdf}
- docinto html
- dodoc Doc/*.html
- popd >/dev/null
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-
- zcompile_dirs
-
- rm -vf -- "${ED}"/bin/zsh?*
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
- touch_zwc
-}
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 9d052a5c..64c0e66e 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -44,7 +44,6 @@ app-shells/runtitle 2.10: Scripts to run commands and set the hard status line (
app-shells/schily-tools 2017.08.14-r1: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
app-shells/set_prompt 3.0.0: An intelligent prompt for zsh or bash with status line (window title) support
app-shells/termcolors-mv 4.2: 256colors sample script and dircolors configuration for standard or 256 colors
-app-shells/zsh 5.4.1 99999999: UNIX Shell similar to the Korn shell
app-shells/zsh-completions 0.26.0 99999999: Additional completion definitions for Zsh
app-shells/zsh-syntax-highlighting 0.6.0_rc1 99999999: Fish shell like syntax highlighting for zsh
app-shells/zshrc-mv 3.10: A zshrc file initializing zsh specific interactive features
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 896cb475..3a39b914 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -58,19 +58,6 @@ app-shells/schily-tools:system-libschily - Rely on app-cdr/cdrtools for providin
app-shells/schily-tools:system-star - Rely on app-arch/star for the match manpage
app-shells/termcolors-mv:create - Install DIR_COLORS-create perl script
app-shells/termcolors-mv:perl - Install 256colors perl script
-app-shells/zsh:compile - Byte-compile. This costs disk space and may make things faster or slower. Do not use this if you are cross-compiling
-app-shells/zsh:completion_AIX - Install zsh completions for AIX
-app-shells/zsh:completion_BSD - Install zsh completions for BSD
-app-shells/zsh:completion_Cygwin - Install zsh completions for Cygwin
-app-shells/zsh:completion_Darwin - Install zsh completions for Darwin
-app-shells/zsh:completion_Debian - Install zsh completions for Debian
-app-shells/zsh:completion_Linux - Install zsh completions for Linux
-app-shells/zsh:completion_Mandriva - Install zsh completions for Mandriva
-app-shells/zsh:completion_Redhat - Install zsh completions for Redhat
-app-shells/zsh:completion_Solaris - Install zsh completions for Solaris
-app-shells/zsh:completion_Unix - Install zsh completions for Unix
-app-shells/zsh:completion_X - Install zsh completions for X
-app-shells/zsh:completion_openSUSE - Install zsh completions for openSUSE
app-shells/zsh-completions:completion_Android - Install zsh completions for Android-related programs
app-shells/zsh-completions:completion_Arch - Install zsh completions for Archlinux
app-shells/zsh-completions:completion_Google - Install zsh completions for Google tools